OVH Community, votre nouvel espace communautaire.

Vps Cloud, Mod Deflate


jidane
16/11/2014, 01h59
Citation Envoyé par gaboul49
En fait c'est con mais c'était marqué dans ton premier post dans la réponse du serveur "Server:nginx". Tout le monde était passé à coté.
Du coup quelqu'un a trouvé la solution pour du apache ??

thx

gaboul49
09/07/2014, 06h36
En fait c'est con mais c'était marqué dans ton premier post dans la réponse du serveur "Server:nginx". Tout le monde était passé à coté.

adilis
08/07/2014, 19h41
Citation Envoyé par thekamaster
Tu parles de nginx maintenant ? (parce que le .htaccess, c'est uniquement pour apache, tout comme le httpd.conf avant)
Beh vi, je sais pas trop ce que j'ai commandé chez ovh moi :/
J'ai Plesk 12 et dans la config serveur je peux mettre des directives htaccess ( apaches ) et nginx :s
Je suis perdu lol

thekamaster
08/07/2014, 17h33
Tu parles de nginx maintenant ? (parce que le .htaccess, c'est uniquement pour apache, tout comme le httpd.conf avant)

adilis
08/07/2014, 10h51
Ah beh voila
En cherchant sur le net, j'ai trouvé, je suis pas doué en gestion de serveur. Mais en ajoutant dans les directives supplémentaire Nginx =
Code:
gzip on;
gzip_disable "MSIE [1-6]\.(?!.*SV1)";

gzip_types text/plain [s]text/html[/s] text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript application/javascript text/x-js;
Cela fonctionne.

adilis
08/07/2014, 10h43
Citation Envoyé par gaboul49
As-tu un seul site sur ton serveur ou utilises-tu des VirtualHost ?
Un seul site, par contre je n'ai jamais eu ce genre de soucis. C'est la premiere fois que j'ai cette problématique. je pense que Plesk 12 gère la chose différement.

gaboul49
08/07/2014, 10h27
As-tu un seul site sur ton serveur ou utilises-tu des VirtualHost ?

adilis
08/07/2014, 10h22
Citation Envoyé par gaboul49
Il faut que tu fonctionnes pas à pas, sans faire de copier coller dans tout les sens.

AllowOverride d'ajouter à un endroit précis du fichier, il faut que tu fasses une recherche google concernant AllowOverride pour comprendre comment ça marche.
J'ai regardé mon httpd.conf dedans j'y avais :
Code:
#
# Each directory to which Apache has access can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories). 
#
# First, we configure the "default" to be a very restrictive set of 
# features.  
#

    Options FollowSymLinks
    AllowOverride None
j'ai modifié la valeur a All, redémarrer le serveur WEB, rien a faire pas de compression :/

gaboul49
08/07/2014, 09h15
Il faut que tu fonctionnes pas à pas, sans faire de copier coller dans tout les sens.

AllowOverride d'ajouter à un endroit précis du fichier, il faut que tu fasses une recherche google concernant AllowOverride pour comprendre comment ça marche.

adilis
08/07/2014, 00h19
Citation Envoyé par Freemaster
un petit site pour vérifier si la compression est bien active, et qui te donne le taux de compression :
http://www.whatsmyip.org/http_compression/
J'ai trouvé ce site dans la matinée, bien pratique, mais désespérément négatif à tous mes tests

adilis
08/07/2014, 00h17
Quand j'essaye de rajouter les lignes suivantes dans les parametres du serveur dans plesk 1
Code:
AllowOverride All
SetOutputFilter DEFLATE
AddOutputFilterByType DEFLATE text/html text/css text/plain text/xml application/x-javascript
J'obtiens l'erreur suivante : Configuration Apache invalide : Syntax error on line 1 of vhost.conf: AllowOverride not allowed here

https://www.dropbox.com/s/ehago85fh0...2001.16.20.png

Freemaster
07/07/2014, 20h33
un petit site pour vérifier si la compression est bien active, et qui te donne le taux de compression :
http://www.whatsmyip.org/http_compression/

thekamaster
07/07/2014, 20h06
Est-ce que ta directive AllowOverride est à All ou à None au niveau de la configuration Apache ? (tu parles de .htaccess, mais si ça ne marche pas il est fort possible que ça vienne de là).

adilis
07/07/2014, 15h54
Citation Envoyé par gaboul49
Pourquoi tu mets "IfModule mod_filter.c" alors que c'est le mod deflate que tu dois utiliser ?
J'ai copié le code depuis un autre site pour lequel cela fonctionne,
Mais meme en enlevant les IF, ex :
Code:
AddOutputFilterByType DEFLATE text/html text/css text/plain text/javascript application/javascript application/x-javascript
Le deflate n'est pas activé, et pourtant aucune erreure.

gaboul49
07/07/2014, 15h43
Pourquoi tu mets "IfModule mod_filter.c" alors que c'est le mod deflate que tu dois utiliser ?

adilis
07/07/2014, 13h34
Bonjour a tous,
Je viens de commander un VPS Cloud chez OVH et je n'arrive pas à utiliser le mod_deflate
Pourtant le module est bien chargé dans apache.

Quand j'appelle un fichier CSS :
Request headers
Code:
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding:gzip,deflate,sdch
Accept-Language:fr-FR,fr;q=0.8,en-US;q=0.6,en;q=0.4,zh-CN;q=0.2
Cache-Control:no-cache
Connection:keep-alive
Cookie:PHPSESSID=qailr5mn9d98mdtmstnsahdkm5
Host:www.marcelcard.fr
Pragma:no-cache
User-Agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36
Response :
Code:
Accept-Ranges:bytes
Cache-Control:max-age=604800
Connection:keep-alive
Content-Length:68337
Content-Type:text/css
Date:Mon, 07 Jul 2014 12:29:25 GMT
ETag:"53ba9295-10af1"
Expires:Mon, 14 Jul 2014 12:29:25 GMT
Last-Modified:Mon, 07 Jul 2014 12:29:09 GMT
Server:nginx
X-Powered-By:PleskLin
Dans mon HTACCESS =
Code:

	
		AddOutputFilterByType DEFLATE text/html text/css text/plain text/javascript application/javascript application/x-javascript
	
Et au niveau du PhpInfo, tout semble correct :
https://www.dropbox.com/s/nohdmneyjo...2014.32.09.png

J'y perds vraiment mon latin, quelqu'un aurait il une idée ?
Merci pour votre temps