OVH Community, votre nouvel espace communautaire.

Problème réception formulaire Php


Gaston_Phone
04/07/2014, 15h45
Merci pour la précision.

Chrystelle
04/07/2014, 15h34
J'ai trouvé et ça marche.
Pour ce que ça peux aider, j'ai juste rajouté
Code PHP:
ini_set("SMTP""smtp.mondomaine.com");
Et tout marche.
Merci de votre patience

Chrystelle
04/07/2014, 14h46
Ovh vient de me répondre :
"La fonction php d'envoi de mail n'est pas fonctionnelle, il faut ajouter un smtp dans cette dernière, via une adresse existante."
Euh...c'est du chinois pour moi, j'abuse si je demande comment ont fait ça?

Chrystelle
04/07/2014, 14h41
Test réussi

Gaston_Phone
04/07/2014, 13h31
Et si tu essayais le même script de test sur ton hébergement PERSO linux ?

Chrystelle
04/07/2014, 13h06
Merci.
C'est ce que j'ai fais. Il m'ont dit que ça venait de ma programmation et qu'il ne pouvait pas m'aider.
Je viens de les relancer...
Si par miracle, ils m'apportent une solution, je t'en ferai part.
Merci du temps que tu m'as consacré

Gaston_Phone
04/07/2014, 12h54
Citation Envoyé par Chrystelle
j'ai activé la version 5.4 (Gérer son hébergement>Versions de php et DotNet Framework>)
Je pense que la question est alors à poser au support OVH sur le manager v3.

Chrystelle
04/07/2014, 12h43
j'ai activé la version 5.4 (Gérer son hébergement>Versions de php et DotNet Framework>)

http://compas-france.com/test.php pour voir la config

Gaston_Phone
04/07/2014, 12h32
Citation Envoyé par Chrystelle
Pour info, je viens de faire le test avec cette page : http://www.wordetweb.com/word-et-web...ipt-php-FR.htm
Et j'ai un message "### CR_Mail= - Erreur envoi mail "
C'est le type de test que je préconise.
Ce type de message d'erreur est très rare sur un hébergement PERSO (linux).

Quelle version de PHP as-tu sur ton mutualisé Windows : phpinfo();

Chrystelle
04/07/2014, 12h13
Pour info, je viens de faire le test avec cette page : http://www.wordetweb.com/word-et-web...ipt-php-FR.htm
Et j'ai un message "### CR_Mail= - Erreur envoi mail "

Chrystelle
04/07/2014, 12h04
Je suis d'accord.
Pour ma défense, je suis webdesigner, je touche rarement au PHP et mes formulaires n'ont jamais été mis sur Windows, je n'avais donc jamais eu confronté à ce problème de compatibilité.
Mais en est-ce vraiment un? Une astuce pour le faire fonctionner ? ou faut-il que je change de langage (ce que je trouverai au passage zarb vu que cet hébergement autorise le php )
merci de ton aide

Gaston_Phone
04/07/2014, 11h51
Préparer et tester un site sur linux et rendre public sur Windows ne me semble pas très cohérent et efficace.

Chrystelle
04/07/2014, 11h44
L'hebergement Perso est à moi et me sert pour tester et présenter des maquettes, l'hébergement Mutualisé Windows et celui choisi par mon client, j'ai donc tout reposé sur celui-la.
J'ai bien activé PHP dans l'hébergement et laissé les paramètre par défaut (version 5.4/Version de DotNet Framework 4.0/Pipeline mode : integrate/Mode 32 bits : non)

Gaston_Phone
04/07/2014, 11h39
Qu'est-ce qui t'a fait passer vers mutualisé Windows ?
PHP est-il bien activé sur ton hébergement ?

Chrystelle
04/07/2014, 11h27
Bonjour,
j'ai crée un formulaire Php qui marchait très bien quand il était sur un hébergement Ovh Perso.

J'ai changé d'hébergement et suis passé sur du mutualisé Windows.
Le formulaire s'affiche bien et semble partir mais je ne reçois dans la boite du destinataire.
Y-a-t-il quelque chose à changer dans le script ou est-ce des paramètres à modifier dans le manager ?
D'avance merci

Ci-dessous, mon script :

Code:
Prénom :'.$prenom.'
E-mail: '.$email.'
Société :'.$societe.'
Fonction :'.$fonction.'
Téléphone : '.$telephone.'
Fax :'.$fax.'
Adresse :'.$adresse.'
Code postal :'.$code.'
Ville :'.$ville.'
Message : '.$message.'
Catalogue : '.$catalogue.'
Commercial : '.$commercial; mail($destinataire,$objet,$mess,$headers); } ?>