OVH Community, votre nouvel espace communautaire.

Probleme mail() depuis ce matin


testeur115
30/09/2006, 19h01
Oué ça merde grave chez ovh et on est le week end donc aucun support, rien, on va se payé un week end sans mail, en plus c'est un début de mois, moi j'ai donc plein de mail a envoyé normalement en php et ça va etre la misere....
et d'ici que lundi ça soit pas encore réparé....
marre d'ovh et tout leurs problème

sanosuke85
30/09/2006, 18h35
Bonjour,

Je rencontre aussi aujourd'hui un problème d'envoi de mail automatisé. J'ai testé il y a quelques semaines sans aucun soucis la fonction. Mais on m'a contacté ce matin m'annonçant que cela ne fonctionnait pas. J'ai fait un test il y a une demi heure et toujours rien.

Dans l'espoir d'une réponse.

Cordialement.

K4leph
27/09/2006, 19h09
Même problème, j'ai un start10g et j'ai un forum phpBB dessus. Les mails de confirmation n'arrivent plus à ceux qui s'inscrivent, c'est plutôt embêtant. Des nouvelles venant d'OVH ? Merci de me renseigner, j'ai pas lu les 5 pages qui précèdent mon post.

Amicalement

k4leph

BZH
26/09/2006, 16h57
Je n ais toujours pas de nouvelles de la part des techniciens...

Yggdrasil
25/09/2006, 15h21
Pour info, Guillaume à quitté OVH fin de la semaine dernière ...

BZH
25/09/2006, 15h20
Bonjour,

Suite a ton conseil guillaume,
j ais contacté le support technique par mail,
cela fait maintenant 5 jour et je n ais toujours pas de reponses.

et j ais toujours ma fonction mail du site kiama design qui sont HS
et angersweb qui deconne.

serait il possible de jeter un oeil ou de faire avancer les choses.

cordialement

joxp
23/09/2006, 14h09
C'est ce que j'ai finalement fait, et c'est bon ça fonctionne rapidement maintenant

apocalx
23/09/2006, 12h41
En ce qui me concerne, après avoir insisté auprès du support, c'est revenu à la normale. Donc hésite pas à leur ecrire, ils sont peut-être pas au courant pour toi.

joxp
22/09/2006, 21h45
Meme chose pour moi qui suis en plan90, il me semblait aussi que ça fonctionnait hier la fonction mail() php.
J'espère juste que les mail ne sont pas perdus...

Si c'est général, je ne contacte pas le support, j'attends vos retours.

merci

ovhuser
22/09/2006, 11h39
apocalx :
As-tu essayé avec le webmail? (webmail.ovh.net)
ça ne marchait pas totalement au niveau du webmail non plus (messages manquants). mais c'est rentré dans l'ordre.

Yggdrasil
21/09/2006, 20h06
Je susi désolé mais cette fonciton ets en cours de maintenance.
Elle sera remise en place d'ici la fin du mois.
C'est exactement ce que l'on m'a répondu pour une demande similaire ...

apocalx
21/09/2006, 19h42
Citation Envoyé par Guillaume
Tant que tu y es, crée un compte pop spécifique sur ton domaine et demande à recevoir les retours en erreur sur ce compte pop.
Moi je veux bien, mais voila ce que m'a répondu le support quand je le leur ai demandé...

Je susi désolé mais cette fonciton ets en cours de maintenance.
Elle sera remise en place d'ici la fin du mois.

apocalx
21/09/2006, 08h12
Citation Envoyé par ovhuser
Nous, on ne reçoit plus les messages contenant une pièce jointe. Le probleme a démarré à partir du moment ou la boite est devenue pleine (enfin y a surement un lien). Depuis la taille de la boite a été agrandie, mais le probleme persiste sur les pieces jointes.
As-tu essayé avec le webmail? (webmail.ovh.net)

Guillaume
20/09/2006, 23h00
Les deux sont au-dessus de 5% mais cela ne veut pas forcément dire que tes fonctions sont bloquées.
Contacte le support pour te renseigner et éventuellement te les faire débloquer.

BZH
20/09/2006, 21h07
Bonsoir,

Il semblerait que ma fonction mail() soit désactiver.

En effet apres avoir acheter un logiciel de newsletter, pour tenir informer mes clients, il semblerait que ma fonction mail ait ete desactivé pour je ne sais quel raison.

serait il possible de vérifier ma fonction mail()
ainsi que de la réactiver si possible?

-http://www.kiama-design.com
-http://www.angersweb.com

Merci beaucoup d'avance

cordialement.

ovhuser
20/09/2006, 18h19
Nous, on ne reçoit plus les messages contenant une pièce jointe. Le probleme a démarré à partir du moment ou la boite est devenue pleine (enfin y a surement un lien). Depuis la taille de la boite a été agrandie, mais le probleme persiste sur les pieces jointes.

---------------
EDIT : probleme réglé dans la soirée. Mais je me pose toujours la question.

bbq
20/09/2006, 17h11
Citation Envoyé par apocalx
...Cette procédure ne devrait-elle d'ailleurs pas être demandée par défaut pour tous les sites?
Oui, ce serait bien, par défaut sur postmaster, avec possibilité d'affecter un autre compte POP via le manager...

apocalx
20/09/2006, 14h45
Ok, merci du conseil, j'ai déja ouvert un thread au support hier soir, j'attends encore la réponse, mais je vais en profiter pour creer un compte pop "special erreurs". Cette procédure ne devrait-elle d'ailleurs pas être demandée par défaut pour tous les sites?

Guillaume
20/09/2006, 11h37
Contacte le support et expose leur le problème.
Tant que tu y es, crée un compte pop spécifique sur ton domaine et demande à recevoir les retours en erreur sur ce compte pop.

apocalx
20/09/2006, 10h46
Merci pour la réponse rapide.

A ce moment la il y a un autre problème quelquepart. Aucun des scripts utilisant la fonction mail n'a envoyé aucun message depuis 1 semaine. Y a peut-être des bouchons dans les tuyaux?

Guillaume
20/09/2006, 10h10
Ta fonction mail n'a pas été bloquée.

apocalx
20/09/2006, 10h07
Bonjour,

Même problème avec apocalx.com (sur 240plan), plus un seul mail a partir de la fonction php mail() depuis le 12 septembre. Je pensais a un retard, mais une semaine, ça commence a faire.

Aurais-je été bloqué? (sans préavis?)

Guillaume
16/09/2006, 10h33
phendile> ta fonction mail() n'a pas été bloquée

njord
16/09/2006, 01h58
Même problème chez moi, depuis apparemment plusieurs jours (je viens juste de m'en rendre compte)

Guillaume
12/09/2006, 10h01
Signale ce problème au support.

marcob47
11/09/2006, 22h35
Bonjour,

Je constate que beaucoup ont eu un pb avec les fonctions d'envoi de mail php mais il semble pour eux que cela ait été résolu.

De mon côté, j'ai constaté le problème pour la première fois le 09/09 et je n'ai pas reçu de mail depuis.

Mon site n'est pas critique (blog perso) mais ça m'ennuie un peu...

Quelqu'un a t-il des news sur ce sujet ? Mon hébergement est un 1000 gp offert avec un .info.

Merci d'avance de votre aide,

Marc

phendile
11/09/2006, 19h04
Bonjour,

Je suis nouvelle utilisatrice d'OVH. J'ai fait hier un essai d'envoi d'e-mails (274 envois simultanés). En revanche, certains champs e-mail de ma base de données n'étaient pas renseignés et j'ai donc dépassé la barre des 5% d'emails en erreur.
Ma fonction mail a donc apparemment été bloquée. Je n'arrive plus à expédier aucun mail depuis mes scripts.
Pourriez-vous me préciser comment je peux réactiver la fonction mail ? Je n'ai pas accès au manager de site ces jours-ci (je suis en déplacement) et il semblerait que les erreurs soient redirigées vers postmaster que je ne peux donc changer pour le moment.
Le domaine concerné est : mdmv.net (90 plan)

C'est assez urgent... Est-ce qu'un administrateur pourrait la réactiver pour moi ?

velk
06/09/2006, 22h13
retard aussi chez moi... j attends voir si ca vient

oualad
06/09/2006, 10h13
De rien, mais avant toute chose, ma bd est faite avec 2 champs:
1) pour le mail
2) pour l'id en auto_increment.

C'est pour cette raison que la requete est:
Code PHP:
 $requete=mysql_query("insert into inscriptions values ('$mail','')"); 
'$mail' pour mail et ' ' pour l'id.

@+

thefxage
06/09/2006, 09h52
Oualad,

Merci.
Nous allons essayer ton code et voir ..What's happens !

Marc

oualad
06/09/2006, 09h40
thefxage écrivait :
...
$to = "NOM_MAILING_LIST-subscribe-" . str_replace("@", "=", $email_visiteur) . "@domaine.tld";
...
Bonjour,
a vrai dire, je ne comprends pas très bien cette ligne. Si on pouvait m'expliquer pourquoi remplacer le '@' par '=' ?

Au fait, je ne sais pas comment tu récupères l'adresse mail.
Voici ma manière de faire:
Le formulaire en get d'inscription appelle le script suivant:
Code PHP:
$mail=$_GET['mail'];
$point strpos($mail,".");
$aroba strpos($mail,"@");
if((
$point=='') or ($aroba=='')) 
    {
        include 
"inscript_non_ok.php";
    }
else {
        
$connex=mysql_connect("tutu","tutu","tutu") or die("Connexion impossible");
        
mysql_select_db("tutu") or die("Connexion impossible ˆ la BD");
        
$requete=mysql_query("insert into inscriptions values ('$mail','')");
        if (!
$requete)
            {
                echo 
"Erreur à la base Mysql - Recommencez plus tard";
                echo 
"Merci";
                echo 
"Retour";
            }
        else 
            {
                
$adresse=$_GET['mail'];
                
$sujet="Inscription à la newsletter";
                
$message="Bonjour";
                
$message.="

Vous recevez ce mail suite à votre inscription sur le site:"
                
$message.="etc...

"
;
$message.="etc...";
                
$headers  'MIME-Version: 1.0' "\r\n";
                
$headers .= 'Content-type: text/html; charset=iso-8859-1' "\r\n";
                if (
mail($adresse,$sujet,$message,$headers))
                    { include 
"inscript_ok.php"; }
            }
    
mysql_close(); 
Voilà en gros. Tous mes tests se sont révélés ok. Mais on pourrait me reprocher de ne pas prendre en compte un doublon.
Mais je n'arrive pas à bien saisir la technique. Une double requete? une req1 qui verifie si le mail existe déja. Si oui, alors... sinon $req2 qui insere.
Je vais essayer.

J'espere que c'est bien ce que vous demandiez.

@+

thefxage
05/09/2006, 21h23
Merci pour ta réponse

Voici le code proposé par OVh .. que nous essayons d'insérer dans notre page php générale contenant déjà un formulaire connecté à une base pour uploader les infos du visiteur. ( et qui fonctionne déjà sans soucis).


Marc

OVH guide : ( partie Mailinglist)
Si vous voulez proposez une inscription automatique par un formulaire sur votre site web vous pouvez utilisez ce bout de script pour enregistrer la demande :

$email_visiteur = Recuperation de l'adresse pasé dans le formulaire;

$to = "NOM_MAILING_LIST-subscribe-" . str_replace("@", "=", $email_visiteur) . "@domaine.tld";
$subject = "inscription";
$message = "inscription";
$additional_headers = "From: <".$email_visiteur.">
"."Reply-To:<".$email_visiteur.">
";
mail($to , $subject, $message, $additional_headers);
?>

thats
05/09/2006, 20h52
Pour schématiser la chse:
mon fichier formulaire.php:

Entrez votre email pr vs abo à la newsletter



dans votre fichier newsletterbddp.php
vous vous connecter à votre bdd
vous faites une table newsletter avec un id autoincrementé et un champ mail :
$emailentre=$_POST['email'];
on vérifie si doublon:
$sql1="SELECT * from newsletter where email=$'emailentre' ";
$req1=mysql_query($sql1);
$res=mysql_num_rows($req1);
if ($res!="0") { echo " Le mail existe deja dans notre base de données newsletter"; }
else
{
$sql="INSERT into newsletter (id, email) VALUES ('','$emailentre');
$req=mysql_query($sql) or die ('Erreur lors de l'abo à la newsletter');
$sujet='Confirmation de votre abo à la newsletter';
$message='Félicitations blablabla';
$headers ='From: "nom"'."\n";
$headers .='Reply-To: adresse_de_reponse@fai.fr'."\n";
$headers .='Content-Type: text/plain; charset="iso-8859-1"'."\n";
$headers .='Content-Transfer-Encoding: 8bit';
mail ($emailentre,$sujet,$message, $headers);
}
Voilà c'est du vite fait mais c'est l'idée générale.

oualad
05/09/2006, 19h50
thefxage écrivait :
Oualad,

nos lisons que tu as des probl emails ce jour. Idem pour nous. donc sans doute ... probl général.
Tout fonctionne pour nous désormais correctement depuis cet aprèsm.
Nous sommes sur MediaPlan.

Cependant, nous lisons également que tu as créé un formulaire personnel sur ton site pour récolter les emails et les envoyer vers le suscribe d'une newsletter.

Peux-tu nous éclairer ?
Nous devons faire la meme chose.
Nous avons pris le script proposé par OVH ( guide) .. Mais ou le places-tu ? Comme un server Markup dans la Form d'envoi vers la base .. ou .. entre des lignes précises dans le code général de la page ?

Merci pour ton aide si poss ..
Marc
Bonsoir,
le script proposé apr ovh, je ne le connais pas.
Néanmoins, le formulaire perso, une fois soumis, appelle un script qui insère l'adresse mail dans la bd.
Le tout, bien entendu, via une requete.
Lorsque cette requête est accomplie (true), il envoie un mail de confirmation à la personne pour la prévenir qu'elle vient d'être inscrite à la newsletter.

Bon! dis de cette manière, c'est peut-etre pas complet et comprehensif, mais vous pouvez coller votre code ici ou créer un autre sujet. Et nous serons surement nombreux à apporter notre petite contribution

@ bientôt

Rador8
05/09/2006, 18h16
Tout est OK pour moi aussi, les messages arrivent à nouveau instantanément.

oualad
05/09/2006, 17h34
Je réponds vite par manque de temps, mais je repasserais plus tard pour le script.
Voici la réponse du support OVH:
...En fait, le problème vient du fait que le serveur sortant des hébergemùent 60gp à subit une attaque de spams ce qui ralentis l'acheminement des mail.
Désolé de la gène occaisonnée.
Je reste à votre disposition en cas de problème....
Mais à présent tout est ok...avec du retard, mais lors d'envoi de mail, rien ne nous garantis que la personne le lit instantanément

Allez je me sauve
@+

thats
05/09/2006, 16h07
Sinon envoie un ticket a ovh. C'est ce que j'ai fait et miracle 15mn ca marchait

Rador8
05/09/2006, 16h02
thats écrivait :
Si tu doutes de ton code, mets le en copier-coller ici
Salut, non je ne doute pas trop, ça fait des années que mon petit formulaire hyper basique fonctionne

thats écrivait :
J'ai renvoyé sur gmail et cela est arrivé mais avec un retard de 2-3h. Je serai toi, j'attendrai.
Je vais attendre, mais là ça fait déjà des retards de 4 heures.

thats
05/09/2006, 15h49
J'ai renvoyé sur gmail et cela est arrivé mais avec un retard de 2-3h. Je serai toi, j'attendrai. Si tu doutes de ton code, mets le en copier-coller ici

thats
05/09/2006, 15h48
lol. Moi c'est pareil. Enfin l'essentiel c'est que ca revienne. Mais j'ose pas imaginer pour un site pro avec un site en phase de production. Moi je suis en dév ca me fait rien mais le jour ou cela arrive en phase de production (cad finalisé) ca voudrait pas me faire rire

Rador8
05/09/2006, 15h47
Salut,

Pareil pour moi, plus aucun message n'arrive depuis mon formulaire http://www.rador8.eu/contact.php

Je suis en 60GP.

Perso mes messages sont envoyés vers une adresse Gmail. J'ai vu que récemment ça ne passait pas entre OVH et Gmail/Free. Ce problème serait-il revenu ou est-ce autre chose...
http://travaux.ovh.net/?do=details&id=1027

Vos messages sont-ils envoyés vers une adresse Gmail ou Free ?

kevin58
05/09/2006, 15h45
oui, moi aussi mais ils ont 3 heures de retard

thats
05/09/2006, 15h42
Bon je commence à recevoir des mails. Ca semble remarcher. A suivre.

thats
05/09/2006, 15h22
J'ai moi aussi le même probleme. Même le mail le plus simple (c'est à dire un mot en txt et pas en html) ce ne passe pas.
Aucune erreur dans le code. Juste le mail qui n'arrive pas.
Moi j'ai un petit 90plan.J'attends encore un peu aprés je send le support.

thefxage
05/09/2006, 14h31
Oualad,

nos lisons que tu as des probl emails ce jour. Idem pour nous. donc sans doute ... probl général.
Tout fonctionne pour nous désormais correctement depuis cet aprèsm.
Nous sommes sur MediaPlan.

Cependant, nous lisons également que tu as créé un formulaire personnel sur ton site pour récolter les emails et les envoyer vers le suscribe d'une newsletter.

Peux-tu nous éclairer ?
Nous devons faire la meme chose.
Nous avons pris le script proposé par OVH ( guide) .. Mais ou le places-tu ? Comme un server Markup dans la Form d'envoi vers la base .. ou .. entre des lignes précises dans le code général de la page ?

Merci pour ton aide si poss ..
Marc

Shadow aok
05/09/2006, 14h13
luipon écrivait :
Bonjour,

pareil avec 300gp, je recoit pas les mails. (mail de php)

Existe-t il un moyen de recuperer les mails d erreurs sans devoir telephoner a ovh ??

Ou peut on voir le taux de mails d erreur ?? les 5% ??

Merci.
Crée un compte mail sur ton domaine qui sera dédié à la récupération des retours (doit être différent de postmaster) et ouvre un ticket au support pour leur demander de faire envoyer les retours sur ce compte pop.

Tu ne peux pas voir le taux de mails en erreur.

oualad
05/09/2006, 13h11
En ce qui me concerne, ce n'est pas une question d'erreur.
Je fais mes tests avec mes differentes adresses mail.
Le script d'hier, je ne l'ai pas changé, je ne l'ai que relancé pour voir comment mon message html s'affichait dans differentes boites lail (mail, outlook, ...).

Donc, je pense que le problème vient d'OVH.

Je m'en vais le signaler au support.
Je transmettrais ici leur commentaire.

@+

luipon
05/09/2006, 13h05
Bonjour,

pareil avec 300gp, je recoit pas les mails. (mail de php)

Existe-t il un moyen de recuperer les mails d erreurs sans devoir telephoner a ovh ??

Ou peut on voir le taux de mails d erreur ?? les 5% ??

Merci.

kevin58
05/09/2006, 12h45
Bonjour,

idem pour moi en 60GP

@+

oualad
05/09/2006, 12h23
Bonjour,
j'ai crée un formulaire pour l'inscription à une newsletter. A chaque inscription, la personne reçoit un mail de confirmation.
En faisant mes tests hier, tout fonctionnait bien.
Depuis ce matin, niet. Mail() n'envoie plus.

Avant de contacter le support, certains sont-ils dans le même cas.

J'ajoute que je n'ai modifié mon script en rien.

Merci