OVH Community, votre nouvel espace communautaire.

Problème smtp serveur sous roudcube


rubenxela
23/09/2014, 09h54
Citation Envoyé par loick2000
J'ai enfin reussi à envoyer un message avec roudcube, après changement du mot de passe du compte.
Mais je trouve ça totalement incroyable, et surtout informatiquement incompréhensible.
OVH opère un blocage sur les envois quand les comptes emails sont hackés. Il me semble toutefois que leur script de détection du hacking soit hyper sensible, car ça m'est arrivé plusieurs fois et je ne voyais pas de trace de hack via l'appli roundcube en ligne en tous cas !

Vois dans tes emails tu as du recevoir un message dont le sujet est [OVH-Mail] contact@tonmail.fr- Compte email Hacké
Il est stipulé dans ce message qu'il faut changer de mot e passe pour débloquer.

fritz2cat
20/08/2014, 12h35
Citation Envoyé par Nicolas.C
Bonjour,

@loick2000 : Il s'agit la d'envoi en PHP, et non pas via SMTP, d'où le fait que le blocage soit apparent sur le site, mais pas sur le client lourd.

Je t'invite à débloquer ou à purger les envois depuis ton Manager OVH de la manière suivante :

Manager -> loic-martin.net -> Hébergement -> Suivi des emails automatisés

Débloquer les envois permettra d'envoyer les mails en attente après l'utilisation de la fonction mail().

Purger les envois permettra de supprimer les mails en attente.
@Nicolas.C : je pense que ceci n'est pas applicable.
Voici un exemple de headers d'un mail envoyé depuis le Webmail OVH Roundcube et j'y ajoute mes commentaires:
Pour rappel il faut lire de bas en haut.

Code:
Received: from mo7.mail-out.ovh.net (mo7.mail-out.ovh.net [178.32.228.7])
     by mx.du.destinataire (Postfix) with ESMTP
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
Received: from mail332.ha.ovh.net (b6.ovh.net [213.186.33.56])
     by mo7.mail-out.ovh.net (Postfix) with ESMTP id 55584FF82EC
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
Received: from ssl0.ovh.net (localhost [127.0.0.1])
     by mail332.ha.ovh.net (Postfix) with ESMTPA id 33C16C005D
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
Received: from remote.host.name ([123.45.67.89])
     by ssl0.ovh.net
     with HTTP (HTTP/1.1 POST); Wed, 20 Aug 2014 13:21:36 +0200
Reprenons-les en détail avec des explications

Chemin de sortie habituel
Code:
Received: from mo7.mail-out.ovh.net (mo7.mail-out.ovh.net [178.32.228.7])
     by mx.du.destinataire (Postfix) with ESMTP
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
Received: from mail332.ha.ovh.net (b6.ovh.net [213.186.33.56])
     by mo7.mail-out.ovh.net (Postfix) with ESMTP id 55584FF82EC
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
Ici Roundcube transmet le mail à Postfix via une connexion SMTP authentifiée à destination de localhost
Code:
Received: from ssl0.ovh.net (localhost [127.0.0.1])
     by mail332.ha.ovh.net (Postfix) with ESMTPA id 33C16C005D
     for ; Wed, 20 Aug 2014 13:21:36 +0200 (CEST)
L'en-tête ci-dessous est inséré par Roundcube
Code:
Received: from remote.host.name ([123.45.67.89])
     by ssl0.ovh.net
     with HTTP (HTTP/1.1 POST); Wed, 20 Aug 2014 13:21:36 +0200
Le circuit des e-mails automatisés du mutu n'est pas mis à contribution.
(remarquez qu'il n'y a plus de Qmail et que les serveurs sont à l'heure)

loick2000
20/08/2014, 11h31
J'ai enfin reussi à envoyer un message avec roudcube, après changement du mot de passe du compte.
Mais je trouve ça totalement incroyable, et surtout informatiquement incompréhensible.

loick2000
20/08/2014, 11h24
Citation Envoyé par Nicolas.C
Bonjour,
@loick2000 : Il s'agit la d'envoi en PHP, et non pas via SMTP, d'où le fait que le blocage soit apparent sur le site, mais pas sur le client lourd.
Je t'invite à débloquer ou à purger les envois depuis ton Manager OVH de la manière suivante :
Manager -> loic-martin.net -> Hébergement -> Suivi des emails automatisés
Débloquer les envois permettra d'envoyer les mails en attente après l'utilisation de la fonction mail().
Purger les envois permettra de supprimer les mails en attente.
Bonjour,
Je viens une nouvelle fois d'appliquer la procédure, et il m'est toujours impossible d'envoyer des messages. Et tout fonctionne toutjours sous thunderbird.

Est-ce que quelqu'un va réellement chercher une solution à un moment ?

Loïc

loick2000
01/07/2014, 15h12
Citation Envoyé par Nicolas.C
Bonjour,
@loick2000 : Il s'agit la d'envoi en PHP, et non pas via SMTP, d'où le fait que le blocage soit apparent sur le site, mais pas sur le client lourd.

Je t'invite à débloquer ou à purger les envois depuis ton Manager OVH de la manière suivante :
Manager -> loic-martin.net -> Hébergement -> Suivi des emails automatisés
Débloquer les envois permettra d'envoyer les mails en attente après l'utilisation de la fonction mail().
Purger les envois permettra de supprimer les mails en attente.
J'ai appliqué la procédure, et 20 minutes plus tard, je ne peux toujours pas envoyé de messages depuis le webmail OVH ...
Dommage, j'y ai cru.

Citation Envoyé par fritz2cat
C'était donc un roundcube installé par Loick dans son hébergement ?
Hé non,
C'est bien ça que je trouve inquiétant... c'est celui d'OVH par défaut.

fritz2cat
01/07/2014, 12h45
C'était donc un roundcube installé par Loick dans son hébergement ?

Nicolas.C
01/07/2014, 11h57
Bonjour,

@loick2000 : Il s'agit la d'envoi en PHP, et non pas via SMTP, d'où le fait que le blocage soit apparent sur le site, mais pas sur le client lourd.

Je t'invite à débloquer ou à purger les envois depuis ton Manager OVH de la manière suivante :

Manager -> loic-martin.net -> Hébergement -> Suivi des emails automatisés

Débloquer les envois permettra d'envoyer les mails en attente après l'utilisation de la fonction mail().

Purger les envois permettra de supprimer les mails en attente.

loick2000
30/06/2014, 11h03
L'erreur est toujours présente sur le site web, et les messages partent sans problème du client lourd....

loick2000
11/06/2014, 10h58
Si le compte avait été hacké, on verrait dans la boite d'envoi les mails envoyés par le hacker, et même s'il les détruit au fur et à mesure, il suffit de suivre les logs d'envoi de mail avec ce compte pour constater qu'il est peu utilisé.

D'autre part, en cas de hacking et d'utilisation pour envoyer trop de messages, le compte est bloqué. Pour une heure ou plus. Mais lors de mon dernier test, j'ai essayé un envoi depuis roundcube qui n'a pas fonctionné, et dans les minutes qui ont suivies un autre envoi à partir d'un client lourd (thunderbird dernière version) qui lui a parfaitement fonctionné.

Le problème vient donc de la configuration du SMTP lorsque l'on utilise roundcube. Et surtout, cela vient d'un changement de cette configuration, puisqu'il y a encore un mois elle fonctionnait parfaitement. peut-être un effet de bord d'une montée de version quelconque.

Mon DUT en informatique date de plus de 25 ans, mais j'ai essayé de me maintenir à un niveau de connaissance informatique minimum depuis.

Je ne comprends pas vraiment comment un changement de mot de passe modifierait la communication avec le serveur SMTP....
D'autant que le serveur SMTP fonctionne parfaitement, puisque le client lourd arrive à l'utiliser.

Mais si on me donne une explication informatique, je peux évidemment changé d'opinion.

Nicolas.C
10/06/2014, 12h14
Bonjour,

Pouvez-vous modifier le mot de passe de vos comptes emails depuis votre Manager > [DOMAINE] > Emails > Mot de passe

Et me préciser si le problème persiste?

Quant à la cause de cette erreur, vous trouverez un complément d'informations à l'adresse suivante :

http://forum.ovh.com/showthread.php?...l=1#post608302

loick2000
09/06/2014, 18h42
Citation Envoyé par Baptiste.D
Bonjour,

Après vérification, je ne constate pas de blocage particulier côté OVH.

Peux-tu effectuer un test depuis le lien suivant : https://ssl0.ovh.net/roundcubemail/ ; et me communiquer le résultat ?
Si possible, je t'invite à me communiquer une capture d'écran de l'erreur.

L'envoi que tu essayes d'effectuer contient-il une pièce jointe ou un nombre de destinataire important ? Si oui, peux-tu m'indiquer plus de détail ?

Je viens de t'envoyer un message de test depuis une adresse en @test-mutu.com ; je t'invite à essayer de répondre à cet email également.

Cordialement,
Baptiste D.
J'ai refait le test, comme le forum ne permet pas de mettre des images depuis un DD local, j'ai répondu au mail, et mettant les images dans la réponse.

Ca ne marche toujours pas depuis roundcube.
Mais le message semble être parti correctement depuis thunderbird.

Cordialement
Loïc

jlandrei
09/06/2014, 14h15
J'ai le même problème que loik2000 mais sur l'adresse jean-luc@chez-andrei.fr
j'ai testé d'envoyer un mail depuis l'adresse que tu donnes et ça ne change rien.
Je ne peux pas non plus envoyer de mails depuis mon client lourd ni même sur un autre webclient comme outlook.com

Baptiste.D
09/06/2014, 12h36
Bonjour,

Après vérification, je ne constate pas de blocage particulier côté OVH.

Peux-tu effectuer un test depuis le lien suivant : https://ssl0.ovh.net/roundcubemail/ ; et me communiquer le résultat ?
Si possible, je t'invite à me communiquer une capture d'écran de l'erreur.

L'envoi que tu essayes d'effectuer contient-il une pièce jointe ou un nombre de destinataire important ? Si oui, peux-tu m'indiquer plus de détail ?

Je viens de t'envoyer un message de test depuis une adresse en @test-mutu.com ; je t'invite à essayer de répondre à cet email également.

Cordialement,
Baptiste D.

loick2000
06/06/2014, 10h54
Le blocage est toujours là ....

loick2000
05/06/2014, 16h56
Le domaine est loic-martin.net et l'email loic@loic-martin.net

Merci pour les recherches.

Baptiste.D
05/06/2014, 15h43
Bonjour,

Peux-tu me préciser le nom de ton domaine ainsi que le compte mail concerné s'il te plait ?

Cordialement,
Baptiste D.

loick2000
05/06/2014, 15h04
Merci pour le test.

Je n'ai pas thunderbird sur ce PC, je vérifierai ce soir.

Ce qui est ennuyeux, c'est que j'avais un Email important à envoyer, et que le système ne fonctionne pas...

Et au bout d'une heure trente, pas de message d'un admin ou d'un modo du forum. Même pas pour dire qu'OVH s'intéresse au problème.

jlandrei
05/06/2014, 14h33
Je viens d'essayer et j'ai le même problème que toi
Essais voir d'envoyer un mail depuis un client lourd. Il semblerait que tu ai le même problème que moi. "Erreur SMTP (535) : Échec de l'authentification." que ce soit dans un webmail ou avec un client lourd.

Malheureusement je n'ai toujours pas de solution.
Courage

loick2000
05/06/2014, 12h57
Bonjour,

J'utilise roudcube pour lire et envoyer certain mail sous Firefox.

La connexion se fait bien, la lecture de Email aussi (ainsi que tout le reste). Mais après rédaction d'un nouveau mail, impossible de l'envoyer :

Erreur SMTP (535) : Échec de l'authentification.

Alors que je suis connecté.

Quand aux deux autres lecteurs web, impossible de me connecter dessus, il ne reconnait pas mes identifiants qui fonctionnent parfaitement sous roundcube.

Merci de m'indiquer le pourquoi du comment.