OVH Community, votre nouvel espace communautaire.

SqlMembershipProvider .net4.5.1


Delyha
01/05/2014, 19h02
bonsoir,

j'ai fait une update de mon site du framework .net 4.0 en 4.5.1 mais j'ai un problème au niveau du SqlMembershipProvider, et j'arrive pas a voir d'ou vient le problème.

J'ai deux chaines de connexion, une pour l'entity framework qui donne les datas du site et une seconde qui permet de faire le lien avec le SqlMembershipProvider. J'ai bien accès aux datas du site, mais le problème vient du SqlMembershipProvider.

Quand j'y accède j'ai ce message :
'System.Web.Security.SqlMembershipProvider' requiert un schéma de base de données compatible avec la version de schéma '1'. Cependant, le schéma de base de données actuel n'est pas compatible avec cette version. Vous devrez peut-être installer un schéma compatible avec aspnet_regsql.exe (disponible dans le répertoire d'installation de Framework) ou effectuer une mise à niveau du fournisseur vers une version plus récente.
J'ai delete les toutes les tables/vues du SqlMembershipProvider grâce a un scripte générer avec aspnet_regsql.exe puis j'ai remis exactement la même version que j'ai en locale mais j'ai le même problème.
J'ai même remis une version vierge directement générer avec aspnet_regsql.exe mais pareil

je tourne sur un SQLServer2012 en locale aussi...

Problème de version côté serveur ?

Quelqu'un a une idée ?