OVH Community, votre nouvel espace communautaire.

Installation de mod_security et mod_evasion sur vps debian 6


enricocerica
24/04/2014, 19h05
Je ne parviens pas à installer mod_security et mod_evasive

Je reçois les messages suivants :


root@vps31569:/# apt-get install libapache-mod-security
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libapache-mod-security : Depends: mod-security-common (= 2.5.12-1+squeeze3) but it is not going to be installed
Depends: liblua5.1-0 but it is not going to be installed
mysql-server-5.1 : Depends: mysql-server-core-5.1 (= 5.1.66-0+squeeze1) but 5.1.73-1 is to be installed
Recommends: mailx
Recommends: libhtml-template-perl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


root@vps31569:/# apt-get install libapache2-mod-evasive
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
mysql-server-5.1 : Depends: mysql-server-core-5.1 (= 5.1.66-0+squeeze1) but 5.1.73-1 is to be installed
Recommends: mailx
Recommends: libhtml-template-perl but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


J'ai bien essayé de lancer le apt-get -f install mais manifestement il n'est pas possible d'actualiser la version de mysql qui ne peut semble-t-il pas être arrêté.