OVH Community, votre nouvel espace communautaire.

VPS 2014 Cloud 2 - LAMP 1.0 - Permaliens & ERREUR 404


AgenceSG
25/04/2014, 16h52
Pour ceux qui ont la configuration suivante et qui cherchent aussi voici ce qui a fonctionné.

Distribution LAMP 1.0 (64bits) sur VPS2014 Classic1 et Cloud 2

Dans le terminal (putty) se connecter en "root"

éditer le fichier par defaut suivant en tapant:

nano /etc/apache2/sites-enabled/000-default

modifier les trois arguments "allowoverride none" en "allowoverride all"

Enregistrer et quitter

relancer apache en tapant : service apache2 restart

Activer le mode "rewrite" en tapant : a2enmod rewrite

puis relancer le serveur apache : service apache2 restart

Merci a PiRR et gaboul49 pour les deux informations qui une fois compilées sont la solution.

en ce qui concerne le "allowoverride all" sur les 3 directory, un avis d'expert peut se poser ..... En tout cas cela fonctionne

NB:
Selon la doc Apache : En général, vous ne devriez jamais utiliser les fichiers .htaccess à moins que vous n'ayez pas accès au fichier principal de configuration du serveur. Il y a, par exemple, une conception erronée qui prévaut selon laquelle les droits des utilisateurs doivent toujours être gérés dans le fichier .htaccess. Cela n'est simplement pas le cas

AgenceSG
25/04/2014, 16h21
Citation Envoyé par gaboul49
Les fichiers htaccess ne sont peut-être pas activés

http://httpd.apache.org/docs/2.2/mod...#allowoverride
Donc j'ai fais.

nano /etc/apache2/sites-enabled/000-default

Changer les 3 AllowOverride en ALL

Relancé le serveur apache.

Et comment dire ... et bien toujours pas ...

AgenceSG
24/04/2014, 13h42
Merci de votre rapide réponse.

Si je comprend bien, n'ayant qu'un seul site par serveur, il est donc possible de faire Un "AllowOverride All" ?
après cela reste de la théorie, mais en pratique comment faisons nous exactement, sans en faire un "tuto" ....

gaboul49
24/04/2014, 13h06
Les fichiers htaccess ne sont peut-être pas activés

http://httpd.apache.org/docs/2.2/mod...#allowoverride

AgenceSG
24/04/2014, 10h51
Malheureusement OUI ....

PiRR
24/04/2014, 09h17
Bonjour,

Avez-vous activé le mod rewrite ? (en root dans le terminal: a2enmod rewrite puis /etc/init.d/apache2 restart)

AgenceSG
23/04/2014, 17h36
Bonjour,

c'est dans la joie et l'allégresse que nous avons entrepris de migrer nos multiples sites (Tous en Wordpress) d'un serveur Dédié SP32 vers des Classic 1 ou Cloud 2 selon la charge.

Les VPS sont en LAMP 1.0

Tout va bien si ce n'est la "mouche dans le lait" ... Lorsque l'on est en permaliens par défaut, cela fonctionne. (mais c'est moche faut le dire)
Quand on choisit les permaliens ( nom d'article par exemple) ont a une ERREUR 404

Le fichier HTACCESS est bien modifié mais ne semble pas être pris en compte par le serveur.

Seuil de competence atteint ...... En clair, on sèche et c'est la m!@#de !!!