OVH Community, votre nouvel espace communautaire.

Pb sous PHP sur mon VPS


Daniel60
23/04/2014, 20h17
Cf mon post #2.
CQFD
Merci pour les liens

marl
23/04/2014, 19h26
Bon c'est bon ... c'est Paypal qui avait changé son mode de transmission afin d'abandonner le vieux protocole HTTP1.0 devenu obsolète.

Si vous aussi, vous utilisez un script Paypal, soit TDP, soit NIP, alors pensez à regarder les nouveaux scripts :

- https://github.com/paypal/pdt-code-samples
- https://github.com/paypal/ipn-code-samples

;-)

marl
23/04/2014, 11h19
bonjour gaboul,

Non, rien dans les variables d'erreur :

errno : 0
errstr :


gaboul49
21/04/2014, 20h30
Et dans $errno et $errstr tu as quoi après avoir exécuté la commande ?

marl
20/04/2014, 19h54
Comment puis-je faire un test sur une autre adresse ssl ?

merci de votre aide. Gilles

marl
20/04/2014, 19h22
Merrci de ta réponse,

Je ne crois pas que cela vienne de Paypal car cela coïncide avec le changement de serveur.

fsocket ne génère pas d'erreur car il y a un contenu sec: Resource id #1

Que faire ?

Daniel60
20/04/2014, 18h15
Peut-être un problème Paypal.
As-tu essayé un fsockopen sur une autre adresse ?
et aussi :
Code PHP:
if (!$fp) {
    echo 
"$errstr ($errno)\n"

marl
20/04/2014, 17h06
Bonjour à tous:

J'ai migré des sites vers un vps sous debian.

Tout fonctionne sauf un script php qui récupère des informations sous ssh :

$fp = fsockopen ('ssl://www.sandbox.paypal.com', 443, $errno, $errstr, 30);

la variable $fp n'est pas chargée !

Ai-je oublié quelque chose lors de ma configuration PHP ?