OVH Community, votre nouvel espace communautaire.

Accés en SSH bloqué


doc_denis
01/05/2014, 21h06
Bonjour,
gaboul49 ouvre une porte "évidement" LOL.

logiquement le redémarrage de ssh doit-être :
sudo service ssh restart

sinon oui un :
sudo reboot

tu en est où ?

gaboul49
30/04/2014, 09h16
Après avoir modifié le fichier de conf tu dois redémarrer le service ssh, ou reboot si tu ne sais pas comment faire.

fritz2cat
30/04/2014, 07h59
Regarde du côté de la commande sudo

mt32274
29/04/2014, 23h34
ok tout ça est fait. Mais ça ne rêgle pas mon problème qui est que je ne peux me connecte en root que sur KVM et pas via WinSCP ou Putty et en plus quand je me connecte avec mon nom utilisateur par KVM ou Winscp, je n'ai pas tous les droits,
Je ne peux pas modifier de fichiers ...
je ne peux pas copier de fichiers ...
et pourquoi je ne peux pas me connecter avec mon NOMUSER perso avec les mêmes permissions que avec le ROOT ?

Merci encore à toi, t'es super sympa de prendre du temps pour moi
Thierry

doc_denis
29/04/2014, 21h22
Bonne idée ton post copier/coller

décommente ton :

#PasswordAuthentication yes
en
PasswordAuthentication yes

regarde aussi ton
AllowUsers

il affiche :
AllowUsers dew

il devrais être
AllowUsers tonnomd'utilisateur

si tu à bien ajouter ton nouvel utilisateur en sudoers.

ajouter l'utilisateur en sudoer :

nano /etc/sudoers

et ajouter cette ligne a la fin "évidement changez le tonnomd'utilisateur par votre nom d'utilisateur ssh"

tonnomd'utilisateur ALL=(ALL:ALL) ALL


A propos du prob en écriture : ajoute "sudo la commande"
sudo nano /etc/ssh/sshd_config

et hop
...m'enfin sur le papier.

@+

mt32274
28/04/2014, 23h22
Alors mon port est bien à 22,.
Je peux me connecter via KVM avec mon nouvel user et par WinSCP en port 21 seulement mais lorsue je veux copier des dossiers local sur le distant j'ai un "Accés Denied" .

Ci joint mon SSHD_CONFIG

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22

# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
AllowUsers dew
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

doc_denis
28/04/2014, 18h14
re bonjour, oublie l'étape : /etc/hosts.deny
mauvaise idée, car tu te connecte en ftp donc tu n'est pas banni
...préfère utiliser le scp = sftp, mais c'est sur le port ssh

la bonne piste c'est la première :
vérifie le port ssh ouvert dans /etc/ssh/sshd_config
regarde si c'est bien le port 22 ...ou sinon, tu saura sur quel port te connecter

avec ton kvm tape :
nano /etc/ssh/sshd_config

et tu vois la configuration de ssh le port etc...

tu quitte en faisant ctrl+x

doc_denis
28/04/2014, 17h02
Bonjour,
vérifie le port ssh ouvert dans /etc/ssh/sshd_config
regarde si c'est bien le port 22 ...ou sinon, tu saura sur quel port te connecter

plus loin, si ton ip "à toi" est une ip fixe, vérifie le fichier /etc/host.deny
regarde si ton ip n'est pas dedans.

Tu as des trucs en production sur ton VPS ?
Seulement si tu n'a rien sur ce VPS, réinstalle ...ça ira plus vite.


@+

mt32274
28/04/2014, 16h35
Merci de ta réponse (j'ai appris des trucs) .

Donc effectivement par KVM je peux me connecter avec mon nouveau nom d'utilisateur
mais par par Putty ni par WinSCP !
Alors dans WinScp j'ai choisi connexion par Protocole de Fichier en FTP au lieu de SFTP et port 21 au lieu de 22 et là ça marche !!
Je pense que j'ai un problème dans les ports car j'avais tenté de les modifier aussi.

Par Putty en SSH, je n'y arrive toujours pas, comment savoir si les ports sont définis ou fermés ou autres ?

doc_denis
24/04/2014, 19h27
Bonjour, je ne me suis jamais servi du kvm,
mais si ça donne accès à un terminal, tu doit pouvoir créer un user avec des droits d'accès ssh ?

tu à peut-être "logiquement" interdit à root de se connecter en ssh ...l'une des premières action à faire sur un serveur de base, dans ce cas tu peut sans doute lui redonner accès pour résoudre ton problème.

pour redonner l'accès au ssh à root (peut-être avec le kvm) :
/etc/ssh/sshd_config
changer :
PermitRootLogin no
par :
PermitRootLogin yes


normalement on fais le contraire ! par sécurité.
on ajoute un user qui à accès à ssh et on bloque l'acces root comme ça :
PermitRootLogin no


ma procédure pour ajouter un user ..évidement change "monuser" par le nom d'utilisateur :

Je sécurise l'accès SSH "je prépare un utilisateur qui à accès à SSH" :

useradd -m -d /home/monuser/ -s /bin/bash monuser

puis mot de passe (fort si possible):

passwd monuser

puis ajouter l'utilisateur en sudoer :

nano /etc/sudoers

et ajouter cette ligne a la fin "évidement changez le monuser par votre nom d'utilisateur ssh"

monuser ALL=(ALL:ALL) ALL

puis tenter une connexion avec notre nouveau user
si ça roule, on coupe l’accès à root, comme vu plus haut

@+ denis

mt32274
24/04/2014, 12h14
Merci,
j'ai donc tapé "reboot" dans mon KVM.

Ensuite je peux donc me connecter par KVM en root avec mon mot de pass, mais lorsque je veux me connecter par Putty avec root et mon mot de asse , il me répond "Access denied"

Rhhhoooo

fritz2cat
24/04/2014, 09h52
Reboote ton serveur à partir d'une session sur le kvm.
Donne plus d'explications, parce que sinon, tu ne trouveras personne pour t'aider, en effet.

mt32274
23/04/2014, 18h07
personne pour m'aider

mt32274
19/04/2014, 11h31
Bonjour,

Voilà je n'arrive plus a accéder en SSH par Putty sur mon serveur en Root.
Je suis passé par l'espace client OVH

https://www.ovh.com/manager/web

pour ensuite accéder au KVM et là ça marche bien avec le root et le mot de passe.

Pour info, j'avais changé le port et je l'ai remis (sans trop savoir si c'est pris en compte bien sur )
et
le voyant SSH est en VERT sur l'espace client.

Merci de votre aide