OVH Community, votre nouvel espace communautaire.

configuration du server Bind pour DNS


buddy
08/03/2014, 08h14
Bonjour,

il faut également mettre une ligne "allow-transfer' pour autoriser sdns2.ovh.net ... ( ici il y a un tuto pour kimsufi mais çà fonctionne pareil, il faut juste remplacer ns.kimsuf.com et son ip par celle de sdns2.ovh.net - http://blog.idneo.fr/configuration-d...x-manager-ovh/ )
Tu peux aussi tester ton serveur DNS avec ce site http://www.kloth.net/services/dig.php
si çà marche tu dois voir apparaître ton ip.

Si çà ne marche pas tu auras un message d'erreur de ce style " ;; connection timed out; no servers could be reached
"

Freemaster
07/03/2014, 19h21
Code:
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
si ton serveur dns n'est pas accessible de l'extérieur, il risque pas de résoudre ton nom de domaine... pour l'extérieur
d'ailleurs je me demande comment tu as pu indiquer ton dns primaire 11.ip-37-187-34.eu, il me semblait que le serveur devait être accessible pour valider la demande ?

lyyant
07/03/2014, 17h40
Bonjour,

Je vous présente mon problème,
mon nom de domaine est le suivant : unionboost.com , actuellement chez "godaddy", et je souhaite le faire pointer vers mon ip serveur,
à savoir : 37.187.34.11 (VPS OVH sous centOS 6).

les names servers sont les suivants : 11.ip-37-187-34.eu et sdns2.ovh.net

J'ai configuré les fichiers suivants :

-/etc/named.conf comme ci :

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
	listen-on port 53 { 127.0.0.1; };
	listen-on-v6 port 53 { ::1; };
	directory 	"/var/named";
	dump-file 	"/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
	allow-query     { localhost; };
	recursion yes;

	dnssec-enable yes;
	dnssec-validation yes;
	dnssec-lookaside auto;

	/* Path to ISC DLV key */
	bindkeys-file "/etc/named.iscdlv.key";

	managed-keys-directory "/var/named/dynamic";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
	type hint;
	file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
include "/etc/named.conf.local";
ainsi que le fichier /etc/named.conf.local comme ceci :

Code:
zone "unionboost.com" IN {
type master;
file "unionboost.com.zone";
allow-update { none; };
};
et finalement mon fichier /var/named/unionboost.com.zone :

Code:
$ttl 86400
unionboost.com. IN SOA 11.ip-37-187-34.eu. root.unionboost.com. (
2004011801
21600
3600
604800
86400 )

IN NS 11.ip-37-187-34.eu.
IN NS sdns2.ovh.net.
IN A 37.187.34.11
www IN A 37.187.34.11
j'ai ensuite appliqué la commande suivante : # rndc reload
et redémaré le VPS

je souhaiterais donc savoir si cette configuration était "juste", car pour l'instant je n'obtiens toujours pas de réponse après un ping sur
le domaine : unionboost.com.

merci beaucoup pour votre aide