OVH Community, votre nouvel espace communautaire.

VPS 2014 Release 3 : comment configurer en PHP 5.4 ?


hotburne
22/05/2014, 12h04
Salut Isendel
Merci pour l'information !

Isendel
22/05/2014, 08h16
Cela implique de très lourdes manipulations dans lesquelles je n'oserai personnellement m'aventurer de peur de planter tous les sites de la machine.

Mais si le coeur t'en dit tu peux creuser un peu sur le web par exemple : http://serverfault.com/questions/431...usly-on-ubuntu

hotburne
21/05/2014, 16h57
Bonjour a tous
y a t'il une manip pour faire cohabiter des sites 5.4 5.3 et 5.2
sur le même vps ?

PS_
21/05/2014, 10h57
Voici la réponse du support technique :

Si vous souhaitez utiliser une autre version de php il vous faudra procéder a son installation manuellement en récupérant les sources sur le site de php.

Si vous souhaitez de l'aide a ce niveau je vous conseil de passer par notre forum :
http://forum.ovh.com

Cordialement, Bertrand C.

Isendel
20/05/2014, 16h35
Effectivement la version actuelle de PHP sur la release est la 5.3.3 il serait intéressant de savoir si la mise à jour de la version de PHP est prévue sous peu.

Tu peux tenter l'upgrade toi même mais tu risques de sortir de la release ce qui perd de son intérêt.

Je suis preneur du retour du support.

PS_
20/05/2014, 13h27
Merci Isendel pour ta réponse.

L'erreur est celle-ci :

Your host needs to use PHP 5.3.10 or higher to run this version of Joomla!
Je voulais commencer par la version 5.3 puis la version 4 s'il y a un problème...

Isendel
20/05/2014, 12h39
Salut,

Tu veux 5.3 ou 5.4 ?

PS_
20/05/2014, 11h34
Je viens d'écrire au support car j'ai le même problème sur mon nouveau VPS 2014 (release 3 ).

Je souhaiterais utilser PHP 5.3 pour un site Joomla 3.0.

Quelqu'un aurait trouvé la solution ?

Dans le cas contraire je posterai la solution du support technique s'il y en a une...

Isendel
13/03/2014, 09h48
A part faire remonter l'info à la team d'ovh et attendre qu'ils offrent cette possibilité la dans la R3 je ne vois pas trop...

Daniel60
07/03/2014, 19h39
Citation Envoyé par Benji2i
Je ne souhaite pas trop faire ça car je souhaite pouvoir bénéficier des mises à jour de la release 3.
J'ai en effet peur que si je customise ça m'oblige à devoir gérer les mise à jour.
C'est pas faux.

Benji2i
07/03/2014, 19h13
Merci Daniel pour ta réponse.

Ca c'est pour installer des packages supplémentaires.
N'y a-t-il que ça ?

Je ne souhaite pas trop faire ça car je souhaite pouvoir bénéficier des mises à jour de la release 3.
J'ai en effet peur que si je customise ça m'oblige à devoir gérer les mise à jour.

N'y a-t-il pas un moyen de le faire juste en config ?
Sur le Kimsufi qui est actuellement en prod et dont je migre les sites sur ce VPS, on peut choisir la version de PHP à la création du domaine pour Apache.

Daniel60
07/03/2014, 07h46
SetEnv PHP_VER 5_4
Cette commande ne fonctionne que sur le mutualisé.
Sinon, as-tu essayé apt-get ou dpkg ?

Benji2i
07/03/2014, 07h07
Bonjour,

Je viens d'intaller un serveur VPS 2014 en Release 3.
Je souhaite que mes sites web soient en PHP 5.4.

Je vois que par défaut je suis en PHP 5.3.

J'ai essayé de mettre SetEnv PHP_VER 5_4 dans le .htaccess mais ça ne change rien.

Comment faire ?

Ben