OVH Community, votre nouvel espace communautaire.

non reception de mail entre un domaine et son sous domaine avec hébergement différent


ataroa
07/03/2014, 15h36
Merci beaucoup pour le coup de main. Le problème a été résolu tout seul. Je pense qu'un DNS n'était pas à jour. J'ai quand même fait quelque motifs dans la config suite à vos indications. Merci beaucoup pour le coup de main et bon week end

fritz2cat
07/03/2014, 09h51
Il y a des trucs vilains pas beaux là-dedans.

1) l'adresse d'expéditeur root@SRNF2902VTL@asplenium.net ou www-data@SRNF2902VTL@asplenium.net va se faire refuser partout (on appelait ça du poor-man-routing il y a 15 ans, mais ici c'est une erreur)

2) sur ta machine SRNF2902VTL, pourquoi un mail adressé à f.barletXelia-medical.com est-il relayé vers 172.30.248.252 et non vers le MX désigné chez OVH ? Parce que au choix: dans ton /etc/postfix/main.cf il y a un mydomains qui dit que c'est chez lui ; ou bien ton resolver DNS lui dit que le MX est 172.30.248.252.
Depuis SRNF2902VTL, fais la commande: dig elia-medical.com MX => si la réponse contient 3 lignes mx1, mx2, mxb.ovh.net alors le problème est dans ton fichier de config postfix.
N'oublie pas que si tu changes la config, par exemple pour enlever ataroa et elia-medical, il faut envoyer la commande: postfix reload.

ataroa
07/03/2014, 07h38
Bonjour Merci de vous être penché sur mon problème. et bravo pour cette petite analyse du système.

Mon soucis c'est que l'orsque je regarde dans la log le statut est sent.
Voici un exemple ce matin le mail arrive bien sur ataroa mais pas elia-medical...

[Extrait de log retirée]

fritz2cat
07/03/2014, 07h23
Citation Envoyé par ataroa
j'ai un script php sur un sous-domaine appli.elia-medical.com ( hébergé chez asplénium )
...
de appli.elia-medical.com (asplenium) vers elia-medical.com = message non reçu
Il faut voir les logs chez asplénium, car si ça ne sort pas de leurs systèmes, la raison y est indiquée.
Je ne connais pas cet hébergeur et je n'en ai jamais entendu parler avant aujourd'hui.
Quel type d'hébergement utilises-tu ?
Ca a tout l'air d'un serveur dédié puisque l'accès par l'adresse IP en dur 213.41.53.172 mène aussi à ton site.
Ca semble être un debian, mais le port 25 est firewallé donc on va supposer que tu as Postfix installé.
Le log se trouverait alors dans /var/log/mail.log, que je t'invite à consulter.

ataroa
06/03/2014, 17h06
Bonjour

Je vous écris car je suis face à un problème délicat que je ne sait résoudre.

Pour faire simple j'ai un script php sur un sous-domaine appli.elia-medical.com ( hébergé chez asplénium )
le même script sur un serveur mutualité (ovh) acpresse.fr

ce script identique sur les deux machines envoie un mail via la fonction php mail() aux deux domaines hébergé chez ovh en mutualisé ataroa.com et elia-medical.com avec les entête par défaut.

de acpresse (ovh) vers elia-medical.com (ovh) = message reçu
de acpresse (ovh) vers ataroa.com (ovh) = message reçu
de appli.elia-medical.com (asplenium) vers ataroa.com (ovh) = message reçu
de appli.elia-medical.com (asplenium) vers elia-medical.com = message non reçu

Avez-vous une idée, une piste d'où cela pourrait venir ?

Merci pour votre aide.