OVH Community, votre nouvel espace communautaire.

Problème de DNS


RomualdC
04/03/2014, 15h10
Bonjour,

Il se peut que cela soit lié au délai de propagation DNS qui peut prendre 24 à 48 heures lorsque vous modifiez les serveurs DNS.

Cordialement,
Romuald C.
Service Client OVH

Lab44
03/03/2014, 10h08
Bonjour

J'ai un soucis avec mes zones DNS, configurées dans le manager OVH (même problème sur plusieurs noms de domaine). Je souhaite supprimer un serveur DNS perso pour rebasculer sur les serveurs DNS OVH, mais l'hôte "www" pose problème. J'ai un serveur web et un serveur mail.


Exemple d'une zone DNS :
Code:
$TTL 180
@	IN SOA dns107.ovh.net. tech.ovh.net. (2014030310 86400 3600 3600000 300)
            IN NS     dns107.ovh.net.
            IN NS     ns107.ovh.net.
            IN MX 1   mail.toto.fr.
            IN A      91.121.111.111
mail        IN A      91.121.222.222
test        IN CNAME  toto.fr.
www         IN CNAME  toto.fr.
"toto.fr" renvoi bien sur l'adresse du serveur web (91.121.111.111), tout comme le CNAME "test". Par contre "www" renvoi sur l'ip de "mail". En créant un enregistrement "A" pour "www" pointant directement sur l'IP du serveur web le comportement est le même.

Dans "Accueil > Mutualisé > Domaines & DNS" les serveurs dns sont bien "ns107.ovh.net." et "dns107.ovh.net.".


C'est comme si l'hôte "www" avait une IP forcée... Le problème est sans doute simpliste mais je n'arrive pas à mettre le doigt dessus.

Merci d'avance pour vos réponses.


EDIT : un "nslookup www.toto.fr dns107.ovh.net" me donne la bonne IP. Ce serait un problème de propagation DNS (?). Pourtant le problème est présent depuis 3 jours, ça fait long. Quelque chose m'échappe.

EDIT 2 : j'ai enfin la bonne IP associée à "www". Pas contre je ne comprends toujours pas le délai ni le fait que tous les autres hôtes fonctionnaient correctement depuis un moment...