OVH Community, votre nouvel espace communautaire.

Mise à jour PHP sur VPS 2013 Plesk


jbouv55151
19/05/2014, 12h18
Citation Envoyé par grabit
Il faut se connecter en ssh via un éditeur de ligne de commande. C'est assez rébarbatif.

Moi, sur Mac, j'utilise "Terminal".

Tu trouvera les données d'accès sur ton mail de configuration d'OVH.
Du style:
User: root
et ton mot de passe.
Super merci !
J'ai du faire quelques mises à jour, mais tout marche maintenant !

Daniel60
19/05/2014, 11h42
Sur Windows c'est putty.exe à télécharger.
(C'est un peu osé de prendre un VPS sans connaître l'utilisation d'un console)

grabit
19/05/2014, 10h58
Il faut se connecter en ssh via un éditeur de ligne de commande. C'est assez rébarbatif.

Moi, sur Mac, j'utilise "Terminal".

Tu trouvera les données d'accès sur ton mail de configuration d'OVH.
Du style:
User: root
et ton mot de passe.

jbouv55151
19/05/2014, 10h24
Salut,
Merci pour ton retour.
En effet, pour ma part j'ai Plesk 11.5, c'est donc exactement ce que je recherche. Par contre, pour l'installation, je suis un peu novice. Tu utilises des commandes comment ?

grabit
18/05/2014, 11h49
Bonjour,

j'ai trouvé ceci si tu as Plesk:

http://forum.parallels.com/showthrea...ller-for-Plesk

Ca marche super!

jbouv55151
16/05/2014, 10h38
Bonjour à tous les deux,
J'ai la même problématique avec mon VPS et Joomla. Avez-vous pu mettre à jour la version de PHP ?

shirokoweb
18/02/2014, 12h24
Ce n'était pas clair dans votre premier message. Il y a un guide sur les forums plesk : Guide Voyez s'il répond à votre besoin.
Cdt

grabit
18/02/2014, 09h58
Merci Shirokoweb,

Mais ma demande est centrée sur le fait qu'il faut faire tourner plusieurs versions de PHP sur Plesk. Donc je ne peux pas simplement upgrader PHP sur la machine.

Pour info:

CentOS 6.4 final
Plesk 11.5.30

et ici le lien vers les explications pour ajouter des versions PHP mais qui sont partiellement laconiques:
http://download1.parallels.com/Plesk...Name=70562.htm

D'autres suggestions?

shirokoweb
18/02/2014, 00h42
Bonjour, je ne connais pas plesk, ni sur quelle distro il est installé (je présume CentOS), ni avec quel serbeur HTTP (je présume Apache) en encore moins si on peut mettre PHP à jour depuis l'interface de gestion graphique.

En revanche, en ligne de commande pour les mises à jour c'est apt-get updates > apt-get upgrade (attention ça met TOUT à jour)

Pour mettre à jour PHP uniquement :

Code:
apt-get -y install php5 libapache2-mod-php5
Vous pouvez démarrer les scripts php en ligne de commande, pour ce faire vous devez installer php5-cli avec la commande suivante :

Code:
apt-get -y install php5-cli
Vous pouvez également exécuter les scripts PHP5 sans le module PHP5 d'Apache. Pour cela vous devez installer php5-cgi avec la commande suiavante :

Code:
apt-get -y install php5-cgi
Pour pouvoir utiliser MySQL avec PHP5 vous devez installer php5-mysql avec la commande ;

Code:
apt-get -y install php5-mysql
Pareil pour PostgreSQL, il vous faut php5-pgsql que vous installez avec la commande :

Code:
apt-get -y install php5-pgsql
Pour terminer, si vous avez besoin de l'ensemble des packages, saisissez tout à la suite :

Code:
apt-get -y install php5 libapache2-mod-php5 php5-cli php5-cgi php5-mysql php5-pgsql
Il se peut que les mirors d'ovh soient osbolète, il vous faudra donc trouver des sources plus récentes et les ajouter à sources.list
Sans oublier de faire un restart du php.ini après les installations

cdt

grabit
17/02/2014, 18h01
Bonjour,

Plusieurs de mes sites en Joomla me signale que la version PHP installée par défaut par Plesk est quasi obsolète (5.3.3).

J'aimerais donc mettre à jour PHP.

Plusieurs questions:

Quelle version choisir?
Comment procéder avec Plesk (je ne suis pas un super user de unix et du ssh).
Il y a bien un pas à pas dans l'aide de Plesk mais déjà à la première étape, ils n'ont pas uploadé le fichier sur le serveur et donc on cale.

Merci aux bonnes volontés.