OVH Community, votre nouvel espace communautaire.

VPS 2013 Cloud securité postfix


b.b.b
10/09/2015, 14h43
/etc/cron.daily/logrotate:

No valid records found!

Sur mon VPS 2016 Release 3 ....
Quelqu'un a trouvé depuis ?

Tristan
06/07/2015, 10h38
Citation Envoyé par farscape94
Bonjour,

J'ai le même problème et pour avoir cherché cela est provoqué par le programme logrotate qui traites les webalizer log pour éviter qu'ils ne grossissent trop. Il est lancé par un cron (Voir dans /etc/cron.daily). Quand logrotate ne trouve pas de fichier de log du jour à traiter il génère ce messages.

Malheureusement je n'ai pas trouvé de solution à appliquer. Si quelqu'un a une solution je prend aussi.
Merci.
Bonjour,

j'ai le même pb....
A priori, il faut rajouter le paramètre "missingok" pour éviter d'avoir le message d'erreur si le fichier de log n'existe pas...
Par contre, je ne sais pas trop où / comment rajouter ce paramètre ???
Si un "pro" passe par là

PascalP37
16/04/2015, 17h35
Citation Envoyé par farscape94
Bonjour,

J'ai le même problème et pour avoir cherché cela est provoqué par le programme logrotate qui traites les webalizer log pour éviter qu'ils ne grossissent trop. Il est lancé par un cron (Voir dans /etc/cron.daily). Quand logrotate ne trouve pas de fichier de log du jour à traiter il génère ce messages.

Malheureusement je n'ai pas trouvé de solution à appliquer. Si quelqu'un a une solution je prend aussi.
Merci.
Idem même soucis.

farscape94
19/11/2014, 10h07
Bonjour,

J'ai le même problème et pour avoir cherché cela est provoqué par le programme logrotate qui traites les webalizer log pour éviter qu'ils ne grossissent trop. Il est lancé par un cron (Voir dans /etc/cron.daily). Quand logrotate ne trouve pas de fichier de log du jour à traiter il génère ce messages.

Malheureusement je n'ai pas trouvé de solution à appliquer. Si quelqu'un a une solution je prend aussi.
Merci.

jhonbauwens
18/11/2014, 09h34
Hello,

Même problème ici pour:

/etc/cron.daily/logrotate:

No valid records found!
No valid records found!
No valid records found!

J'ai installé la Release 3 il y a trois jours à je reçois ce mail chaque jour. Quelqu'un a-t-il une solution?

Merci !

mailbox
17/01/2014, 15h52
Oui mais ca oblige a refaire la creation des mails et a faire la gestion ensuite ... c'était justement pas le but !

J'ai lu plusieurs POST techniques ou pour une question de "facilité de gestion" il propose de basculer que le web (A) ... mais bien sur ils ne parlent jamais de ce problème pour envoyer un mail en PHP avec une adresse du domaine en question.

J'ai mis en place la modif du MX dans BIND mais j'ai toujours un dovecot: auth: sql(test@domaine.com): Unknown user qui me bloque dans le logmail

j'ai laisse dans BIND les directives A pour smtp.domaine.com et mail.domaine.com sur l'IP du serveur VPS pour le moment .... peut etre qu'il faut mettre l'IP de mx1.ovh.net 213.186.33.29 ?

postfix/pickup[19388]: 947DA11C142: uid=504 from=
postfix/cleanup[19928]: 947DA11C142: message-id=<8cc4184616b963c5d686f641a2de7b9c@www.domaine.c om>
postfix/qmgr[19389]: 947DA11C142: from=, size=743, nrcpt=1 (queue active)
dovecot: auth: sql(test@domaine.com): Unknown user
postfix/pipe[19937]: 947DA11C142: to=, relay=dovecot, delay=0.11, delays=0.05/0.01/0/0.05, dsn=5.1.1, status=bounced (user unknown)
postfix/cleanup[19928]: ACE2611C143: message-id=<20140117135742.ACE2611C143@vps*******.ovh.net>
postfix/bounce[19939]: 947DA11C142: sender non-delivery notification: ACE2611C143
postfix/qmgr[19389]: ACE2611C143: from=<>, size=2521, nrcpt=1 (queue active)
postfix/qmgr[19389]: 947DA11C142: removed

( modification sur : domaine.com et ****** pour le forum )

Isendel
17/01/2014, 14h59
De mon côté je n'utilise le fichier de zone du manager V3.

J'ai directement dans les zones dns le dns primaire de mon vps et sdns2.ovh.net pour le secondaire.
Ensuite le fichier de zone principal devient celui du bind du vps sur lequel tu peux rediriger vers le mx d'ovh.

Ça paraît plus simple comme façon de procéder qu'en dis-tu ?

mailbox
17/01/2014, 14h02
gaboul49 : Oui j'attendais bien ce genre de réponse

Ah si j'avais dit ca a toutes les personnes que j'aide en PHP ... je n'ai pas tes compétences... mais je suis la pour apprendre et j'aime ca !....
C'est un bon debut ne penses-tu pas ?

Isendel : Mon MX pointe sur un MXplan de OVH qui existe deja depuis un moment, et mon web (A) pointe maintenant vers le VPS2013.

Je pense que le problème est plus simple que ce que je cherche depuis hier, lors de la creation du domaine sur ovhm la config BIND est mise en place de facon standard ...

domaine.com. NS Par défaut xx.ip-xx-xx-xx-xx.eu.
domaine.com. NS Par défaut sdns2.ovh.net.
domaine.com. MX Par défaut 10 mail.*********.com.
domaine.com. A Par défaut 1.2.3.4
www.domaine.com. A Par défaut 1.2.3.4
mail.domaine.com. A Par défaut 1.2.3.4
smtp.domaine.com. A Par défaut 1.2.3.4
pop.domaine.com. A Par défaut 1.2.3.4
pop3.domaine.com. A Par défaut 1.2.3.4
imap.domaine.com. A Par défaut 1.2.3.4
sql.domaine.com. A Par défaut 1.2.3.4
mysql.domaine.com. A Par défaut 1.2.3.4
ftp.domaine.com. A Par défaut 1.2.3.4
domaine.com. SPF Par défaut v=spf1 a ip4:**.**.**.** mx ~all

Je pense qu'il faut modifier le MX pour mettre le MX qui se trouve dans managerv3 pour le MX PLAN. cela devrait permettre au serveur de comprendre qu'il n'a pas de gestion local pour pour les mails de la commande PHP MAIL() ( ca doit etre ca le bounced que j'ai )

la question théorique est : faut-il modifier les IP pour smtp.domaine.com egalement ? et que faut-il mettre pour les MXPLAN ? webmin souhaite une IP ? moi j'ai uniquement mx1.ovh.net ?

Est il possible de supprimer ou bloquer dans BIND le pop3.domaine.com ou imap.domaine.com comme le serveur ne fait pas la gestion sans bloquer l'utilisation de la commande mail() PHP pour les adresses@domaine.com ?

Merci pour vos reponses

Isendel
17/01/2014, 13h43
Le MX n'est pas envoyé vers le VPS mais où est-il envoyé ? Est-il tout de même configuré ?

Ensuite lorsque tu ajoutes le domaine sur l'ovhm tu peux ne pas activer postfix pour ce domaine et donc limiter les requêtes postfix. Du reste je pense que postfix a des routines qui s'exécutent régulièrement mais je ne suis pas assez calé pour t'en dire plus.

gaboul49
17/01/2014, 12h12
Citation Envoyé par mailbox
Personne n'utilise de VPS R3 ?
Personne capable de t'aider peut-être.

Mon point de vue : Soit tu fais un peu d'admin sys et tu as le temps de chercher sur internet donc tu prends une distribution nue (comme une debian). Soit tu n'as pas le temps/les compétences et donc tu loues un mutu performance.

Mais je suis peut-être trop pessimiste.

mailbox
17/01/2014, 08h46
Personne n'utilise de VPS R3 ?

mailbox
16/01/2014, 19h26
Merci pour ta réponse .... ca semble plus calme...surtout depuis que j'ai monté bantime à 86400

Mais j'ai toujours un LOST de Postfix connections toutes les 5 mins dans le Graph Monitoring POSTFIX alors que le serveur se tourne les pouces ... y'a rien dessus !
Il doit y a voir un truc dans la conf qui colle pas ...

J'ai ca dans le maillog mais j'ai pas la moindre idée d'ou chercher ?

Jan 16 19:03:54 vps++++ clamd[3162]: SelfCheck: Database status OK.
Jan 16 19:05:06 vps++++ postfix/smtpd[12410]: connect from unknown[unknown]
Jan 16 19:05:06 vps++++ postfix/smtpd[12410]: lost connection after CONNECT from unknown[unknown]
Jan 16 19:05:06 vps++++ postfix/smtpd[12410]: disconnect from unknown[unknown]
Jan 16 19:08:26 vps++++ postfix/anvil[12411]: statistics: max connection rate 1/60s for (smtp:unknown) at Jan 16 19:05:06
Jan 16 19:08:26 vps++++ postfix/anvil[12411]: statistics: max connection count 1 for (smtp:unknown) at Jan 16 19:05:06
Jan 16 19:08:26 vps++++ postfix/anvil[12411]: statistics: max cache size 1 at Jan 16 19:05:06

Isendel
16/01/2014, 17h23
Les premiers temps mon VPS bloquait beaucoup de chinoiseries comme tu dis depuis fail2ban puis ça s'est calmé. Je me suis dit qu'un nouveau serveur = un nouveau joujou pour ceux qui essaient de s'y introduire mais bon bizarre quand même.

mailbox
16/01/2014, 15h51
Bonjour

J’ai pris un VPS 2013 Cloud pour me faire la main n’étant pas un pro dans la gestion serveur.

J’ai installé un Domaine au travers de OVHM et dans mon manager j’ai mis en place uniquement une redirection A vers l’ip du VPS ( le MX n’est pas envoyé au VPS )

J’ai 3 questions techniques pour avancer dans mon apprentissage VPS :

J’ai lu pas mal d’infos techniques sur internet et j’ai compris qu’avec la release OVH il faut rester dans le standard au risque de ne plus pouvoir faire les MAJ voir pire …. il semble que pour la sécurité il est conseillé de changer le mot de passe Root, changer le Port SSH voir meme bloquer la connexion SSH Root une fois un nouvel utilisateur SU en place ? faut il faire cela également avec la R3 ? est ce que ça ne bloquera pas Webmin et ovhm ou les mises a jour ??

Dans Webmin, je remarque dans le monitoring que le graphe POSTFIX Connections balance un pic rouge (LOST) toutes le 5 minutes ? est ce que ca viendrait de Fail2ban qui bloque des chinoiseries qui essayent de se connecter en SSH ? fail2ban me balance des mails régulièrement en SSH ? ( je n’arrive pas a trouver fail2ban.log sur la R3 ?)

Je recois ce mail également /etc/cron.daily/logrotate: No valid records found!
Est-ce logique pour livraison toute neuve ?

Merci