OVH Community, votre nouvel espace communautaire.

soucis d'intégration kcinder et ckeditor


caema
10/02/2014, 16h35
J'ai réussi, j'avais un souci dans mes URL... bête erreur de ma part, je ne devais pas avoir les yeux en face des trous!
Merci à vous

sabtwot
01/02/2014, 13h32
De plus :

http://www.oscommerce-fr.info/forum/...ic=70556&st=50 (ctrl+F ==> ovh).

Les permissions risquent d'etre un problème aussi.

Daniel60
01/02/2014, 13h21
Euh...

The requested URL /admin/kcfinder/browse.php was not found on this server.

config.filebrowserBrowseUrl = '../../js/admin/kcfinder/browse.php?type=files';
config.filebrowserImageBrowseUrl = '../../js/admin/kcfinder/browse.php?type=images';

sabtwot
01/02/2014, 12h44
As-tu toujours le souci? As-tu pensé à vérifier les permissions de ton dossier et de tes fichiers? Car les permissions en 777 ne sont pas permises sur les hébergements OVH, max 755.

Cdt

caema
16/01/2014, 09h27
Bonjour,

Je suis en train d'héberger un site, et je rencontre un souci avec l'intégration du plugin KCfinder pour CKEditor.
Je m'explique: CKEditor fonctionne nickel. Quand je tente d'ajouter une image via le bouton "image" de CKEditor, la fenêtre propriété de l'image s'ouvre bien.
Mais si je clique sur "explorer le serveur", j'ai une page not found qui s'ouvre, stipulant ceci:
The requested URL /admin/kcfinder/browse.php was not found on this server.

Je comprend bien qu'il y a un souci pour trouver le fichier browse, le problème c'est que peu importe les changements que je fais dans le fichier config.js de CKEditor, ils n'ont pas l'air d'être pris en compte puisque j'ai toujours exactement la même erreur.

Voici mon arborescence:
  • admin
  • js


Dans le dossier js:
  • ckeditor
  • kcfinder


La page où se trouve mon textarea CKEditor est dans le dossier admin.

Voici le fichier config.js de mon CKEditor:
Code:
CKEDITOR.editorConfig = function( config ) {
    config.language = 'fr';
    config.toolbar = [
	{ name: 'clipboard', items : [ 'Cut','Copy','Paste','-','Undo','Redo' ] },
	{ name: 'basicstyles', items : [ 'Bold','Italic','Underline','TextColor'] },
	'/',
        { name: 'paragraph', items : [ 'NumberedList','BulletedList','-','Outdent','Indent',
	'-','JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock' ] },
	{ name: 'insert', items : [ 'Image','Link','Unlink' ] }
    ];
    config.filebrowserBrowseUrl         = '../../js/admin/kcfinder/browse.php?type=files';
    config.filebrowserImageBrowseUrl    = '../../js/admin/kcfinder/browse.php?type=images';
    config.filebrowserFlashBrowseUrl    = '../../js/admin/kcfinder/browse.php?type=flash';
    config.filebrowserUploadUrl         = '../../js/admin/kcfinder/upload.php?type=files';
    config.filebrowserImageUploadUrl    = '../../js/admin/kcfinder/upload.php?type=images';
    config.filebrowserFlashUploadUrl    = '../../js/admin/kcfinder/upload.php?type=flash';
};
et le fichier config.js de mon kcfinder:
Code:

  * @copyright 2010, 2011 KCFinder Project
  *   @license http://www.opensource.org/licenses/gpl-2.0.php GPLv2
  *   @license http://www.opensource.org/licenses/lgpl-2.1.php LGPLv2
  *      @link http://kcfinder.sunhater.com
  */

// IMPORTANT!!! Do not remove uncommented settings in this file even if
// you are using session configuration.
// See http://kcfinder.sunhater.com/install for setting descriptions

$_CONFIG = array(

    'disabled' => false,
    'denyZipDownload' => false,
    'denyUpdateCheck' => false,
    'denyExtensionRename' => false,

    'theme' => "oxygen",

    'uploadURL' => "upload",
    'uploadDir' => "",

    'dirPerms' => 0755,
    'filePerms' => 0644,

    'access' => array(

        'files' => array(
            'upload' => true,
            'delete' => true,
            'copy' => true,
            'move' => true,
            'rename' => true
        ),

        'dirs' => array(
            'create' => true,
            'delete' => true,
            'rename' => true
        )
    ),

    'deniedExts' => "exe com msi bat php phps phtml php3 php4 cgi pl",

    'types' => array(

        // CKEditor & FCKEditor types
        'files'   =>  "",
        'flash'   =>  "swf",
        'images'  =>  "*img",

        // TinyMCE types
        'file'    =>  "",
        'media'   =>  "swf flv avi mpg mpeg qt mov wmv asf rm",
        'image'   =>  "*img",
    ),

    'filenameChangeChars' => array(/*
        ' ' => "_",
        ':' => "."
    */),

    'dirnameChangeChars' => array(/*
        ' ' => "_",
        ':' => "."
    */),

    'mime_magic' => "",

    'maxImageWidth' => 0,
    'maxImageHeight' => 0,

    'thumbWidth' => 100,
    'thumbHeight' => 100,

    'thumbsDir' => ".thumbs",

    'jpegQuality' => 90,

    'cookieDomain' => "",
    'cookiePath' => "",
    'cookiePrefix' => 'KCFINDER_',

    // THE FOLLOWING SETTINGS CANNOT BE OVERRIDED WITH SESSION CONFIGURATION
    '_check4htaccess' => true,
    //'_tinyMCEPath' => "/tiny_mce",

    '_sessionVar' => &$_SESSION['KCFINDER'],
    //'_sessionLifetime' => 30,
    //'_sessionDir' => "/full/directory/path",

    //'_sessionDomain' => ".mysite.com",
    //'_sessionPath' => "/my/path",
);

?>
Je précise qu'en test local, tout était fonctionnel!

Quelqu'un a-t-il une solution à ce problème?

Merci!