OVH Community, votre nouvel espace communautaire.

Probleme lecture PHP - erreur 403


Kril
17/01/2014, 19h39
Merci a tous pour vos réponses.

L'origine du problème a été décelé :
Après pas moins de 11 échanges de mails, OVH a trouvé la raison :
J'ai l'offre 20gp pour mon site web, et cette offre n'a pas le PHP activé.

Sauf que depuis 5 ans, mon site fonctionne parfaitement en PHP, avec des milliers de téléchargements.

Mais OVH s'est aperçu tout récemment de ce bug, et a mis à jour leur serveur, désactivant ainsi le PHP,
et rendant ainsi mon site TOTALEMENT in-opérationnel !

Et ce, sans avertir leurs clients qui, comme moi, ignoraient totalement cette désactivation du PHP avec l'offre 20gp !

La solution proposée par OVH : Souscrire à l'offre "Hebergement Perso".
Ce qui revient à dire : Pour un abonnement de 36 mois, passer de 3€ à 86.40€, c'est à dire "tout simplement" 28 fois plus cher !!!!

Bref, très grosse déception du comportement d'OVH dans cette affaire, de leurs tarifs, et de l'efficacité de leur support.

Kril
15/01/2014, 23h33
Merci pour t'être penché sur mon problème.
Et j'aurai tendance à penser, comme toi, que c'est un problème de serveur OVH.
D'autant que, sauf erreur de ma part, ce problème est apparu sans intervention de ma part !

Sauf que d'une part, ils ne répondent plus,
et d'autre part mon site n'est plus du tout opérationnel puisque tous les téléchargements se font en PHP !!!!

Bref, je suis preneur de tout autre idée ...
...en attendant que le support d'OVH cesse de se mettre aux abonnés absents (plus de réponses depuis 5jours!)

Gaston_Phone
15/01/2014, 22h41
OK, tu serais bien sur un Hébergement LINUX.

Là je sèche et ne vois à priori qu'un problème de serveur OVH.

Kril
15/01/2014, 22h27
Après recherche sur Factures et infos sur le Manager OVH, le mot Windows n'apparait nulle part

Gaston_Phone
15/01/2014, 22h04
Citation Envoyé par Kril
Serveur OVH : LINUX ou WINDOWS ?
Comment avoir cette info ?
Sur le bon de commande (ou de ta facture) de ton hébergement.

Le mot Windows apparait-il ou non ?

Kril
15/01/2014, 20h56
Serveur OVH : LINUX ou WINDOWS ?
Comment avoir cette info ?

Mes PC sont sous Windows

Gaston_Phone
15/01/2014, 20h47
Serveur OVH : LINUX ou WINDOWS ?

Kril
15/01/2014, 20h32
Merci pour cette réponse.

Test effectué : même erreur 403

Gaston_Phone
15/01/2014, 20h11
Provisoirement renomme /www/.htaccess en /www/.htaccess_OVH
Et teste ton index.php avec ton Bonjour.

Kril
15/01/2014, 20h10
et les droits du fichier :
604
Propriétaire : Lire/Écrire/-
Groupe : -/-/-
Publiques : Lire/-/-

Kril
15/01/2014, 20h08
Les droits du dossier sont identiques sur les 2 sites :
705
Propriétaire : Lire/Écrire/Exécuter
Groupe : -/-/-
Publiques : Lire/Écrire/Exécuter

RobertG
15/01/2014, 19h54
Quels sont les droits du dossier de ce site qui donne cette erreur 403 ?

Kril
15/01/2014, 19h36
Je n'ai jamais mis de fichier de configuration PHP sur mon site, et tout fonctionnait très bien depuis des années.

A noter, qu'il y a un fichier .htacess à la racine du server (sous /www) et qui contient 1 seule ligne "SetEnv PHP_VER 4"
Il y a exactement le même fichier sur mon autre site, sur lequel la lecture de "index.php" ne donne aucune erreur 403

Rizz
15/01/2014, 18h50
Comment tu fais pour configurer php / choisir la version sans .htacess ou .ovhconfig ?

Kril
15/01/2014, 18h23
Merci pour vos réponses.

Cependant, difficile de donner du code, je n'ai aucun fichier "config", ni ".htacess"
Pour les besoins du test, la racine de mon site ne possède que 2 fichiers
- index.html
(page vierge)

- index.php
echo '

Bonjour

';
?>

Résultat de "http://krilome.com/index.php"
403 Forbidden
You don't have permission to access /index.php on this server.

Rizz
15/01/2014, 18h07
En attendant quand tu aura montré un peu de code, tes fichiers de config et ce genre de chose on pourra te donner notre avis.
D'ici la ...

Kril
15/01/2014, 18h06
Pour info, j'ai sollicité le support d'OVH, pensant que le problème venait de leur serveur.
Mais après quelques tests sans résultats, ils ne me répondent plus, considérant sans doute que l'origine du problème est de mon coté (ce que je doute).

Rizz
15/01/2014, 17h49
On voit pas non plus.

Kril
15/01/2014, 13h41
Bonjour,

Je sollicite votre aide car je "bloque" dans la résolution de mon problème.

Je ne peux plus lire les fichiers PHP sur mon site, quelque soit leur emplacement.

J'ai fait un test en plaçant le MEME fichier PHP basique (mêmes droits de permission) à la racine du site de mes 2 sites web.
j'ai effacé TOUS les autres fichiers de la racine.
Résultat : erreur 403 sur 1 site, et bon fonctionnement sur l'autre !!

Les droits de permission du répertoire www sont identiques sur les 2 sites web.

Je ne vois pas du tout d'où pourrait venir le problème.

Merci d'avance pour votre aide.

Kril