OVH Community, votre nouvel espace communautaire.

Erreur d'accès SQL Server


Journeyman
20/12/2013, 12h13
En effet !
Merci pilly52 d'avoir regardé. Je crois que j'avais deux erreurs qui se sont croisées : j'avais tenté de changer le nom de la connection, et en même temps j'avais dû tester de retirer SQLMUTU de la data-source...
En tout cas c'est reglé maintenant ! Merci beaucoup!

pilly52
20/12/2013, 11h52
oui, j'ai vérifié tout ca, depuis web12 tu as bien accès au server, ta db est up et joignable, niveau droits, c'est bon, ta connection string est correcte, ducoup je me demande si tu utilises vraiment la connectionstring datacontext et pas une autre dans le code

Journeyman
20/12/2013, 11h42
Citation Envoyé par pilly52
je ne sais pas si tu as supprimé/recréé ta db sql server. Mais actuellement, je vois qu'elle s'appelle journeymoon et non pas journeymgok
Oui pilly52, effectivement j'ai essayé de la récréer ce matin, mais le problème persiste avec cette nouvelle base journeymoon.

Pour info, j'ai tenté de pinger en c# le serveur "srv-sql004" depuis le serveur web et ça semble répondre.

pilly52
20/12/2013, 11h33
ta connection string m'a l'air correcte. Tu es sur que ton code utilise bien celle là ?

Gaston_Phone
20/12/2013, 11h31
Dans ton message #3 ta photo montre la création d'une base de type MySQL 5.1.
Tu ne dois pas être au bon endroit. ;(

Journeyman
20/12/2013, 11h28
Citation Envoyé par Gaston_Phone
Base MySQL ou SQL Serveur ? ? ?
Je voudrais utiliser une base sqlserver.

Gaston_Phone
20/12/2013, 10h17
Base MySQL ou SQL Serveur ? ? ?

Journeyman
20/12/2013, 00h56
Citation Envoyé par Gaston_Phone
Es-tu sûr que Data Source=srv-sql004\SQLMUTU ?
Ne serait-ce pas plutôt : Data Source=srv-sql004 ?
Ah non justement, dans le guide il est bien écrit qu'il faut ajouter le nom de l'instance locale \SQLMUTU
En fin pour info, j'ai essayé et j'ai le même message d'erreur avec ou sans.

J'ai plutôt l'impression que je n'ai pas activé quelque chose dans mon manager, que l'accès n'est pas actif ou une bidouille dans le genre. J'ai copié les paramètres de la connection directement depuis mylittleadmin, je n'ai pratiquement pas de doute sur le fait qu'elle est bonne.

Edit : je viens de supprimer recréer une base de données via le manager, et j'ai trouvé étrange de créer une base SQLServer dans une page qui s'appelle MySQL :

Mon problème vient peut-etre de là ?
De toute façon je ne trouve pas d'autre moyen de créer la bdd. Quelqu'un a-t-il déjà eu ce genre de probleme ?

Edit2 : pour info, dans MoM dans la section hébergement journeyman.fr, le bouton "Base de données" est grisé.

Gaston_Phone
19/12/2013, 23h10
Es-tu sûr que Data Source=srv-sql004\SQLMUTU ?
Ne serait-ce pas plutôt : Data Source=srv-sql004 ?

Journeyman
19/12/2013, 23h00
Bonjour,
J'utilise Entity Framework 6 avec code first et la chaine de connection suivante :



Lors du premier accès aux données, le serveur reste en attente une dizaine de secondes puis me renvoie une erreur d'accès :

Une erreur liée au réseau ou spécifique à l'instance s'est produite lors de l'établissement d'une connexion à SQL Server. Le serveur est introuvable ou n'est pas accessible. Vérifiez que le nom de l'instance est correct et que SQL Server est configuré pour autoriser les connexions distantes. (provider: SQL Network Interfaces, error: 26 - Erreur lors de la localisation du serveur/de l'instance spécifiés)

J'ai vérifié plusieurs fois la connection string, surtout le Data-source.. Mais je crois que c'est net :je n'arrive meme pas jusqu'au serveur SQL. Pourtant via MyLittleAdmin j'accès sans probleme à ma base avec exactement les mêmes identifiants.

Le fait d'être dans un sous-domaine doit-il me fait modifier quelque chose dans la connection à la base ?

Merci de votre aide.


PS : visiblement il vaut mieux fournir l'url qui ne fonctionne pas, la voilà : http://gokeyboard.journeyman.fr/Home/ChaptersList