OVH Community, votre nouvel espace communautaire.

Pas de notification en cas d'echec d'envoi d'un mail


Zarus
18/12/2013, 16h54
J'ai effectivement l'impression que le support ne s'est pas franchement penché sur la question et que mon problème (qui au passage à l'air de toucher d'autres utilisateurs; si ce n'est tous) ne sera pas résolu...

fritz2cat
18/12/2013, 13h51
A part Octave et Angie, j'ai l'impression que plus grand monde chez OVH ne sait exactement comment fonctionne l'usine à gaz articulée autour de qmail.
Certainement pas le support en tout cas.

Zarus
18/12/2013, 13h14
Je reviens à la charge après avoir contacté le support OVH et voilà leur réponse:

> Suite aux vérifications auprès d'un administrateur, je vous informe que c'est un paramètre au niveau de votre logiciel de messagerie.
> Veuillez vérifier au niveau des paramètres de votre logiciel de messagerie.

Sachant qu'il n'y a qu'avec des comptes gérés par OVH que le problème se pose et que je me contente de configurer le nom du serveur et le port, mon login mot de passe et la méthode d'authentification je ne vois pas trop de quel paramètre il pourrait s'agir.

Quelqu'un aurait une piste à me fournir ?

Zarus
05/12/2013, 14h12
Citation Envoyé par fritz2cat
aucune notification reçue pour (2) et (4)
Ok donc c'est ce que je craignais, le problème vient à priori de chez OVH, et je ne suis pas le seul à l'avoir...
Quoi qu'il en soit merci pour ton temps.

fritz2cat
05/12/2013, 13h52
@Zarus: je confirme tes propos.

J'ai envoyé un mail à 6 destinataires (3 domaines et pour chaque domaine une adresse valable et une non valable)
1) adresse valable de Zarus (domaine hébergé chez OVH, mx= mx1, mx2, mxb.ovh.net)
2) adresse non valable dans le même domaine de Zarus
3) adresse valable d'un de mes domaines hébergés chez OVH (demees.be)
4) adresse non valable dans le même domaine
5) adresse valable d'un mes domaine hébergés sur un dédié (demees.net: postfix/debian)
6) adresse non valable dans le même domaine

Tout ça via le SMTP: ns0.ovh.net ou ssl0.ovh.net

Croyez-moi si vous le voulez:
j'ai reçu les 2 mails (n° 3 et 5)
j'ai reçu un message d'erreur relatif au (6)
j'imagine que Zarus a reçu le message n° (1)
aucune notification reçue pour (2) et (4)

Détails techniques:
le message (6) a été émis par un Postfix mo1.mail-out.ovh.net le 5 Dec 2013 14:37:54 +0100,
Message-Id: <20131205133754.DD741FFAD35@mo1.mail-out.ovh.net>.

Extrait des headers du n° 5:
Received: from mo1.mail-out.ovh.net (11.mo1.mail-out.ovh.net [188.165.48.29])
by v2XdmmailXeu (Postfix) with ESMTP
for ; Thu, 5 Dec 2013 14:34:48 +0100 (CET)
Received: from mail611.ha.ovh.net (gw6.ovh.net [213.251.189.206])
by mo1.mail-out.ovh.net (Postfix) with SMTP id 33CD4FF971B
for ; Thu, 5 Dec 2013 14:37:44 +0100 (CET)
Received: from b0.ovh.net (HELO queueout) (213.186.33.50)
by b0.ovh.net with SMTP; 5 Dec 2013 15:35:10 +0200
Received: from ip-62-235-166-230.dsl.scarlet.be (HELO XXXXX0910878) (postmaster@dXXXXs.be@62.235.166.230)
by ns0.ovh.net with SMTP; 5 Dec 2013 15:35:08 +0200
Message-ID: <4055A461573F49EF996B16B340338C2B@LXXXXXXXXXXXXX 8>
Frédéric

Zarus
05/12/2013, 12h40
C'est fait, encore merci pour ton aide.

Je viens de faire un essai avec DNS lookup et j'ai une erreur au niveau des champs MX: "Certains champs MX ne possèdent pas de PTR ou un PTR différent de leur nom initial". Ca peut être une explication, je vais creuser...

fritz2cat
05/12/2013, 09h09
Ce n'est pas normal.
peux-tu m'envoyer un message depuis exactement la même adresse, avec le même contenu, envoyé via les mêmes paramètres SMTP, à l'adresse forum.201312(à)demees(point)net

Zarus
05/12/2013, 08h52
Ok, merci pour ces précisions.
Par contre du coup pour l'absence de notification d’échec d’émission, quelqu'un voit une explication ?
C'est quand même ennuyeux de ne pas être averti en cas d'erreur lorsque l'on rentre un adresse manuellement...

fritz2cat
04/12/2013, 15h58
Oublie ceci:
Envoyé par Nowwhat

Finalement, OVH cumule le retours et rend le résultat visible dans le Manager. Va voir dans ton Manager lié à ton hébergement.
Ca ne concerne que les envois faits depuis des pages de ton site web via la directive php mail()

L'envoi par ssl0.ovh.net via le port smtp/submission/587 c'est ce qu'il faut faire. Sachant qu'on est limité à 100 envois par heure. 3 mails à 30 destinataires, ça compte pour 90.
Le refus est notifié par une erreur 555 et le serveur ne prend pas le message en charge.

Zarus
04/12/2013, 15h25
Merci pour vos réponse.

Je n'ai pas été très clair sur ce point, les absences de notification se produisent sur des clients lourds (j'ai le problème en utilisant Thunderbird), ou via un web mail hébergé ailleurs qui utilise le smtp d'OVH. Je précise également que l'utilisation des comptes mails du domaine est tout a fait standard (pas d'envois scriptés ou groupés, il s'agit d'une utilisation par des utilisateurs lambda).

Citation Envoyé par Nowwhat
Finalement, OVH cumule le retours et rend le résultat visible dans le Manager. Va voir dans ton Manager lié à ton hébergement.
Je n'ai pas trouvé ? Il y a bien un accès pour configurer le "catch all" mais qui est désactivé et non activable, je n'ai rien vu d'autre qui pourrait être lié aux retours de mails...

Citation Envoyé par Nowwhat
De plus, envoyer des mails vers des gens qui n'existe pas, et ta bureau de la poste va te punir. Ce que fait OVH ..... etc là, pas glop.
J'éspère qu'on a quand même le droit a quelques fautes de frappe Et la fonctionnalité étant parfaitement fonctionnelle via le webmail OVH je penche plutot pour un problème de configuration (coté clients) ou à des restriction coté serveur.

Citation Envoyé par fritz2cat
-> quel est le serveur SMTP utilisé pour le courrier sortant ?
La configation SMTP est la suivante :
Serveur mail.mondomaine.fr ou ssl0.ovh.net (j'ai testé les deux), port 587, connexion en STARTTLS et mot de passe en clair.

fritz2cat
04/12/2013, 09h51

Citation Envoyé par Zarus
Je suis le seul à être confronté à ce problème ou personne n'a de solution ?
Si tu n'emploies pas le Webmail mais un logiciel comme Outlook, Windows Mail ou Thunderbird:
-> quel est le serveur SMTP utilisé pour le courrier sortant ?

Nowwhat
04/12/2013, 09h20
Bonjour,

C'est le prix à payer si tu utilise la fonction mail() de PHP dans tes scripts sur ton hébergement.
Finalement, OVH cumule le retours et rend le résultat visible dans le Manager. Va voir dans ton Manager lié à ton hébergement.
De plus, dès qu'il y à trop des echecs, il te bloque l'envoi par mail() .....
C'est aussi exactement pourquoi l'envoi des mails se paramètre avec l'option "smtp", disponible dans toutes les CMS. T'as le résultat disponible, comme le web-mail-interface.
En gros, le mail() de PHP est facile, et parfait pour ceux qui ne cherchent pas à comprendre.
L'option "smtp'" pour envoyer des mails est plus sérieux.

Sache comprendre aussi la différence:
Si tu essaie d'envoyer un mail vers un domaine non-existant, genre "@blablablabla.bla", le résultat est disponible directement: cette destination n'existe pas. C'est comme envoyer une lettre vers un ville qui n'existe pas. ta lettre ne va même pas partir de ton bureau de la poste. On te la ramène de suite.
Mais si "@blablablabla.bla" existe, mais l’utilisateur "personne@blablablabla.bla" n'existe pas (n'habite pas la) le domaine "@blablablabla.bla" peut décider de ne pas prevenit l'émetteur (toi !) de suite car "@blablablabla.bla" ne va pas divulguer quel mail valable, et quel mail ne l'es pas. Les spammeurs adorent ça.
Pareil: la lettre va vers la ville ... mais une fois la bas, le facteur dans cette ville trouve pas la personne/rue. Ta lettre va rester quelques semaines (mois !) sur le bureau, puis il sera renvoyé (comme La Poste en France - ils appliquent les mêmes délais).

De plus, envoyer des mails vers des gens qui n'existe pas, et ta bureau de la poste va te punir. Ce que fait OVH ..... etc là, pas glop.

Zarus
04/12/2013, 09h02
Je suis le seul à être confronté à ce problème ou personne n'a de solution ?

Zarus
26/11/2013, 13h37
Bonjour,

J'utilise les services de mails associés à un hébergement web et nom de domaine OVH.
Lorsque j'envoie un mail vers un destinataire inexistant (domaine existant mais nom de destinataire incorrect), je ne reçoit pas de notification d’échec d'envoi si le mail a été envoyé d'ailleurs que du webmail OVH.
Par contre je reçoit bien une notification si j'envoie le mail du webmail ou vers un domaine inexistant.

Existe t-il une configuration particulière à effectuer pour bien recevoir ces notifications ?