OVH Community, votre nouvel espace communautaire.

impossible d'interpreté php3


euroc
17/11/2013, 16h47
Ok,
Sur release 3,
il faut cliquer sur la gauche sur
1 serveur
2 Serveur Web Apache
3 Sur l'onglet Configuration globale
4 Édition des fichiers de configuration
5 sélectionnes dans le menu déroulant le fichier httpd.conf celui de ton nom de domaine, ex: toto.httpd.conf
6 modifier (exemple de buddy)
AddHandler php5-script .php
AddType text/html .php

par

AddHandler php5-script .php .php3
AddType text/html .php .php3"

buddy
17/11/2013, 16h16
tu pourrais expliquer la démarche / ce que tu as modifié ?
çà pourrait servir à d'autre

euroc
17/11/2013, 16h09
Merci buddy et Gaston_Phone,
enfin de compte j'ai trouvé en modifiant le fichier toto.fr.conf (celui du nom de domaine).
Merci à vous 2

euroc
17/11/2013, 13h40
Non non, je n'ai pas de problème en php (le code fonctionne, il n'affiche pas la source), seulement en php3.

Gaston_Phone
17/11/2013, 13h33
Donc ton problème n'est pas lié au php3. Il est général à tout le PHP.

As-tu bien activé les daemons PHP et APACHE ?

euroc
17/11/2013, 13h12
Oui bien sur, un exemple tout simple:
echo "coucou!!!";
echo phpinfo;
?>
j'ai la source qui s'affiche sur le navigateur.

Gaston_Phone
17/11/2013, 13h09
Est-ce que les scripts xxx.php sont interprétés correctement ?

euroc
17/11/2013, 12h48
Merci encore, mais toujours le même problème, il affiche la source.

buddy
17/11/2013, 11h26
Salut,

je ne la connais pas du tout désolé ...

mais apparement, il faudrait se connecter en ssh.
ouvrir le fichier /etc/httpd/conf.d/php.conf avec nano ou vi

si tu trouves 2 lignes ressemblant à çà
Code:
AddHandler php5-script .php
AddType text/html .php
ajouter .php3 à chacune
donc :
Code:
AddHandler php5-script .php .php3
AddType text/html .php .php3
sauvegarder les modifications

et taper /etc/init.d/httpd restart (cette ligne relance le serveur Apache/PHP)

et esayer.

euroc
17/11/2013, 11h14
Merci pour ta réponse rapide, je suis en ovh release 3

buddy
17/11/2013, 11h05
Salut,

l'extension est juste php3 ou le code est du PHP 3 non compatible php 5 ?
car l'astuce que tu utilises permet simplement de dire à php 5(.2 surement) de lire les page .php3
mais si le code n'est pas compatible, il n'y aura pas de miracle ... si le code n'est pas compatible tu devrais voir une erreur dans les logs erreur apache

tu as trouvé cette ligne ou ? elle est bien adaptée à ta config ?

si c'est une page seule, tu peux modifier l'extension en .php , si après c'est un CMS ou autre çà va devenir plus compliqué ...

ovh release 1 ou 2 ou 3 ?

euroc
17/11/2013, 11h00
Bonjour à tous,
Je suis sur ovh release, quand je lance une page en php3, il affiche la source sur le navigateur,
en cherchant sur internet pour ce type de pb, il conseille en général d’inséré dans le fichier httpd.conf "AddType application/x-httpd-php .php .php3 .htm .html" puis redémarrer le serveur,
j'ai toujours le même problème, avez vous eu ce problème?
Merci à vous