OVH Community, votre nouvel espace communautaire.

Comment upgrader Squeeze -> Wheezy ?


ortoloj
15/11/2013, 11h48
Problème résolu.

Le support téléphonique de OVH m'a confirmé que la distro Debian 7 Wheezy, est bien disponible pour des réinstall par l'API RestFul.

Merci beaucoup de votre aide.

Jean Ortolo

ortoloj
14/11/2013, 22h44
Ok

Donc voilà.

Comme je ne reçois pas de réponse de OVH sur le support depuis 4 ou 5 jours, je sais que je peux simplement réinstaller mon VPS Classic 3 avec l'API RestFul, et je sais comment faire.

Mais... parmi les distributions proposées, je ne sais pas s'il y aura Debian Wheezy ?

Celà ne me gêne pas de tout réinstaller, en toute sécurité.

Comme c'est la procédure ultra-classique, j'ai simplement besoin de savoir si cette distro : Debian Wheezy, est disponible pour une réinstallation d'un VPS Classic 3.

Ou éventuellement la plus récente ( son nom m'échappe ).

Merci beaucoup de vos réponses.

Bien amicalement.

Jean François Ortolo

ortoloj
13/11/2013, 21h25
Rebonjour

Le problème de migrer mon VPS Classic 3 de Squeeze vers Wheezy, me semble plus que délicat.

Le contenu de /etc/apt/sources.list , comporte deux sources :

http://debian.mirrors.ovh.net/debian/ , et

http://security.debian.org

Le premier pour la distro OVH'like , et la deuxième pour les updates

Binaires et sources pour les deux, avec seulement le main ( pas de contrib ni de non-free )

Le problème, c'est que OVH livre le VPS Classic 3 avec Squeeze installé, mais je ne peux pas savoir, si le fait de remplacer squeeze par wheezy, tout en gardant ces deux urls telles quelles, suffira pour que la migration ne se heurte pas à des problèmes de dépendances, et autres joyeusetés de Debian.

Si je fais cette migration, c'est un aller sans retour, et si le VPS plante, c'est moi qui vais demander après à OVh de réparer ?

Je trouverais beaucoup plus logique, de m'adresser à OVH pour procéder à cette migration, après laquelle je pourrai facilement remettre mon site et sa base de données, dont j'ai des sauvegardes quotidiennes.

J'ai envoyé avant-hier ma demande de faisabilité en ce sens au support, et je n'ai pas de réponse.

C'est vrai que je me suis présenté avec mon prénom "Jean Francois" au lieu de Jean, mais bon ils doivent surtout être occupés après le 11 Novembre... ;(

Merci beaucoup de vos réponses.

Bien amicalement.

Jean Ortolo

ortoloj
13/11/2013, 08h28
Rebonjour Nowhat

Donc j'ai théoriquement le droit de procéder à cette migration.

Je sais que les VPS Cloud, sont livrés actuellement avec Wheezy.

Je ne tiens pas à payer plus cher pour un Cloud.

Plutôt que je fasse la migration Squeeze -> Wheeze moi-même, j'envisage de la confier à OVH.

Deux questions :

- Est-ce possible de demander à OVH de faire cette migration, et à quelles conditions ?

- OVH, ne va-t-il pas procéder lui-même à cette mise à jour dans le futur, pour les VPS Classic 3 ?

Merci beaucoup de vos réponses.

Amicalement.

Jean François Ortolo

Nowwhat
12/11/2013, 19h40
Je vous confirme que Wheezy (version 7.2) possède ces versions 'PHP 5.4.4':
Code:
ii  php-auth                                      1.6.2-1                     all                         PHP PEAR modules for creating an authentication system
ii  php-pear                                      5.4.4-14+deb7u5             all                         PEAR - PHP Extension and Application Repository
ii  php5                                          5.4.4-14+deb7u5             all                         server-side, HTML-embedded scripting language (metapackage)
ii  php5-cgi                                      5.4.4-14+deb7u5             i386                        server-side, HTML-embedded scripting language (CGI binary)
ii  php5-cli                                      5.4.4-14+deb7u5             i386                        command-line interpreter for the php5 scripting language
ii  php5-common                                   5.4.4-14+deb7u5             i386                        Common files for packages built from the php5 source
ii  php5-curl                                     5.4.4-14+deb7u5             i386                        CURL module for php5
ii  php5-dev                                      5.4.4-14+deb7u5             i386                        Files for PHP5 module development
ii  php5-gd                                       5.4.4-14+deb7u5             i386                        GD module for php5
ii  php5-imap                                     5.4.4-14+deb7u5             i386                        IMAP module for php5
ii  php5-mcrypt                                   5.4.4-14+deb7u5             i386                        MCrypt module for php5
ii  php5-mysql                                    5.4.4-14+deb7u5             i386                        MySQL module for php5
Après le saut vers 7.0 (Wheezy) il y aura d'autres mises à jour 'dist-upgrade' à faire. Je ne suis pas sur si on saute directement de 6.x vers 7.2.

(détail: je possède la version '32 bits', je présume que pour les '64' c'est la même version des paquets)

ortoloj
12/11/2013, 19h14
Citation Envoyé par Nowwhat
'Soir.

Tu y été presque:

https://wiki.debian.org/fr/SourcesList

En gros: c'est avec ce fichier que tu indique avec quel version tu désire 'synchroniser'.
Pour l'instant, c'est 'Squeeze'. Change toutes les 'Squeeze' pour 'Wheezy' et # apt-get update
# apt-get upgrade
# apt-get dist-upgrade
va te donner du boulot http://www.debian.org/releases/stabl...rading.fr.html

Bonjour Monsieur

Je suis déjà allé sur la page de Debian que vous indiquez, et j'ai noté toutes les manip à faire avant et après la mise à jour.

Mais, je croyais que Squeeze avait quand même déjà PHP > 3.3.3-7 ?

Pour les manips, je sais à peu près, que les services Apache et MySQL devront être arrêtés avant la mise à jour, et toutes les autres manip, dont celles sur MySQL 5.5 ( j'ai noté toutes les manips à faire, et il faudra refaire la base de données à partir d'une sauvegarde *.sql , après avoir arrangé certaines table de la bdd maître mysql + un mysql_upgrade avec les paramètres qui vont bien pour empêcher l'accès distant et la prise en compte des privilèges.

Merci de me dire s'il y a lieu de faire d'autres manips ( sur les logiciels après la mise à jour ) que pour MySQL.

Respectueusement.

Jean François Ortolo

Nowwhat
12/11/2013, 19h03
'Soir.

Tu y été presque:
Citation Envoyé par ortoloj
..... Si oui, que mettre dans /etc/apt.sources.list , qui semble-t-il, doit contenir obligatoirement, les sources main de Debian et de OVH.
https://wiki.debian.org/fr/SourcesList

En gros: c'est avec ce fichier que tu indique avec quel version tu désire 'synchroniser'.
Pour l'instant, c'est 'Squeeze'. Change toutes les 'Squeeze' pour 'Wheezy' et # apt-get update
# apt-get upgrade
# apt-get dist-upgrade
va te donner du boulot http://www.debian.org/releases/stabl...rading.fr.html

ortoloj
12/11/2013, 18h52
Bonjour

J'ai un VPS Classic 3 depuis environ février 2013.

Il a été livré avec Squeeze installé, et il fonctionne depuis très bien, mais il n'a que jusqu'à PHP 5.3.3-17.

Or, j'ai besoin de PHP >= 5.3.10 pour installer JsMin, en vue de minifier à la volée, des scripts Javascript de mon site.

Celà nécessite-t-il de passer à Wheezy ?

Si non, comment faire pour upgrader PHP ?

Si oui, que mettre dans /etc/apt/sources.list , qui semble-t-il, doit contenir obligatoirement, les sources main de Debian et de OVH.

Merci beaucoup de vos réponses.

J'ai déjà essayé à l'instant, de mettre à jour le système squeeze, en faisant :

# apt-get update
# apt-get upgrade
# apt-get dist-upgrade

Résultat : 0 paquets supprimé, ajouté ou mis à jour.

Tout se passe, comme si le fichier /etc/apt/sources.list , n'était pas assez permissif ( il ne permet que le main de Debian et OVH ), pour accepter des paquets plus récents.

Amicalement.

Jean François Ortolo