OVH Community, votre nouvel espace communautaire.

La connexion à la base <...>; sur <...> a échoué. Access denied (using password : NO)


Titeufvelo
22/10/2013, 17h44
Après manipulations avec l'aide de Gaston, on en déduit ce qui suit ...

Le problème est totalement indépendant d'OVH ...

Tout fonctionne en local tout simplement parce qu'en local, ma base de données n'a pas de mot de passe ...

Ceci dit, la base de données est accessible et on peut y lire les données ...

Le problème est donc inhérent à ma plateforme de développement Webdev.
Il semble que les commandes de lecture des enregistrements (hlitrecherche par exemple) n'envoie pas le mot de passe de ma base de données chez OVH ...

Je vais de ce pas sur le forum de PcSoft afin de poser mon problème ...

Gaston_Phone
22/10/2013, 16h23
Je viens de t'envoyer un MAIL personnel.

Titeufvelo
22/10/2013, 16h21
Je suis rassuré que tu considères que c'est une bonne nouvelle, j'attrape la corde que tu m'as tendue ... me reste maintenant à me hisser au sommet ...

Je ne connais pas php , c'est pour cette raison qu'ayant de l'expérience avec windev, j'ai choisi webdev pour le développement de mon site.

Peux-tu me donner plus d'explications sur ce que je peux faire comme manipulations ou modifications?

Gaston_Phone
22/10/2013, 16h19
Pour MySQL chez OVH le nom de la base et le nom de l'utilisateur SQL sont identiques.

D'ailleurs le script dit bien : $DBName = $DBowner;

Gaston_Phone
22/10/2013, 16h16
Citation Envoyé par Titeufvelo
J'ignore en fait pourquoi j'ai un abonnement mutualisé ... je ne me souviens pas avec eu le choix quand j'ai souscrit mon abonnement ...
Non, tu as bien le choix.
Mais comme tu travailles déjà dans un environnement Windows sur ton PC, je suppose que tu as sélectionné le même type d'environnement .

Titeufvelo
22/10/2013, 16h16
Désolé pour la faute "je ne me souviens pas AVOIR eu le choix quand j'ai souscrit mon abonnement ..." ...

Autre indice ... "fcwbhain" du message d'erreur de ton programme test est en fait mon nom d'utilisateur ... "fcwbhainsiteht" du message d'erreur de mon application est le nom de ma base de données !!!

Gaston_Phone
22/10/2013, 16h14
Citation Envoyé par Titeufvelo
Non j'ai le message d'erreur ci-dessous ...
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'fcwbhain'@'10.0.103.185' (using password: NO) in /homez.707/fcwbhain/www/testbdpaul.php on line 87
mysql_connect= - Erreur=Access denied for user 'fcwbhain'@'10.0.103.185' (using password: NO)
Bonne nouvelle.

Ton problème est lié à l'accès à ta base de données.
Règle ce problème d'accès grâce à ce script indépendant de ta base données.
Et après, seulement, tu reviendras sur ton site.

Titeufvelo
22/10/2013, 16h09
Non j'ai le message d'erreur ci-dessous ...

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'fcwbhain'@'10.0.103.185' (using password: NO) in /homez.707/fcwbhain/www/testbdpaul.php on line 87
mysql_connect= - Erreur=Access denied for user 'fcwbhain'@'10.0.103.185' (using password: NO)

PEUT-ETRE UN INDICE ...

Avec ton programme test, il m'indique user "fcwbhain@10.0?1.103.185" et avec mon application ... "fcwbhainsiteht'@'10.0.103.185" ...

J'ignore en fait pourquoi j'ai un abonnement mutualisé ... je ne me souviens pas avec eu le choix quand j'ai souscrit mon abonnement ...

Merci pour ton aide rapide ... et j'ai l'impression qu'elle sera efficace !!!

Gaston_Phone
22/10/2013, 16h02
Quand je vois le temps sur le temps pour afficher la page d'accueil de http://www.pcsoft.fr/webdev/ebook/, j'ai quelques inquiétudes.

Au fait, pourquoi ton site nécessite-t-il un hébergement mutualisé Windows ?

Gaston_Phone
22/10/2013, 15h58
Citation Envoyé par Titeufvelo
Je suis certain de mes identifiants, mot de passe y compris ...
Donc le test avec ce script OVH - Test de Base de Données via un script devrait être correct.

Essaie ce script en faisant des séries de 10 tests consécutifs.

Titeufvelo
22/10/2013, 15h52
J'ai développé un site php avec webdev18. Ce site dynamique est relié à une base de données MySQL.

En local, je travaille avec EasyPHP (Apache 2.4.4 - Php 5.4.14 et Mysql 5.6.11) et tout fonctionne superbement bien ...

J'ai créé ma base de données et j'y ai accès par l'outil "Manager".
J'ai déployé mon site avec l'outil fourni par webdev.

J'ai un abonnement mutualisé "pro".

Mon serveur est "mysql51-57.pro"

Au début, tout allait très bien via OVH et je ne comprends pas pourquoi j'ai maintenant un problème ...

Mes pages web sont basées sur des tables qui, après sélection d'une ligne, donnent accès à la fiche complète de l'élément sélectionné.

Pour certaines pages, les pages "tables" s'affichent très bien pour d'autres, 9 fois sur 10, cela ne fonctionne pas.
De plus, pour les pages qui fonctionnent, après la sélection d'une ligne, le site se plante et j'ai le message "Access denied for user '...'@'...' (using password: NO)".

J'ai commis la maladresse de changer le mot de base de ma base de données et d'après le service technique, le changement de mot de passe ne se serait pas répercuté correctement sur tous les fichiers de ma base de données.

Sur conseil du service technique, j'ai remis le mot de passe initial mais rien ne change ...

Je suis bloqué sur ce problème depuis près de 3 semaines et ne trouvant pas de solution ni d'indice probant, vous êtes ma dernière chance de solutionner mon problème.

Idéalement, je dois présenter le site jeudi ...

Un membre inscrit peut se connecter sans problème, ça marche ...

Je suis certain de mes identifiants, mot de passe y compris ...