OVH Community, votre nouvel espace communautaire.

Configuration Reverse Dns


trendles
10/12/2013, 20h20
Bonjour je me trouve face à un problème similaire sauf que moi je suis sous prestashop et en vps chez ovh,pour les mail j'ai un compte exchange
Lorsque je tape la commande nslookup voilà le résultat:
Code PHP:
nslookup 37.187.53.222
Server
:         127.0.0.1
Address
:        127.0.0.1#53

Non-authoritative answer:
222.53.187.37.in-addr.arpa      name 222.ip-37-187-53.eu.

Authoritative answers can be found from:
53.187.37.in-addr.arpa  nameserver ns104.ovh.net.
53.187.37.in-addr.arpa  nameserver dns104.ovh.net.
ns104.ovh.net   internet address 213.251.128.148
ns104
.ovh.net   has AAAA address 2001:41d0:1:1994::1
dns104
.ovh.net  internet address 213.251.188.148
dns104
.ovh.net  has AAAA address 2001:41d0:1:4a94::
Comme je le comprend, (avec mon peu de connaissance) j'ai bien un rDNS de configuré mais le problème c'est que ce n'est pas mon vps mais une ip d'ovh donc mon Dkim... n'est pas reconnu car il est installé sur mon serveur...
Mon raisonnement est il correct ? que puis je faire pour remédier à mon soucis?
Merci beaucoup.

cassiopee
26/09/2013, 16h19
Cool

geoffray
26/09/2013, 15h00
J'ai fait la demande à VPS.net sur leur chat, ils ont dit qu'il fallait ouvrir un ticket, chose faite et désormais en place. Je prends mon 10/10 sur mon test de mail auprès de l'anti-spam, c'est parfait!

Merci bien Cassiopee!

geoffray
26/09/2013, 13h52
D'un seul coup c'est beaucoup plus clair ;-)
Merci!

cassiopee
26/09/2013, 11h04
Citation Envoyé par geoffray
Heuuuu dans Wordpress il n' a pas de configs SMTP, je suis formel.
Oui, si on veut : par défaut, avec un WordPress tout seul, tout simple, l'envoi
des messages se fait via la fonction PHP mail() donc en utilisant le serveur de mail
de la machine dans laquelle est installé WordPress. Certains plugins de WordPress
permettent d'y accéder, voire de modifier ce comportement (notamment dans le but
d'utiliser un autre serveur SMTP).

Après comment il récupère un smtp pour envoyer les mails, je n'en ai aucune idée... j'imagine qu'il fait un essai sur "smtp.nomdomaine.com"
Le message d'erreur vu précédemment fait référence à l'adresse IP 176.67.172.53.
C'est donc cette adresse IP qui est utilisée par WordPress pour émettre les messages.

Sinon chez VPS.net, mon ip est bien associée au domaine "1max2peche.com" avec un nom de machine "server".
Non, ce n'est pas le cas, la preuve :

Code:
# nslookup 176.67.172.53

** server can't find 53.172.67.176.in-addr.arpa.: NXDOMAIN
Il n'y a aucun nom de reverse associé à cette adresse IP.

En revanche, l'association oppposée existe :

Code:
# nslookup server.1max2peche.com

server.1max2peche.com	canonical name = 1max2peche.com.
Name:	1max2peche.com
Address: 176.67.172.53
Autrement dit, l'association "server.1max2peche.com => 176.67.172.53" existe.
Ce qui manque, c'est l'association inverse "176.67.172.53 => server.1max2peche.com",
ce que l'on appelle le reverse.

Donc il y a bien un truc qui ne va pas, et je pencherais plutôt du côté OVH qui gère
la zone DNS de ce domaine... puisqu'il n'y a pas d'autres options de configuration du côté
de l’hébergeur. Ou alors des choses à configurer directement sur la machine
server.1max2peche.com? Vu que les DNS pointent sur les DNS OVH, je serais tenté
de dire non...
Cela n'a aucun rapport avec OVH ni même le DNS : c'est le reverse de l'adresse IP
que vous devez configurer.

Or cette adresse IP est chez vps.net. Le seul endroit où il sera éventuellement possible
de modifier le reverse est chez vps.net. Au besoin, interrogez le support de vps.net.

geoffray
26/09/2013, 10h15
Heuuuu dans Wordpress il n' a pas de configs SMTP, je suis formel. Après comment il récupère un smtp pour envoyer les mails, je n'en ai aucune idée... j'imagine qu'il fait un essai sur "smtp.nomdomaine.com"


Sinon chez VPS.net, mon ip est bien associée au domaine "1max2peche.com" avec un nom de machine "server". Donc il y a bien un truc qui ne va pas, et je pencherais plutôt du côté OVH qui gère la zone DNS de ce domaine... puisqu'il n'y a pas d'autres options de configuration du côté de l’hébergeur. Ou alors des choses à configurer directement sur la machine server.1max2peche.com? Vu que les DNS pointent sur les DNS OVH, je serais tenté de dire non...

D'ailleurs, j'ai configuré mes SPF et DKIM sur OVH et cela fonctionne bien, les changements ont bien été pris en compte lorsque je vérifie avec un mail tester.


Vous la comprenez comment cette phrase?
You cannot associate more than one domain name with a single IP address.
Your IP 176.67.172.53 is associated with the domain 3(NXDOMAIN).

C'est quoi le domain 3(NXDOMAIN)? Ce serait pas un serveur OVH, du coup quand il cherche le reverse sur "server" il ne le trouve pas? Alors qu'il faudrait que ce soit plutôt sur mon domaine? Est-ce une piste?

cassiopee
25/09/2013, 21h09
Citation Envoyé par geoffray
Ok, je n'y étais pas désolé ^^


Donc comme j'ai tout fait via l'interface Manager d'OVH, je suppose que j'utilise les serveurs OVH.
Vi vi vi, là c'est un peu comme si tu nous disais "la marque de ma voiture ?
Ben je sais pas trop, elle a 4 roues, un volant ... ah et une carrosserie !" ...

ça n'aide pas vraiment

Le soucis c'est qu'avec WordPress, il n'y a pas de config smtp... c'est de la magie ça marche tout seul ;-)
Mais bien sûr, la marmotte, le papier alu, toussa toussa

Non, d'après le message d'erreur que tu montres par la suite, c'est ton VPS
chez vps.net qui émet les messages (adresse IP 176.67.172.53)

C'est donc lui qui te sert de serveur SMTP dans le sens sortant (toi -> Internet).

Donc il faut que tu ailles dans le manager de vps.net et c'est là que tu pourras,
éventuellement, si c'est permis par vps.net, configurer le reverse associé à ton VPS
pour y indiquer "server.1max2peche.com".

geoffray
25/09/2013, 17h58
Comme je n'arrive pas à trouver la possibilité de faire un PTR (et je ne sais pas sur quoi...) j'ai vu qu'il y a une clause redirect dans les champs de type SPF.

Cela sert pour les spams visiblement, est-ce que la clause redirect m'aiderait? Là c'est trop complexe pour mes compétences.... mais en attenant j'ai toujours une pénalité sur SpamAssassin à cause de l'absence de rDNS :


-1.274 RDNS_NONE Delivered to internal network by a host with no rDNS
This may be a false-positive, please check the reverse DNS test below to confirm or not this issue


Et quand je regarde plus bas dans le détails, voilà le message :

Reverse DNS lookup or reverse DNS resolution (rDNS) is the determination of a domain name that is associated with a given IP address.
Some companies such as AOL will reject any message sent from a server without rDNS, so you must ensure that you have one.
You cannot associate more than one domain name with a single IP address.
Your IP 176.67.172.53 is associated with the domain 3(NXDOMAIN).
Nevertheless your message appears to be sent from "server.1max2peche.com".


You may want to change your pointer (PTR type) DNS record and the host name of your server to the same value.



Je vois bien qu'il y a un soucis... mais je ne sais comment le résoudre!
Merci d'avance

geoffray
25/09/2013, 17h48
Ok, je n'y étais pas désolé ^^


Donc comme j'ai tout fait via l'interface Manager d'OVH, je suppose que j'utilise les serveurs OVH. Le soucis c'est qu'avec WordPress, il n'y a pas de config smtp... c'est de la magie ça marche tout seul ;-)

En tous cas, quand j'observe ma zone DNS, j'ai smtp.1max2peche.com, pop.1max2peche.com et mail.1max2peche.com qui redirigent tous vers ns0.ovh.net

cassiopee
25/09/2013, 14h04
( ce n'est pas ça le souci mais pourquoi utiliser "redirect.ovh.net" plutôt que "mx1.ovh.net" directement ? )

Là tu me parles du sens rentrant (d'Internet vers ton nom de domaine), du serveur indiqué en tant
que MX au niveau DNS.

Moi je parlais du serveur SMTP que tu utilises pour émettre les messages de ta newsletter
(sens "sortant", depuis ton nom de domaine vers Internet).

geoffray
25/09/2013, 13h44
J'ai redirect.ovh.net pour le serveur mx1 et ns103.ovh.net et dns103.ovh.net pour les dns primaires et secondaires. 3 enregistrements de type A pour mon domaine principal et les sous-domaines.

Une piste?

cassiopee
25/09/2013, 09h06
Citation Envoyé par geoffray
J'utilise le serveur mail de chez Ovh
Lequel précisément ?

geoffray
25/09/2013, 08h58
J'utilise le serveur mail de chez Ovh, j'ai préféré tout gérer chez eux et bénéficier de leurs serveurs Dns et mails.

Mon serveur perso est un dédié chez vps.net

Jusqu'à présent tout fonctionne bien en ayant tout configuré via le manager ovh. Mon serveur dédié ne fait que gérer les virtualhost et les bd sql en fait.

Merci d'avance

cassiopee
25/09/2013, 08h01
Où est situé le serveur de messagerie ? Dans ton serveur perso ? Chez OVH ?

Si c'est dans un serveur perso et que tu es en ADSL, le seul qui puisse modifier le reverse
de ton adresse IP est ton FAI. C'est loin d'être évident, ça va dépendre du FAI.

geoffray
25/09/2013, 06h20
Salut à tous,

J'ai un domaine chez ovh qui est redirigé sur un serveur perso. J'ai fait pointer les dns chez ovh car je ne voulais pas m'embêter sur le serveur perso, je ne maîtrise pas encore assez bien ce domaine pour gérer le dns et les mails.

J'ai plusieurs adresses mails, sous domaines, etc tout fonctionne bien... sauf pour l'envoi de newsletter où je n'ai pas de score maxi car je n'ai pas de reverse dns... il est pas content SpamAssassin même si les mails sont signés.

J'ai un hébergement mutualisé pour mon domaine, du coup l'interface est très limitée et je ne vois pas comment arriver à mettre un PTR dans ma zone dns et ce que je dois y mettre.

Mail : mail@1max2peche.com
Zone dns : 1max2peche.com et sous domaine jeu.1max2peche.com
Ip : plus en tête mais disons 122.211.12.24 pour l'exemple.

Si quelqu'un sait comment fair ou m'indiquer des choses à lire, ce serait bien!

Merci d'avance
Geoffray