OVH Community, votre nouvel espace communautaire.

MongoDB & Debian Wheezy


tubededentifric
10/09/2013, 19h15
Ayant le même problème, j'ai réinstallé mon serveur avec le kernel normal. MongoDB fonctionne maintenant !

De plus, d'après mes tests, mes IO sont presque 2 fois plus rapides en utilisant le kernel officiel à la place du kernel OVH !
Je ne regrette pas d'avoir réinstallé mon serveur... et je n'utiliserai plus jamais leur kernel...

eye
02/09/2013, 15h35
Merci pour l'info.

mpam
02/09/2013, 14h38
Citation Envoyé par eye
Bonjour,

Vous savez ce qu'apporte le noyau OVH ?
Si j'ai bien compris, essentiellement divers allègements (suppressions de fonctions inutiles sur un serveurs en général et sur les matos utilisés par OVH en particulier). Le gros bémol c'est le retrait du support des modules (apparemment ça crée des problèmes avec VirtualBox si je me souviens bien, à moins que ce soit un autre logiciel de virtualisation)

Après pour le pb de levince, ça peut être soit lié à la config OVH, soit au kernel plus récent que le kernel de la distrib (le kernel OVH est super récent en ce moment, dans les 3.10.x, donc peut-être pas hyper stable)

eye
02/09/2013, 14h22
Bonjour,

Vous savez ce qu'apporte le noyau OVH ?

levince
02/09/2013, 11h22
ok c'est confirmé..
Avec le noyau "normal" mongodb s'installe sans aucun problème.

Ca pourrait être a faire remonter au niveau "dev" chez OVH

levince
02/09/2013, 10h51
ah j'ai posté un peu vite peut-etre

http://stackoverflow.com/questions/1...system-node-no

apparemment ca serait le noyau spécial OVH qui ne plait pas à MongoDB.. je vais tenter une réinstallation avec le noyau "normal"

levince
02/09/2013, 10h47
Bonjour,

Je viens de prendre un kimsufi 4G pour pouvoir tester varnish, mongo, node.. et je bloque sur l'installation de mongodb, alors que je l'ai déjà installé sur un autre serveur debian sans le moindre souci.

donc la j'ai fait une installation distrib nue, avec le noyau OVH, debian 7 64 bits. J'ai essayé les deux packages dispo (mongodb metapackage, dispo par défaut dans les repositories debian et mongodb-10gen sur le repository fourni par mongodb directement)

donc

Code:
apt-get install mongodb
puis dans le log, j'obtiens a chaque fois ce genre de messages :

Code:
Mon Sep  2 11:37:49 [initandlisten] MongoDB starting : pid=12984 port=27017 dbpath=/var/lib/mongodb 64-bit host=ks*****.kimsufi.com
Mon Sep  2 11:37:49 [initandlisten] exception in initAndListen std::exception: boost::filesystem::exists: Permission denied: "/sys/devices/system/node/node1", terminating
Mon Sep  2 11:37:49 dbexit:
Mon Sep  2 11:37:49 [initandlisten] shutdown: going to close listening sockets...
Mon Sep  2 11:37:49 [initandlisten] shutdown: going to flush diaglog...
Mon Sep  2 11:37:49 [initandlisten] shutdown: going to close sockets...
Mon Sep  2 11:37:49 [initandlisten] shutdown: waiting for fs preallocator...
Mon Sep  2 11:37:49 [initandlisten] shutdown: lock for final commit...
Mon Sep  2 11:37:49 [initandlisten] shutdown: final commit...
Mon Sep  2 11:37:49 [initandlisten] shutdown: closing all files...
Mon Sep  2 11:37:49 [initandlisten] closeAllFiles() finished
Mon Sep  2 11:37:49 dbexit: really exiting now


Quel est le souci ?

Merci d'avance pour vos suggestions, je n'ai pas trouvé grand chose sur google.. ! Je ne vois pas trop a quoi s'applique le permissiondenied .. Est-ce qu'il faut que je change les droits du repertoire "/sys/devices/system/node" ? que faut il mettre ?