OVH Community, votre nouvel espace communautaire.

Problème smtp ssl - port 465 bloqué par fai


Nowwhat
28/08/2013, 22h30
Hummm.

Dans ce cas, pour garantir ton privacy, démarre petit avec un VPN comme, par exemple HMA, ou plus grand: location (dès dispo de nouveau) un KS à 3 €.
Installe ton MTA normalement, puis il suffit de monter le smtpd ssl sur une porte autre que la 465 ....

Pas croyable qu'il existe des FAI qui bloquent la 465 ... le 443, lui, ok.

Puis, mini troll: le trafix shaping aide à la neutralité ! "Un peu de bande passante pour tout le monde est mieux que 99 % pour 1 % - même quand il s'agit le fibre.

édit: ssl en UDP ? Nan, pas possible.

Informatoque
28/08/2013, 16h58
Citation Envoyé par Nowwhat
T'as compris recherché/vu/lu/testé que l'utilisateur/mot de passe sont codés d'une façon un peu spécial, et certainement pas à taper en clair après un USER et PASS ??
Oui j'ai recherché et j'ai trrouvé et j'ai réussi à me logguer en telnet mais pas a envoyer d'emails mais en tout cas ça se connecte avec user et pass hashés.

Citation Envoyé par Nowwhat
Pour bien moins que ça je changerai de FAI demain.
Le problème c'est que c'est eux qui font l'installation de la fibre dans ma rue et que je dois attendrer au moins janvier 2014 pour les virer (mais je pourrais garder la fibre quand même - l'infra est partagé entre FAI au Luxembourg). Le truc c'est que l'autre FAI/fournisseur téléphone mobile tango.lu est fortement soupçonné de faire du traffic shaping en fonction des protocoles (example: torrent). C'est pas super pour la neutralité.

Citation Envoyé par fritz2cat
Il va falloir passer par un VPN, un tunnel ou quelque chose du genre. Ou virer pt.lu qui est bien le seul à ma connaissance à bloquer le 465.
Serait il possible de faire une connection smtp ssl sur port 465 en udp et pas en tcp? Parce que d'après le FAI il ne bloque que le tcp sur port 465...

Nowwhat
28/08/2013, 09h39
pt.lu: pas vu - comme mon café du matin .....

Login: ns0.ovh.net:587 accepte mes AUTH LOGIN avec mail/mot de passe codé, mais bon, ce n'est pas ce que cherche Informatoc.

fritz2cat
28/08/2013, 07h44
FAI: pt.lu voir plus haut.
Login: uniquement en clair d'après les bannières ESMTP.

Nowwhat
28/08/2013, 07h21
Juste une question:
QUI (nom !) est ce FAI, qui bloque tout ce qui est essentielle pour utiliser d'une façon sécurisé le net ?

Ce 'fournisseur' qui te laisse que la porte 25wl-80-110-443, c'est qui ça ? Le point d'accès d'un dortoir d'un lycée ? Le patron hyper nerveux car les salariées ont tous ce foutu besoin de mettre leur profil FB à jour x fois par jour ?

Pour bien moins que ça je changerai de FAI demain.

Concernant le "telnet ip-de-ton-server 587"
Citation Envoyé par Informatoque
J'ai essayé mais le serveur refuse les commande USER et PASS
T'as compris recherché/vu/lu/testé que l'utilisateur/mot de passe sont codés d'une façon un peu spécial, et certainement pas à taper en clair après un USER et PASS ??

fritz2cat
27/08/2013, 22h09
Citation Envoyé par Informatoque
Croyez vous que le support ovh pourrait faire quelque chose?
A mon avis non, d'autant plus que l'infra qmail chez OVH est une très grosse installation avec des composants relativement anciens.

Il va falloir passer par un VPN, un tunnel ou quelque chose du genre. Ou virer pt.lu qui est bien le seul à ma connaissance à bloquer le 465.

Informatoque
27/08/2013, 22h03
Citation Envoyé par fritz2cat
Le port 465 se comporte différemment que 25 / 5025 /587.
Le port 465 ne permet pas de communication SMTP non chiffrée.

Essaie ceci:
Code:
>telnet ns0.ovh.net 587

220 ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net ESMTP
ehlo mail.example.com
250-ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-PIPELINING
250-8BITMIME
250 SIZE 109000000
quit
221 ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net


Connection to host lost.
Si ça fonctionne tu dois pouvoir envoyer du mail.

Sinon essaie avec 5025 au lieu de 587.
Avec les port 5025 et 587 la connexion marche mais pas en ssl ce qui est un problème pour moi.

D'autres solutions possibles?

Croyez vous que le support ovh pourrait faire quelque chose?

fritz2cat
27/08/2013, 19h10
En complément à mon post précédent, il semble que OVH ne supporte pas TLS.
Mon serveur Postfix dit ceci dans les mêmes circonstances:
Code:
> telnet my.mail.server 25
220 my.mail.server ESMTP (No spam allowed here.)
ehlo mail.example.com
250-my.mail.server
250-PIPELINING
250-SIZE 40960000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye


Connection to host lost.

fritz2cat
27/08/2013, 19h04
Le port 465 se comporte différemment que 25 / 5025 /587.
Le port 465 ne permet pas de communication SMTP non chiffrée.

Essaie ceci:
Code:
>telnet ns0.ovh.net 587

220 ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net ESMTP
ehlo mail.example.com
250-ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-PIPELINING
250-8BITMIME
250 SIZE 109000000
quit
221 ns0.ovh.net ssl0.ovh.net. You connect to mail171.ha.ovh.net


Connection to host lost.
Si ça fonctionne tu dois pouvoir envoyer du mail.

Sinon essaie avec 5025 au lieu de 587.

buddy
27/08/2013, 18h37
Salut,

heu ... un même serveur peut très bien faire du SSL ou des connexions non chiffrées. Le fait que l'ip soit la même, je ne vois pas ce que çà change. Le SSL peut être limité au port 465 et les connexions non chiffrés au 25 / 5025 / 587

Freemaster
27/08/2013, 18h33
Citation Envoyé par Informatoque
Le problème du smtp du FAI est que je veux pouvoir utiliser mon nom de domaine...
si ce n'est que ça, tu peux créer une entrée dns A qui pointe un sous domaine genre smtp.tondomaine.tld vers l'ip smtp de ton fai...

Informatoque
27/08/2013, 10h04
Citation Envoyé par fritz2cat
Code:
dig ssl0.ovh.net any

;; ANSWER SECTION:
ssl0.ovh.net.           86400   IN      CNAME   ns0.ovh.net.
No comment
Donc on peut se connecter en ssl sur le serveur "normal"? Bon à savoir ça.

Edit: j'ai essayé ça depuis une autre connexion et on peut le faire sur le port 465 mais ça ne marche ni sur le port 587 ni sur le 5025....

fritz2cat
27/08/2013, 08h38
Citation Envoyé par Informatoque
Je croyais que ce port n'était actif que sur le ns0.ovh.net ?

Je vais essayer de toute façon.
Code:
dig ssl0.ovh.net any

;; ANSWER SECTION:
ssl0.ovh.net.           86400   IN      CNAME   ns0.ovh.net.
No comment

Informatoque
27/08/2013, 08h27
Citation Envoyé par fritz2cat
Ou le port 5025 chez OVH.
Je croyais que ce port n'était actif que sur le ns0.ovh.net ?

Je vais essayer de toute façon.

fritz2cat
27/08/2013, 07h58
Ou le port 5025 chez OVH.

Informatoque
26/08/2013, 22h00
J'ai essayé mais le serveur refuse les commande USER et PASS

Nowwhat
26/08/2013, 21h53
Citation Envoyé par Informatoque
....
EDIT: j'ai essayé avec le port 587 et ça n'a pas l'air de marcher. En telnet le serveur répond contrairement à ce qui se passe avec le port 465 mais mon client mail dit que la connexion ne passe pas quand je met le port 587...
Donc il y a l'espoir.
Documente toi sur la protocole 'submission' == smtp.
En suite,
telnet IP-de-ton-serveur 587
puis, saisi 'à la main' un par un les commandes nécessaires pour envoyer un mail.
Contraire aux apparences, ce n'est pas si complique que cas. Les clients mail comme OE, Outlook, Thunderbird et j(en passe le font depuis des décennies - ce n'est pas très sorcier.

Dès que ça passe, tu sauras que ton client Mail peut faire la même chose.

Informatoque
26/08/2013, 21h43
Citation Envoyé par buddy
heu ... c'est écrit noir sur blanc sur le site du FAI ... il ne s'est pas trompé le mec ...
Après, comme indiqué sur le site du FAI tu peux utiliser le SMTP de ton FAI...
Oups j'avait pas vu ta réponse et j'ai posté la même chose...

Le problème du smtp du FAI est que je veux pouvoir utiliser mon nom de domaine...

EDIT: j'ai essayé avec le port 587 et ça n'a pas l'air de marcher. En telnet le serveur répond contrairement à ce qui se passe avec le port 465 mais mon client mail dit que la connexion ne passe pas quand je met le port 587...

D'autres idées?

Informatoque
26/08/2013, 21h39
Non non il disait vrai. C'est documenter sur leur site dans un pdf. Cette restriction ne touche que les clients fibre (c'est beau le progrès...). Ils n'autorise les connexions en port 465 que sur leur smtp (smtp.pt.lu). Tout le reste est bloqué. La seul option actuelle que j'ai est de me connecter en non ssl ce qui n'est pas vivable (surtout que j'ai quitté gmail pour des questions de vie privée (PRISM toussa toussa...)).

buddy
26/08/2013, 21h35
heu ... c'est écrit noir sur blanc sur le site du FAI ... il ne s'est pas trompé le mec ...
Après, comme indiqué sur le site du FAI tu peux utiliser le SMTP de ton FAI...

Gaston_Phone
26/08/2013, 21h14
Le gars du FAI t'a répondu n'importe quoi. Tu te rends compte le nombre de personnes bloquées avec en SMTP sur le port 465 avec Outlook ou Thunderbird.

A tester aussi : port 587 (avec authentification).

Informatoque
26/08/2013, 21h10
Citation Envoyé par Gaston_Phone
Peut-être une piste --> OVH - Configuration Thunderbird
Je vois pas bien la piste...?

avec le SSL

WEBMAIL: https://ssl0.ovh.net

POP3: ssl0.ovh.net:995

IMAP4: ssl0.ovh.net:993

SMTP: ssl0.ovh.net:465
Toujours le problème du port 465 bloqué en tcp (d'après le fai)

Gaston_Phone
26/08/2013, 21h01
Peut-être une piste --> OVH - Configuration Thunderbird

Gaston_Phone
26/08/2013, 20h58
Citation Envoyé par Informatoque
... Vous êtes bien content de venir au Luxembourg pour l'essence pourtant hein ^^
Beurk! Depuis chez moi (Middle Od Nowhere), ce n'est pas rentable.

Informatoque
26/08/2013, 20h47
Fai du Luxembourg (voir le PS dans mon premier message). pt.lu pour être précis. Il bloque ces ports pour lutter contre le spam.

Gaston_Phone
26/08/2013, 20h42
Quel FAI ?

Informatoque
26/08/2013, 20h42
Par le fai. Je suis sous mac donc pas d'antivirus et j'ai vérifier avec le fai et ils ont confirmé le blocage. Ils bloquent le port 25 ET 465.

Gaston_Phone
26/08/2013, 20h14
Port 465 bloqué par FAI ou par Anti-virus ?

Informatoque
26/08/2013, 20h12
Bonjour,

j'ai un problème pour utiliser le smtp ssl (ssl0.ovh.net). Le port 465 est apparement bloqué par mon fai. Y-a t'il un autre moyen?

Merci d'avance pour vos réponse.

PS: super l'accueil pour s'inscrire: inscription bloqué à l'étranger. Vous êtes bien content de venir au Luxembourg pour l'essence pourtant hein ^^

Informatoque