OVH Community, votre nouvel espace communautaire.

problème réception mail qmail


blumi31
02/08/2013, 16h38
Citation Envoyé par Nowwhat
Hummmm.

Il me semble avoir compris que tu (ton qmail) utilise le 'protocol' pop-before-smtp pour que tu puisse utiliser la porte '25' de ton serveur pour envoyer des mails.
J'ose jurer que j'en ai jamais entendu parler de imap-before-smtp.

Donc, pop (relève le mail de) ton ton compte db@xxxx.org - laisse tomber le imap - puis tu pourrait envoyer des mails sur la porte '25' vers ds mails hébergé sur ton serveur (xx@xxxxx.org) et les autres mails sur la terre entier (l'IP de ton SmartBidule en 3G sera accepté comme émetteur des mails, et le relay sera temporairement accepté).


Si tu pense que c'est un peu le bidouillage tout ça, et bien: t'as raison !!!
Le R2 et son qmail est une 'collection' de services qui date (du siècle dernier) - aujourd'hui, nos clients mail n'utilsent PAS la porte 25 pour transmettre des mails. la porte '25' est réservé uniquement pour les serveurs mail entre eux.

Pour te motiver que toi aussi tu abandonne pour le bon le transmission des mails sur la porte '25' de ton serveur, sache que les plupart des FAI (3G inclus) BLOQUE carrément tout accès à TOUT SERVEUR SUR LE NET la porte '25' (donc aussi TON SERVEUR) SAUF leur (lui du FAI) porte 25.

T'es prêt pour comprendre ceci: http://guides.ovh.com/ConfigurationEmail à 100 % maintenant

Salut Nowwhat,
je savais en effet que le port 25 est bloqué par les FAI.
C'est pour cela que mon Qmail ecoute aussi le port 8025 ... grâce à cela je contourne la restriction des FAI.
Actuellement, je vais me contenter d'utiliser 1 nouvelle adresse mail type pop@xxxx.fr qui sera juste la pour alimenter le open-smtp avec l'ip statique de mes smartphones. C'est un peux dégueulasse comme méthode, mais si vous en avez des plus propres je suis preneur !
Je pense que le SSL serait indiqué, mais actuellement je ne sais pas le configurer.

cassiopee
02/08/2013, 16h33
Citation Envoyé par blumi31
lol c toi le chef ... ca marche ! c'est bien du pop-before-smtp ...
ba je crois qu'on y est ! je te remercie !
Impec, content pour toi

Nowwhat
02/08/2013, 16h26
Hummmm.

Il me semble avoir compris que tu (ton qmail) utilise le 'protocol' pop-before-smtp pour que tu puisse utiliser la porte '25' de ton serveur pour envoyer des mails.
J'ose jurer que j'en ai jamais entendu parler de imap-before-smtp.

Donc, pop (relève le mail de) ton ton compte db@xxxx.org - laisse tomber le imap - puis tu pourrait envoyer des mails sur la porte '25' vers ds mails hébergé sur ton serveur (xx@xxxxx.org) et les autres mails sur la terre entier (l'IP de ton SmartBidule en 3G sera accepté comme émetteur des mails, et le relay sera temporairement accepté).


Si tu pense que c'est un peu le bidouillage tout ça, et bien: t'as raison !!!
Le R2 et son qmail est une 'collection' de services qui date (du siècle dernier) - aujourd'hui, nos clients mail n'utilsent PAS la porte 25 pour transmettre des mails. la porte '25' est réservé uniquement pour les serveurs mail entre eux.

Pour te motiver que toi aussi tu abandonne pour le bon le transmission des mails sur la porte '25' de ton serveur, sache que les plupart des FAI (3G inclus) BLOQUE carrément tout accès à TOUT SERVEUR SUR LE NET la porte '25' (donc aussi TON SERVEUR) SAUF leur (lui du FAI) porte 25.

T'es prêt pour comprendre ceci: http://guides.ovh.com/ConfigurationEmail à 100 % maintenant

blumi31
02/08/2013, 16h19
lol c toi le chef ... ca marche ! c'est bien du pop-before-smtp ...
ba je crois qu'on y est ! je te remercie !

cassiopee
02/08/2013, 16h12
Oui car c'est bien du "pop-before-smtp" et non du "imap-before-smtp"

blumi31
02/08/2013, 16h11
si ... ca fait une différence ? tout mes poste au bureau sont en imap aussi... jvais tenter en pop

cassiopee
02/08/2013, 16h07
Citation Envoyé par blumi31
le fichier open-smtp n'est pas alimenté avec l'ip de mon smartphone.
Est-ce que le logiciel de messagerie dans le smartphone ne serait pas configuré
pour relever la boîte aux lettres via IMAP plutôt qu'en POP3 ?

blumi31
02/08/2013, 16h06
et la jviens de vider open-smtp. il ne semble pas se ralimenter avec l'ip de mon bureau ...

blumi31
02/08/2013, 15h59
dsl j'avais pas vu ton message

Après avoir supprimé plus haut l'adresse IP dans ce fichier "open-smtp", est-ce que tu as
redémarré Qmail ?
-> oui plusieurs fois ...

Est-ce que tu réussis actuellement à émettre des messages à partir de ces adresses emails ?
-> cela dépend, tant que je fais tout cela depuis l'ip présente dans open-smtp, absolument tout fonctionne. Mais (il y a toujours un mais ...) quand j’utilise mes boites mails depuis un smartphone par exemple avec 3g :
peut importe si tel ou tel adresse de messagerie est installée, tant que le destinataire fait partit des "user"@xxxx.fr alors le mail part. Si le message a pour destinataire une autre adresse mail alors le mail ne part pas. et cela peut importe si je consulte avant en imap une des messagerie en "user"@xxxx.fr
le fichier open-smtp n'est pas alimenté avec l'ip de mon smartphone.

cassiopee
02/08/2013, 15h49
ça ne répond pas vraiment à mes questions

blumi31
02/08/2013, 15h33
ce post explique un peux tout ca ...
http://guides.ovh.com/EmailProblemesEtSolutions

cassiopee
02/08/2013, 15h33
Après avoir supprimé plus haut l'adresse IP dans ce fichier "open-smtp", est-ce que tu as
redémarré Qmail ?

Est-ce que tu réussis actuellement à émettre des messages à partir de ces adresses emails ?

blumi31
02/08/2013, 15h14
mon serveur heberge les mail en @xxxx.org
j'ai tout un tas de boite mail avec ce domaine la.
jb@xxxx.org db@xxxx.org etc...

je me doute que normalement lorsque depuis mon tel je consulte ma boite mail cela doit automatiquement mettre a jour le open-smtp en question avec l'ip depuis laquelle je consulte une des boite mail en @xxxx.org ...
seulement cela ne semble pas etre le cas ...

alors que cela devrait se faire automatiquement non ?

un "tail -f /etc/vpopmail/open-smtp" ne me donne rien de nouveau quand je récupère mes message ne IMAP depuis mon tel connecté en 3G à internet.
Et ce système est pas mal j'aimerai que cela marche....

cassiopee
02/08/2013, 14h46
Citation Envoyé par blumi31
en effet !

je n'avais pas remarqué que mes tests d’envois étés réalisé via le wifi de mon taf... c'est pour cela que ca marchait tout le temps ...
Arf

j'ai fais le test en désactivant le wifi de mon téléphone et cela ne marche plus donc super ...
Impec

mais lorsque j'ajoute un des comptes hébergé par mon serveur, il semble que cela n’alimente pas open-smtp.... comment faire le test ?
Gné ? Pas compris ce que tu veux dire/veux faire par "j'ajoute un des comptes hébergés
par mon serveur" ?

blumi31
02/08/2013, 14h14
en effet !

je n'avais pas remarqué que mes tests d’envois étés réalisé via le wifi de mon taf... c'est pour cela que ca marchait tout le temps ...
j'ai fais le test en désactivant le wifi de mon téléphone et cela ne marche plus donc super ... mais lorsque j'ajoute un des comptes hébergé par mon serveur, il semble que cela n’alimente pas open-smtp.... comment faire le test ?

cassiopee
02/08/2013, 13h54
Citation Envoyé par blumi31
j'ai fouillé dans /var/qmail/control et rien ne parle de RELAY...
Quel est le contenu des fichiesr :

- /var/qmail/control/rcpthosts
- /var/qmail/control/me

?

cassiopee
02/08/2013, 13h48
Citation Envoyé par blumi31
par contre dans /etc/vpopmail/open-smtp
j'ai :
Code:
88.xxx.xxx.252:allow,RELAYCLIENT="",RBLSMTPD="" 1375437739
ça c'est parce que tu as relevé ta boîte aux lettres récemment.

C'est ce que l'on appelle du "pop-before-smltp". Autrement dit, le serveur va te permettre
de faire du SMTP à travers lui (pour émettre des messages vers Internet) à condition
qu'au préalable (quelques minutes avant) tu aies fais un "POP", un relevé de ta boîte
aux lettres.

Contrairement au protocole SMTP, le protocole POP t'oblige à indiquer un mot de passe
afin de relever ta boîte aux lettres, c'est donc une forme d'authentification auprès du serveur.

C'est une autorisation temporaire, tu n'as rien à faire en particulier afin de retirer
cette adresse IP, elle se purgera toute seule.

blumi31
02/08/2013, 11h57
En cas j'ai recompilé /etc/tcp.smtp.

Ci dessous le résultat de mailradar.com
A regarder principalement : méthodes 5, 9, 10, 11,15.

Port 25 is Open at 178.xx.xxx.217
[Method 0]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 1]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: relaytest@mailradar.com
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 2]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 3]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM: <>
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 4]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 5]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST NOT PASSED]
[Method 6]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 7]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: <"relaytest@mailradar.com">
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 8]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: <"relaytest%mailradar.com">
<<< 511 sorry, you must specify a domain (#5.1.1 - chkuser)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[Method 9]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST NOT PASSED]
[Method 10]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: <"relaytest@mailradar.com"@[178.xx.xxx.217]>
<<< 250 ok
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST NOT PASSED]
[Method 11]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST NOT PASSED]
[Method 12]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: <@[178.xx.xxx.217]:relaytest@mailradar.com>
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 13]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO: <@[ns32xxxxx.ovh.net]:relaytest@mailradar.com>
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 14]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 511 sorry, you must specify a domain (#5.1.1 - chkuser)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[Method 15]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST NOT PASSED]
[Method 16]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 17]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
[Method 18]
<<< 220 ns32xxxxx.ovh.net ESMTP
>>> HELO mailradar.com
<<< 250 ns32xxxxx.ovh.net
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 553 sorry, that domain isn't allowed to be relayed thru this MTA (#5.7.1)
>>> QUIT
<<< 221 ns32xxxxx.ovh.net
[TEST PASSED]
All tested completed! Relays accepted by remote host.

blumi31
02/08/2013, 11h22
j'ai fouillé dans /var/qmail/control et rien ne parle de RELAY...

blumi31
02/08/2013, 11h18
j'ai supprimé la ligne dans /etc/vpopmail/open-smtp mais aucun changement ...

blumi31
02/08/2013, 11h09
ah par contre dans /etc/vpopmail/open-smtp j'ai :
Code:
88.xxx.xxx.252:allow,RELAYCLIENT="",RBLSMTPD="" 1375437739
l'ip en question est celle de mon lieu de travail.
dois je supprimer la ligne ?

blumi31
02/08/2013, 11h04
par contre dans /etc/vpopmail/open-smtp
j'ai :
Code:
88.xxx.xxx.252:allow,RELAYCLIENT="",RBLSMTPD="" 1375437739

blumi31
02/08/2013, 11h02
lol et pourtant j'ai aussi :

Code:
127.0.0.:allow,RELAYCLIENT="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
une autre idée ?

cassiopee
02/08/2013, 10h54
Les grands esprits se rencontrent

cassiopee
02/08/2013, 10h53
Egalement regarder le contenu du fichier "/etc/tcp.smtp".

Normalement ça devrait être quelque chose comme :

Code:
127.0.0.:allow,RELAYCLIENT="",QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"
:allow,QMAILQUEUE="/var/qmail/bin/qmail-scanner-queue"

blumi31
02/08/2013, 10h53
si je me souviens bien, je pense avoir plutôt modifié quelques lignes dans un fichier se rapportant à qmail quelque part dans /etc/ ... je ne pense pas avoir touché à /var/qmail/control ... c'est la première fois que je le vois ...

cassiopee
02/08/2013, 10h50
Aîe ...

La il faut regarder comment est configuré actuellement ton serveur Qmail.

Voir en particulier le contenu des fichiers dans le répertoire "/var/qmail/control".

blumi31
02/08/2013, 10h41
All tested completed! Relays accepted by remote host
ce qui confirme ce que je pensais ...

cassiopee
02/08/2013, 10h31
Ok, alors pour confirmer le souci, essaye avec des outils de tests classiques :

http://www.mailradar.com/openrelay/

http://mxtoolbox.com/diagnostic.aspx

http://www.abuse.net/relay.html

qui pourront confirmer ou non le problème.

blumi31
02/08/2013, 10h24
Citation Envoyé par cassiopee
Comment est-ce que tu t'es rendu compte de cela ? Quel(s) test(s) as-tu fait ?
Tout d'abord merci !
en effet je commence à recevoir mes messages !

Pour répondre à ta question, j'ai tenté depuis mon téléphone ou une addresse mail en hotmail.fr est configurée d'envoyer un email sur une boite wanadoo.fr en utilisant le smtp de mon serveur et ho surprise ... ca marche ....

J'ai pourtant une release 2 mais je l'ai pas mal bidouillé .... ... je ne saurais pas trop dire ou ...
Penses tu pouvoir m'aider ?
merci d'avance !

cassiopee
02/08/2013, 10h07
C'est normal que tu ne reçoives plus de mail provenant de l'extérieur : les serveurs de messagerie
de tes correspondants (émetteurs des messages) vont essayer de se connecter à ton dédié
sur le port 25 de celui ci et sur aucun autre.

Or de ton côté tu as supprimé complètement l'écoute sur le port 25 par Qmail.

Un serveur de messagerie SMTP doit être obligatoirement à l'écoute sur le port 25
car c'est le port standard pour discuter avec d'autres serveurs SMTP.

Après, tu peux, en plus, lui faire écouter un autre port, ici 587, afin d'émettre des messages
à travers lui. Mais c'est "en plus du port 25", pas "à la place du port 25".

Il faut donc supprimer les commentaires que tu as ajouté et redémarrer Qmail.

Ce qui est étrange c'est lorsque tu dis :

je me suis aperçu que tout le monde pouvait utiliser mon smtp
en standard ce n'est pas le cas avec une Release 2.

Comment est-ce que tu t'es rendu compte de cela ? Quel(s) test(s) as-tu fait ?

blumi31
02/08/2013, 09h38
Bonjour a tous,
je possède un serveur chez ovh equipé de la gentoo 2 d'ovh.

Tout fonctionnait très bien jusqu'à hier, je pouvais recevoir mes emails et en envoyer.

Mais je me suis aperçu que tout le monde pouvait utiliser mon smtp j'ai donc :
- modifié le port de connection pour le SMTP en modifiant /etc/init.d/qmail ce qui a bien fonctionné.
voici le fichier une fois modifié:
Code:
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

depend() {
    use net
    before ntpd ntp-client spamd apache apache2
}

start() {
    cd /

    ebegin "Starting Qmail"
    env - PATH="/var/qmail/bin:/usr/local/bin" \
        /var/qmail/bin/qmail-start ./Maildir/ 2>&1 | /usr/local/bin/tai64n \
        | /usr/local/bin/setuidgid qmaill /usr/local/bin/multilog s500000 n60 /var/log/qmail/ &
    eend $?
    ebegin "Starting Pop"
    env - PATH="/var/qmail/bin:/usr/local/bin" \
        tcpserver -v -H -R -c100 0 pop-3 /var/qmail/bin/qmail-popup \
        ns3299966.ovh.net \
        /home/vpopmail/bin/vchkpw /var/qmail/bin/qmail-pop3d Maildir 2>&1 \
        | /usr/local/bin/tai64n \
        | /usr/local/bin/setuidgid qmaill /usr/local/bin/multilog s500000 n60 /var/log/qmailpop3/ &
    eend $?
#    ebegin "Starting Smtp80"
#    env - PATH="/var/qmail/bin:/usr/local/bin" CHKUSER_START="DOMAIN" \
#        tcpserver -v -H -R -x /etc/tcp.smtp.cdb -c100 -u508 -g503 0 smtp \
#       /var/qmail/bin/qmail-smtpd 2>&1 \
#       | /usr/local/bin/tai64n \
#       | /usr/local/bin/setuidgid qmaill /usr/local/bin/multilog s500000 n60 /var/log/qmailsmtp/ &
#    eend $?
    ebegin "Starting Smtp 8025 "
env - PATH="/var/qmail/bin:/usr/local/bin" CHKUSER_START="DOMAIN" \
tcpserver -v -H -R -x /etc/tcp.smtp.cdb -c100 -u508 -g503 0 8025 \
/var/qmail/bin/qmail-smtpd 2>&1 \
| /usr/local/bin/tai64n \
| /usr/local/bin/setuidgid qmaill /usr/local/bin/multilog s500000 n60 /var/log/qmailsmtp8025/ &
eend $?

}

stop() {
    ebegin "Stopping Qmail"
    killall qmail-send
    killall tcpserver
    eend $?
}
- et tenté de paramétrer un ssl sur mon serveur afin de pouvoir sécuriser tout ça. Mais sans succès .
voici le type de commande que j'ai tapé :

Code:
/etc/ssl/misc/CA.pl -newca
openssl req -config /etc/ssl/openssl.cnf -new -nodes -keyout monserveur.key -out monserveur.csr -days 1000
openssl ca -config ../openssl.cnf -policy policy_anything -days 1000 -out certs/monserveur.crt -infiles ~/tmp/monserveur.csr
Plus tard dans la journée je me suis rendu compte que :
- le SMTP marche toujours très bien tout en n’étant toujours pas sécurisé.
- la connexion à mes boites mail en IMAP ou même en POP fonctionne parfaitement.
- la réception des Mails entre boites mails de ce serveur fonctionne. ex de jb@xxx.fr à db@xxx.fr
- Mais la réception des mails provenant de l’extérieur type : xxxx@hotmail.fr / xxxx@gmail.com etc ne marche pas

Je pense que ce sont mes bidouillages pour le ssl qui ont tout fait foiré. je pense qu'il faudrait que je puisse revenir en arrière. Mais je ne sais pas comment faire...
j'ai bien entendu tenté de redémarrer les services spamd clamd Qmail, j'ai meme tenté de redémarrer mon serveur mais rien n'y fait...

Auriez vous la solution à mon problème
merci d'avance