OVH Community, votre nouvel espace communautaire.

script avec envoi de mail


guirio
10/01/2005, 22h40
Bonjour, pour ma part j ai tourner dans tous les sens ...
J ai modifier et renommer le script CGI, j ai passer 3 jours a chercher, il est vrai que j avais la solution du PHP mais bon je veux le CGI

Donc j ai tout essayer a commencer par le formail-vf puis le rapido form mail
Rien a faire :

Concerant le formail j avais une erreur 500 et j ai appeller OVH 08 ** ** ** ** mais rien a faire j ai appeller au moins six fois il m ont dit que ca venait de mon script CGI donc je l ai envoyer a un ami qui l essayer sur son hebergement OVH et ca a marcher. C etait a ne plus rien comprendre : Fichier en CHMOD 755, Scrit bien configurer et page html aussi donc ce n etais pas possible que ca ne marche mais ca ne marchait pas.

J ai resolut mon probleme : je transfais et donnais les droits au serveur via internet explorer de winxp en me connectant a mon domaine.

Je l ai fait avec ftp expert et ca a marcher dessuite, et je suis partit direct faire l aperitif

Voila j espere que ca pourra en aider quelques un


@Bientot

Gui

dds
06/03/2004, 20h45
Yvan

J'ai enfin réussi à faire fonctionner le script.

Il y avait effectivement des caractères parasites rajoutés et un nom de routine tronqué.

Merci de ton aide et bon week end.

yvan
06/03/2004, 16h36
en tout cas le script que je t'ai renvoyé en privé il fonctionne chez moi...

peut-être un problème de droit, ils sont bien en chmod 705 ton script et ton répertoire cgi-bin ?

autrement tu peux essayer cgiemail, il fonctionne nickel

tu télécharges les binaires linux et hop... dans le dossier cgi-bin

http://web.mit.edu/wwwdev/cgiemail/

dds
06/03/2004, 16h29
Yvan

Merci pour ton aide.

J'ai trouvé un script de test de scripts qui m'a trouvé la même erreur.
Malheureusement, après correction, j'ai encore le problème (erreur 500).

Je vais essayer de simplifier le script ou de récupérer un autre.

dds
06/03/2004, 15h26
Le script est un script perl formmail que j'ai renomé en
"script-mail.pl" .


FormMail Version 1.92 #
# Copyright 1996-2002 Matt Wright mattw@worldwidemart.com #
# Created 06/09/95 Last Modified 04/21/02 #
# Matt's Script Archive, Inc.: http://www.worldwidemart.com/scripts/


Je l'ai mis dans le répertoire cgi-bin et il est activé par un Post dans un formulaire placé sous www

Si éventuellement tu connais d'autres qui marchent, je suis preneur!

L'hébérgement est un plan 720

Merci

yvan
06/03/2004, 15h17
c'est quoi comme script et comme hébergement ?

quel est l'emplacement du script et le nom du fichier ?

dds
06/03/2004, 15h12
Path perl corrigé, mais toujours une erreur 500
à l'éxécution!

yvan
06/03/2004, 14h47
le chemin pour perl c'est /usr/bin/perl

dds
06/03/2004, 14h34
Merci

J'ai modifié le path du sendmail(/usr/sbin/sendmail) ainsi que celui du perl (/usr/sbin/perl) et j'ai toujours
une "internal server error".

J'ai vérifié aussi le CHMOD (755).

Merci d'avance pour toute aide?

yvan
06/03/2004, 13h55
tu le trouveras

dds
06/03/2004, 12h50
Bonjour

Je cherche à faire marcher un script perl d'envoi de mail
pour un formulaire de mon site et je me récupère toujours un "internal server error".
Ce script a été placé dans le répértoire cgi-bin.
Est ce que quelqu'un pourrait me donner le path à utiliser dans le script pour le send mail ?
D'avance merci.