OVH Community, votre nouvel espace communautaire.

Configuration sur dédié + cpanel


PhilTheNet
23/10/2013, 10h50
Citation Envoyé par Unpassant
J'ai passé 30 minutes au téléphone pour enfin avoir la réponse il y a quelques jours, il faut remplacer le A par le CNAME avec un point à la fin du domaine donnée:
test.com IN CNAME test.com.web.cdn.anycast.me.
Argh, j'ai donc pas trop faux

Thks
Par contre j'ai mis direct www.mondomaine.com j'espere que ca sera good

PhilTheNet
23/10/2013, 09h01
Citation Envoyé par emicoma
oui mais on peut pas avoir un cname et un A pour "test.com" donc ma question, c'est en fait CNAME ou A ?
C'est bien la question que je me pose pour ma config, quelqu'un a la réponse ??

emicoma
26/06/2013, 15h00
oui mais on peut pas avoir un cname et un A pour "test.com" donc ma question, c'est en fait CNAME ou A ?

Kindersama
26/06/2013, 11h49
Le CNAME est juste en dessous de ton domaine dans le CDN manager :



donc ça ressemblera à ça par exemple dans le manager domaine d'OVH :

test.com IN CNAME test.com.web.cdn.anycast.me

emicoma
16/06/2013, 17h52
J'ai un peu du mal avec cette config également..
Concrètement :
la ligne type A : on remplace par l'adresse ip du cdn ?
cette ligne CNAME à rajouter, qqn aurait un exemple de syntaxe ?
un petit exemple de zone modifiée avec succès serait d'un grand secours..
Merci de votre aide

bubbly
20/04/2013, 19h02
Quelques heures plus tard, l'URL fonctionne bien, ca va jusqu'au backend (penser à ajouter le virtual host correspondant au "domaine" au backend...). Mais j'ai systématiquement un
Code:
X-Cacheable:Not cacheable: no cache headers from backend
alors que le backend renvoit simplement
Code:
HTTP/1.1 200 OK
Server: nginx/1.0.5
Date: Sat, 20 Apr 2013 16:50:44 GMT
Connection: keep-alive
Content-Length: 8431
J'ai un peu regardé le docs Varnish mais je ne vois pas le problème.
Des idées ? Le CDN d'OVH ne prend en compte que les requêtes avec un Cache-Control ?

bubbly
20/04/2013, 14h43
Je peux partiellement me répondre : j'avais ajouté "ext" dans le CNAME alors qu'il fait partie du "domaine" dans mon vocabulaire. Cad que pour un
www.lesfleurs.com à mettre en CDN ,il faut fait pointer le CNAME vers www.lesfleurs.com.web.cdn.anycast.me et non www.lesfleurs.com.ext.web.cdn.anycast.me

La réponse dig est maintenant beaucoup plus riche. Mais je n'ai rien qui s'affiche pour le moment, c'est peut etre le backend...

bubbly
20/04/2013, 14h35
Alors de ce que j'ai compris, il faut créer un CNAME qui pointe vers un host qui n'est pas dans notre domaine et qui est la concaténation du host que l'on configure et du truc OVH : .ext.web.cdn.anycast.me

J'ai donc çà, le dig sur le domaine positionné sur le CDN marche bien et indique en réponse le domaine+.ext.web.cdn.anycast.me. Un dig sur le domaine+.ext.web.cdn.anycast.me indique
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 35572
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;[MON DOMAINE].ext.web.cdn.anycast.me. IN A

;; AUTHORITY SECTION:
web.cdn.anycast.me. 10800 IN SOA dns200.anycast.me. tech.ovh.net. 2013042038 86400 3600 3600000 86400

;; Query time: 50 msec
;; SERVER: 192.168.1.254#53(192.168.1.254)
;; WHEN: Sat Apr 20 14:35:02 2013
;; MSG SIZE rcvd: 110

ce qui veut dire que çà pointe sur rien je pense.

Pourtant, tout est ok dans le console.

Comment çà marche ?? Quelqu'un peut nous expliquer ?

Take
30/03/2013, 14h21
Bonjour
Je viens de recevoir le mail d'activation de mon compte CDN et je bloque sur les explications données.

1) Déclarer les Backends (IP de vos serveurs WEB) ;
J'ai mis l'IP failover qui sert pour le site concerné

2) Déclarer les domaines / sous-domaines que vous souhaitez voir intégrer le CDN ;
J'ai mis mon site (site.tld)

3) Faire pointer votre domaine vers le CNAME créé une fois votre domaine enregistré ;
Et là... quel CNAME justement?
Dans ma config de DNS pour le site en question, est-ce que cela concerne www avec pour cname l'IP CDN qu'on m'a attribué, tout simplement ou autre chose (éditer toute la zone DNS)?

Quand j'édite le cname de www et que je mets l'IP du CDN, cela se transforme en IPduCDN.monsite.tld. et je ne suis pas vraiment sût que ce soit bon.

Je précise que pour la partie 4 des explications par mail, l'ajout d'un site sur le CDN n'a rien généré de visible :

L'ajout d'un domaine sur le CDN genere un CNAME au format votredomaine.ext.web.cdn.anycast.me, vous devez faire pointer les DNS de votredomaine.ext vers ce CNAME pour l'activation.