OVH Community, votre nouvel espace communautaire.

SMTP relay access denied + config thunderbird


Nowwhat
29/01/2013, 10h48
Ok, content pour toi.
Ok, je supprime ton mail 'chez moi'.

Ayuniverse
29/01/2013, 09h44
Merci pour ton aide Nowwhat,

en fait je croyais qu'en spécifiant le nom d'utilisateur/mot de passe d'un compte pour m'authentifier dessus en SMTP, je ne pourrais pas envoyer de message depuis mes autres comptes (j'ai une 10aines d'adresses emails pour ce domaine dans Thunderbird).

Donc je ne spécifiais pas de login/mdp dans les paramètres, laissant Thunderbird me demander mon mdp quand j'essayais d'envoyer un mail avec un compte spécifique avec le mot de passe de ce compte.

Je ne sais pas si c'est bien clair...

Bref en fait peu importe le compte qui s'identifie lors de l'envoi SMTP le mail arrive avec l'identité du compte qui l'a envoyé. Je n'avais pas saisi ça

Bon ben tout marche.

Merci encore pour ta patience ! Et merci aux autres aussi !

a+

Nowwhat
29/01/2013, 08h18
CONFIRME que:
Citation Envoyé par Nowwhat
Puis, teste à partir de chez toi:
telnet ip-de-ton-serveur 587
et après
telnet domaine-de-ton-serveur 587
cette opération marche à partir de ton PC vers ton dédié....
Car:
C'est du bonne nouvelle ça !!!
Donc tout marche !

(car, il faut le dire à personne, mais Thunderbird (Outlook, OE et j'en passe) font exactement la même chose derrière le rideau)

Plus exactement:
Démarre Google, et cherche comment activer les logs détaillé 'smtp' coté Thunderbird - t’auras tes détails pourquoi ça ne marche pas.

Tu entre : domaine-de-ton-serveur
La porte : 587
Puis, cherche aussi: "serveur smtp a besoin d'une authentification" puis entre ton adresse mail + le mot de passe.
décoche SSL et tout ça.

Et ça marche.

------

Je te préparé un adresse mail sur mon serveur:
Ayuniverse@test-domaine.fr
Porte 587
Authentification: Ayuniverse@test-domaine.fr
Mot de passe : Ayuniverse
(sans SSL etc)

J'ai testé ce mail avec Outlook 2010 (le paramétrage manuel - POP/IMAP/SUBMISSION = Ok)

A toi de tester

(adresse mail valable 24 heures, car sinon ...)

Ayuniverse
28/01/2013, 21h33
J'ai reçu le mail dans les 3 cas

Nowwhat
28/01/2013, 12h45
Il est temps de http://www.ehow.com/how_8252284_test...er-telnet.html

Utilise porte 587 au lieu de 25.
Connecte-toi avec Putty sur ton serveur, et teste d'abord
telnet 127.0.0.1 587

Puis, teste à partir de chez toi:
telnet ip-de-ton-serveur 587
et après
telnet domaine-de-ton-serveur 587

Ayuniverse
27/01/2013, 21h48
J'ai bien le "0: OK "Success." "

Nowwhat
27/01/2013, 18h02
Citation Envoyé par Ayuniverse
...
oui c'est configuré
Si c'est 'correctement' configuré:
testsaslauthd -u mail@domaine.tld -p motdepasse -f /var/spool/postfix/var/run/saslauthd/mux -s smtp
qui donnera:
0: OK "Success."

Si le socket est bien ici (la location est ça normalement):
/var/spool/postfix/var/run/saslauthd/mux

Ayuniverse
26/01/2013, 20h36
Merci pour ta réponse,

oui c'est configuré

Freemaster
26/01/2013, 11h01
ok tu as activé la submission, mais as-tu configuré l'authentification sasl ?

http://postfix.traduc.org/index.php/SASL_README.html

Ayuniverse
26/01/2013, 09h52
up ?

Ayuniverse
24/01/2013, 07h54
C'est encore moi, j'ai dorénavant le message le plus explicite au monde dans Thunderbird :

The message could not be sent using SMTP server mail.mondomaine.com for an unknown reason
et dans mon mail.log :

Jan 24 02:50:23 user postfix/smtpd[17749]: connect from CPE002401cd0a51-CM0014e8b60462.cpe.net.cable.rogers.com[174.116.235.177]
Jan 24 02:50:27 user postfix/smtpd[17749]: disconnect from CPE002401cd0a51-CM0014e8b60462.cpe.net.cable.rogers.com[174.116.235.177]
Sinon, dans syslog j'ai ceci :

Jan 24 02:50:23 user named[3448]: client 127.0.0.1#33804: query (cache) 'CPE002401cd0a51-CM0014e8b60462.cpe.net.cable.rogers.com/A/IN' denied
Jan 24 02:50:23 user named[3448]: client 127.0.0.1#60301: query (cache) 'CPE002401cd0a51-CM0014e8b60462.cpe.net.cable.rogers.com/A/IN' denied
quelque chsoe à voir ?

Ayuniverse
24/01/2013, 07h42
Au temps pour moi, je n'avais pas activé la submission dans master.cf =).

Ayuniverse
24/01/2013, 07h37
Citation Envoyé par Nowwhat
Salut.

Comme d'hab, Thunderbird ne devrait pas toucher à la porte '25' de ton serveur.
Cette porte est uniquement destinée pour les autres serveurs mail (MTA) pour qu'ils déposent des mails sur ton serveur, destiné pour ton (tes) domaines.
Le reste va être refusé (= no relaying).

Thunderbird, un client mail, devrait passer par la porte 'submission' (= 587) - et SASL s'occupe de l'authentification - un peu pareil comme l'accès à tes comptes POP sur la 110.

Le fait que tout le monde pense qu'il faut envoyer ces messages vers 'son serveur sur la poprte 25' est un vieux héritage, une mauvaise habitude, proposés par nos FAI.
Ces mêmes FAI bloquent aujourd'hui les portes '25' autres que leur propres serveurs mail.
Merci pour ton message, c'est très clair. J'essaye donc d'y accéder par le port 587. Cette fois, pas de timeout, il m'affiche directement ceci :

Sending of message failed.
The message could not be sent because connecting to SMTP server mail.mondomaine.com failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or contact the server administrator.
j'ai pourtant le port 587 ouvert via ufw. Et toujours aucune trace dans les mail.log.

Nowwhat
24/01/2013, 07h27
Salut.

Comme d'hab, Thunderbird ne devrait pas toucher à la porte '25' de ton serveur.
Cette porte est uniquement destinée pour les autres serveurs mail (MTA) pour qu'ils déposent des mails sur ton serveur, destiné pour ton (tes) domaines.
Le reste va être refusé (= no relaying).

Thunderbird, un client mail, devrait passer par la porte 'submission' (= 587) - et SASL s'occupe de l'authentification - un peu pareil comme l'accès à tes comptes POP sur la 110.

Le fait que tout le monde pense qu'il faut envoyer ces messages vers 'son serveur sur la poprte 25' est un vieux héritage, une mauvaise habitude, proposés par nos FAI.
Ces mêmes FAI bloquent aujourd'hui les portes '25' autres que leur propres serveurs mail.

Ayuniverse
24/01/2013, 07h12
Bonjour,

je possède un dédié Kimsufi sur lequel j'ai installé Postfix. La réception de mails envoyés depuis d'autres domaines fonctionne. En revanche, je n'arrive pas à faire marcher le SMTP. Je suis en SASL et je n'arrive pas à configurer Thunderbird pour envoyer des mails via mon serveur. Lorsque j'essaye de me connecter via mon gestionnaire email, je n'ai aucune trace de la connexion dans mail.log, ce qui a du sens vu que Thunderbird m'affiche un timeout après quelques secondes.

Or, lorsque j'utilise un service comme https://www.wormly.com/test_smtp_server pour tester, j'obtiens une trace :

Code:
Jan 24 02:07:05 user postfix/smtpd[15438]: NOQUEUE: reject: RCPT from node-mec2.wormly.com[184.72.226.23]: 554 5.7.1 : Relay access denied; from= to= proto=ESMTP helo=
Jan 24 02:07:05 user postfix/smtpd[15438]: lost connection after RCPT from node-mec2.wormly.com[184.72.226.23]
Jan 24 02:07:05 user postfix/smtpd[15438]: disconnect from node-mec2.wormly.com[184.72.226.23]
Il me semble que le relay access denied a du sens vu qu'il n'y a pas d'auth du service, mais comment configurer mon Thunderbird pour se connecter en SMTP ?

Merci !

Sending of message failed.
The message could not be sent because the connection to SMTP server mail.mondomaine.com timed out. Try again or contact your network administrator.