OVH Community, votre nouvel espace communautaire.

Relay Qmail spam


freeway
04/09/2006, 11h06
Pour empecher des IP d'utiliser le smtp.

J'ai fait :
chmod 444 /etc/vpopmail/open-smtp

C'est la seule solution simple que j'ai trouvé pour empecher l'utilisation du smtp a distance.
Quelqu'un a d'autres solutions simples ?

freeway
03/09/2006, 15h31
Meme chose sur un serveur tout neuf !!!!
Au bout du deuxieme jour ! abusé !

Avec 1 seul site web, qui n'a pas de formmail ou autre.


SithLord écrivait :

Dimanche dernier mon disque system a commencé à être de plus en plus rempli. Apres vérification j'ai pu m'apercevoir que cela venait de qmail, j'avais 9000 msg dans la queue.

florina
13/02/2006, 08h29
merci toortop
en fin j'ai pu regler le problem de qmail
j'ai fais
* ps pour voir le n de process qmail ,
* par la suite j'ai fais un kill n.


concernant mon problem:
je ne peu plus envoyer de message vers hotmail,gmail..etc. (et pas de message d'erreure retourne)
tandis que vers yahoo j y'arrive mais avec 6h, 7h de retard (normal la queue est saturer avec les message de aol )
causes :
je suis blacklister car mon serveur est en open relay

--> comment s'en sortire ???

a l'aide.


et encore merci a toi Toorop pour cette outil

simplement si je fais :
perl qmqtool -e -f "aol.com"
les message de aol seront expire de la queue
mais desque mon serveur envoie d'autres messages a aol il seront inserer dans la queue.
je cherche un moyen pour ne plus envoyer de message vers "aol",

merci a l'avance

florina
12/02/2006, 09h00
g'ai trouver qmail
-rwxr-xr-x 1 root ftp 1141 fىv 12 09:46 qmail
le groupe ftp c normal ca?
quelq'un pour me donner le contenu du fichier /etc/rc.d/init.d/qmail pour s'assurer du contenu?
merci a vous

florina
12/02/2006, 08h54
merci a toi Toorop pour cette outil
mais pour l'executer il faut mettre

perl qmqtool -f "aol.com" : pour aficher les email de aol
simplement je peut pas les supprimer avec
perl qmqtool -e -f "aol.com" je ne sais pas pourqoi.

mais la j'ai un autre problem tres tres grave
j'ai voulu instaler spam-rbl en suivant le guide d'ovh
en redemarant le qmail, ca c planter, g tout remis comme avant
et si je veu fair /etc/rc.d/init.d/qmail resart
voila ce que j'ai comme erreur :
Code PHP:

stopping qmail                                             
[ECHOUE]
Startingqmail pop multilogfatalunable to lock directory /var/log/qmailtemporary failure
smtp 
mais j'arrive a envoyer les email.
aidez moi svp

Toorop
11/02/2006, 15h55
florina écrivait :
et si je vide tout le repertoire remote ?
Tu plantes qmail.

Il faut imperativement utiliser les outils ad'hoc pour travailler sur la queue de qmail.

Si tu veux supprimer,tous les mails en queue a destination d'AOL utilise qmqtool avec un truc du genre :
Code PHP:
qmqtool --'@aol.com' 
Pour ton autre probleme : le fait de mettre un # t'empeche d'envoyer, il n'y a aucun rapport sauf si tu essaye d'envoyer vers une adresse qui n'existe pas.

Maintenant si tu donnais un peu plus de precisions sur ce qu'il se passe et pas un simple "ça marche pas" on pouyrrait y voir plus clair

-> Description precise de ce que tu fait
-> Log qmail
-> Message d'erreur de ton client mail
-> ...

florina
11/02/2006, 13h46
et si je vide tout le repertoire remote ?
cad:
/var/qmail/queue/remote/

car mon serveur essey d'envoyer toujours au serveur d'aol a des comptes inexistant
Code PHP:
        remote  [email]colatiger2000@aol.com[/email]
        
remote  [email]cole1087@aol.com[/email]
        
remote  [email]cokey143@aol.com[/email]
        
remote  [email]coireleis@aol.com[/email]
        
remote  [email]colabear1714@aol.com[/email]
         ..... 
merci Toorop

florina
11/02/2006, 13h40
cad en modifiant le qmail-default (remplacer le contenu par #), j'ai voulu envoyer un mail a un autre compte sur le meme domaine mais je ne peu pas, c possible que si je remet qmail-default a ca valeur
cad en la remettant a :
| /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox
je voie pas ou est le problem?

Toorop
11/02/2006, 13h27
florina écrivait :
j'ai rien compris si j'ajoute le # au debut je ne peu pas envoyer de mail
merci comme meme Toorop
Tu ne rajoute pas # au debut, tu te contente de mettre # dans le fichier et rien de plus.

Je ne vois le rapport entre la modification de fichiers .qmail-default et le fait de ne plus pouvoir envoyer de mails.
Donne des details ? Quelle est l'erreur ?

florina
11/02/2006, 13h06
j'ai rien compris si j'ajoute le # au debut je ne peu pas envoyer de mail
merci comme meme Toorop

Toorop
11/02/2006, 12h47
Salut,

il faut mettre le # au debut de chaque qmail-default de chaque domaines (j'ai plusieurs dom)?
Tu met juste le # rien de plus et ce pour chaque domaine.

Attention, tu ne va plus bouncer auncun mail, ce qui peut etre quand meme genant, dans le cas ou l'expediteur a fait une erreur sur l'adresse. (il ne sera pas prevenu de son erreur)

florina
11/02/2006, 12h05
bonjours tout le monde , il me semble que j'ai le meme probleme que vous, et toujours pas de solution mon serveur est en open relay.

mets un # dans le fichier .qmail-default du domaine (et rien d'autre)

il faut mettre le # au debut de chaque qmail-default de chaque domaines (j'ai plusieurs dom)?

comme ca ?

# | /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox

et vous croyez par la suite que le serveur cesse de renvoyer les emailes (le remote) ?

merci a vous

SithLord
02/02/2005, 16h11
merci ^^

Toorop
02/02/2005, 15h20
mets un # dans le fichier .qmail-default du domaine (et rien d'autre)

SithLord
02/02/2005, 15h18
Ok ^^

Dans ce cas comment puis-je rediriger le catchall vers /dev/null ?

Toorop
02/02/2005, 14h57
Que l'on a envoye des mails a adresse_inexistante@ton_domaine.com avec comme expediteur info@momes.net

Ton serveur cree un bounce et l'envoi a info@momes.net.

Voila

SithLord
02/02/2005, 14h04
Merci de vos réponses si rapide ^^

Alors en fesant :

/var/qmail/bin/qmail-qread

J'obtien sans arret cette réponse :
...
2 Feb 2005 12:14:56 GMT #61422 19742 <>
remote info@momes.net
...

Ce domaine n'est pas géré par mon serveur.

Que peut-on en déduire ?

Toorop
02/02/2005, 13h52
SithLord écrivait :
Je me permets de relancer ce post, car je pense que j'ai un problème du même genre.

Dimanche dernier mon disque system a commencé à être de plus en plus rempli. Apres vérification j'ai pu m'apercevoir que cela venait de qmail, j'avais 9000 msg dans la queue.
La premiere chose a faire est de voir ce qu'il y a dans ta queue, utilise pour ça /var/qmail/bin/qmail-qread
Il y a fort a parier qu'il sagisse de bounces : des messages que ton serveur a reçu, destinés a des adresses qui n'existent pas.
Donc auriez-vous un conseil pour moi ?
Que puis-je faire pour identifier la cause de mon problème et surtout pour l'éradiquer ?
Si le probleme vient bien de ce probleme tu as plusieurs solutions :
- Ne pas bouncer les mails en redirigeant la catchall vers /dev/null
- Verifier au niveau smtp que l'utilisateur existe, si il n'existe pas Qmail ne prend pas le mail. On a un patch GPL pour faire ça ici : http://www.protecmail.com/opensourcehttp://www.protecmail.com/opensource

NetMichel
02/02/2005, 13h31
ils sont de toi ces 9000 mails ????
tu as installé RBL ?

SithLord
02/02/2005, 13h24
Je me permets de relancer ce post, car je pense que j'ai un problème du même genre.

Dimanche dernier mon disque system a commencé à être de plus en plus rempli. Apres vérification j'ai pu m'apercevoir que cela venait de qmail, j'avais 9000 msg dans la queue.

Bon j'ai suivi le guide ovh pour refaire la queue de qmail.

Mais le lendemain ça a recommencé.
J'ai pu remarquer que si j'arrête qmail et le relance, ou si je reboot ma queue n'augmenté plus jusqu'au lendemain matin. En gros tous les matins vers 9h cela reprend.

Donc auriez-vous un conseil pour moi ?
Que puis-je faire pour identifier la cause de mon problème et surtout pour l'éradiquer ?

Merci d'avance pour votre aide.

CASALOG
11/03/2004, 11h51
Merci à tous pour vos réponses.

EricZone
09/03/2004, 13h24
tcp 0 0 ns3931.ovh.net:2319 rst.7.rstassociate:smtp ESTABLISHED 29613/qmail-remote off (0.00/0/0)


Pour moi çà c'est une connection entre le serveur ovh ns3931, et le smtp distant qui va recevoir le mail.
Donc c'est un mail que le serveur OVH renvoi vers l'utilisateur, suite a un user qui n'existe pas.

Ce n'est pas du tout quelqu'un du net qui envoi un mail avec le SMTP.

EricZone
09/03/2004, 13h22
"l'expéditeur existe sur le serveur" ?

Tu ne recoit que des mails provenant de personnes de ton serveur ?
Si ton serveur recoit un mail de n'importe d'ou d'internet, il le traite, pour le mettre dans la boite de reception du user, si le user n'exite pas, TON serveur renvoi ce mail UNDELIVERY a l'emetteur.
Et donc TON serveur émet un mail de nsovh.xxx.nnet vers lespammeur@lespammeur.com

Toorop
09/03/2004, 13h20
Pourquoi ne pas vérifier d'abord que l'expéditeur existe sur le serveur et a le droit d'envoyer.
Pour que le serveur autorise qq a envoyer/relayer il faut qu'une des deux conditions suivantes soit verifiée :
- La persone c'est authentifiée, (quel que soit le mode d'autentification popbeforesmtp, smtpauth....).
- Le mail qu'essais de transmettre la personne est gerée en local par le serveur mail ou est inclu dans les domaines a relayer (/var/qmail/control/rcpthost)
Une identification à l'envoi n'est pas une chose mauvaise en soit.
Tout serveur mail bien configuré dispose de cette option si tu entend par la que le serveur s'assure qu'une des deux conditions citées au dessus soit verifiée. Si ce n'est pas ce que tu veux dire donne un peut plus de details
SMTP_AUTH ou un truc du genre est plus qu'efficace...
Oui ou PopBeforeSmtp qui est installe en standard, incovenient de cette methode il faut poper avant de pouvoir utiliser le smtp.
Mais personne n'explique clairement comment procéder à l'installation d'une autentification SMTP sur le serveur qmail... C'est bien dommage. (Même sur le guide OVH, c'est suggéré mais pas expliqué)
http://www.google.com/search?hl=fr&i...p+auth&spell=1
Une authentification permet de ne pas avoir la liste d'attente de qmail saturée par des essais d'envoi inutiles et qui saturent le serveur...
Tu peux detailler car je ne vois pas ce qui va empecher un utilisateur d'envoyer des mails vers des serveurs inaccessible par ce qu'il sera authentifié (ie parcequ'il lui sera permis d'utiliser le smtp)
Si vous êtes pas d'accord avec moi, c'est que votre serveur mail ne vous sert à rien.
J'aime pas les phrase qui commence par "Si vous n'etes pas d'accord avec moi, c'est que......."
Virez plutôt votre SMTP et utilisez celui de votre FAI pour faire vos envoi, c'est bien plus efficace.
Oui chef !!

atkati
09/03/2004, 12h42
Car quand un email n'existe pas en local, il faut bien que le serveur mail le renvoi a son expediteur non ?
Pourquoi ne pas vérifier d'abord que l'expéditeur existe sur le serveur et a le droit d'envoyer.

Une identification à l'envoi n'est pas une chose mauvaise en soit.

SMTP_AUTH ou un truc du genre est plus qu'efficace...

Mais personne n'explique clairement comment procéder à l'installation d'une autentification SMTP sur le serveur qmail... C'est bien dommage. (Même sur le guide OVH, c'est suggéré mais pas expliqué)

Une authentification permet de ne pas avoir la liste d'attente de qmail saturée par des essais d'envoi inutiles et qui saturent le serveur...

Si vous êtes pas d'accord avec moi, c'est que votre serveur mail ne vous sert à rien. Virez plutôt votre SMTP et utilisez celui de votre FAI pour faire vos envoi, c'est bien plus efficace.

EricZone
09/03/2004, 11h24
TOn Log est normal, c'est juste que ton SMTP se connecte au serveur distant. Car quand un email n'existe pas en local, il faut bien que le serveur mail le renvoi a son expediteur non ?
C'est là que tu as "msg 53876 to remote leopoldomurrell@astudes.powerfuldigest.com"

Sinon pour voir si tu es vraiment un relai de spam, install MRTG pour Qmail
Ca te donnera çà :
http://www.inter7.com/mrtg/

Et c'est dispo sur :
http://www.inter7.com/mrtg.html

Toorop
09/03/2004, 10h45
iRaZ écrivait :
il dise sa à la fin :
Le serveur est un relais ouvert !
Ils se plantent. Cela ne prouve pas que le relais est ouvert. Et en l'occurence Qmail ne va pas delivrer le mail.

iRaZ
09/03/2004, 06h58
il dise sa à la fin :

Le serveur est un relais ouvert !

Est ce bon ou mauvais ?

CASALOG
08/03/2004, 12h03
Bon j'insiste lourdement, mais je pense que n'importe qui peut se retrouver dans mon cas.

Faites ce petit test :
http://vsmtp.pagasa.net/

Et chez moi,
>>> RSET
<<< 250 flushed
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok

Là ou ça rigole moins c'est que pour le mx1 de ovh, c'est pareil
>>> RSET
<<< 250 flushed
>>> MAIL FROM:
<<< 250 ok
>>> RCPT TO:
<<< 250 ok

Merci de m'aider et vous par la même occasion.

CASALOG
06/03/2004, 12h09
Non d'ailleurs je n'ai pas non plus de connexion sur le port 80 de ces IPs ni de post suspect dans l'ensemble de mes logs apache

je réduit grâce à iptables, mais ça va finir par me jouer des tours. et puis ça change tous les jours...

mais portant encore ce matin, j'ai ça, c'est clairement du spam, non ? :

@400000004049bd3e209a2f0c starting delivery 7721: msg 53875 to remote leopoldomurrell@tomis.powerfuldigest.com
@400000004049bd3e209a3ac4 status: local 0/10 remote 5/20
@400000004049bd3e20a308ac starting delivery 7722: msg 53874 to remote leopoldomurrell@wahath.powerfuldigest.com
@400000004049bd3e20a3107c status: local 0/10 remote 6/20
@400000004049bd3e20a6e8dc starting delivery 7723: msg 53876 to remote leopoldomurrell@astudes.powerfuldigest.com
@400000004049bd3e20a6f0ac status: local 0/10 remote 7/20
@400000004049bd402086688c starting delivery 7724: msg 53877 to remote leopoldomurrell@shozet.powerfuldigest.com
@400000004049bd402086705c status: local 0/10 remote 8/20
@400000004049bd40208abdec starting delivery 7725: msg 53878 to remote leopoldomurrell@xasonge.powerfuldigest.com
@400000004049bd40208ac9a4 status: local 0/10 remote 9/20

OVH
06/03/2004, 11h05
Est-ce que vous avez formail.pl ou les scripts web semblables installés sur votre serveur dédié ?

CASALOG
04/03/2004, 22h14
Bonsoir,

Il me semble que je sers de relay de spam.
J'ai pourtant suivi les instructions du guide.ovh.
Je n'ai pas de process inconnu démarré.
Je n'ai rien de bizzarre dans mes log httpd.
Je n'ai rien trouvé sur le forum ni dans feu sd@ml.ovh

Par où chercher ?
Merci


/etc/tcp.smtp :
------------------
127.0.0.:allow,RELAYCLIENT=" "

et d'ailleurs /etc/vpopmail/open-smtp ne montre que mon ip

current :
-----------
@400000004047a8203ae2360c delivery 329: deferral: Connected_to_200.226.132.20_but_connection_died._( #4.4.2)/
@400000004047a8203ae241c4 status: local 0/10 remote 19/20
@400000004047a8203b3ea234 starting delivery 331: msg 52782 to remote linda@cicese.mx
@400000004047a8203b3eadec status: local 0/10 remote 20/20
@400000004047a8203b7ca14c delivery 331: deferral: Sorry,_I_wasn't_able_to_establish_an_SMTP_connecti on._(#4.4.1)/
@400000004047a8203b7cad04 status: local 0/10 remote 19/20
@400000004047a8203b82a45c starting delivery 332: msg 52774 to remote mrjimt@biz4hits.biz
@400000004047a8203b82ac2c status: local 0/10 remote 20/20

netstat :
-----------
tcp 0 0 ns3931.ovh.net:2319 rst.7.rstassociate:smtp ESTABLISHED 29613/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:4053 internal-7.netbrid:smtp ESTABLISHED 1772/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:3189 ntdmail.ntdistribu:smtp ESTABLISHED 18522/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:1612 ztdesk-7.ztenterpr:smtp ESTABLISHED 25612/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:2654 incomingmail.gravi:smtp ESTABLISHED 19272/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:1644 hkkny.7.hkknyinc.c:smtp ESTABLISHED 29348/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:4567 ztdesk-7.ztenterpr:smtp ESTABLISHED 27366/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:2367 mail.npsinvestment:smtp ESTABLISHED 20328/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:4785 hkkny.7.hkknyinc.c:smtp ESTABLISHED 10401/qmail-remote off (0.00/0/0)
tcp 0 0 ns3931.ovh.net:4858 hkkny.7.hkknyinc.c:smtp ESTABLISHED 3656/qmail-remote off (0.00/0/0)