OVH Community, votre nouvel espace communautaire.

formulaire arrivent vides


papyHD
12/01/2013, 19h49
Bien compris. Merci

Pour info
j'ai mis un autre SOS dans la partie "Hébergements mutualisés" du forum concernant justement le fonctionnement de mon .htaccess protégeant un dossier et qui ne fonctionne pas. C'est le dernier truc qui est en panne

cavapulser
12/01/2013, 18h07
La ligne avec "Options -Indexes" permet de sécuriser le site en interdisant de pouvoir lister un dossier. C'est indispensable.
Les deux autres lignes concernent le langage PHP : sa version d'exécution, et l'environnement.

papyHD
12/01/2013, 17h58
Citation Envoyé par cavapulser
Il faudrait en savoir plus pour trouver ce qui cloche !
Je suis loin d'être un expert et de comprendre même ce que je fais. Comment je peux savoir ? En tout cas cela fonctionne en effet (merci encore) et si mon site ne risque rien de plus je vais laisser comme ca... sauf que, à quoi sert ce .htaccess sur OVH ? Je veux parler des deux lignes que j'ai enlevées.. C'est ca qui m'embête un peu. Il doit bien y avoir une raison... non ?

cavapulser
12/01/2013, 17h31
Sur ce coup, OVH ne risque absolument rien
Le principal, c'est que cela fonctionne.
Il faudrait en savoir plus pour trouver ce qui cloche !

papyHD
12/01/2013, 16h49
ok. la formule la + simple fonctionne. Merci beaucoup

Mais cela ne risque pas d'occasionner des dysfonctionnements par rapport à OVH ?

cavapulser
12/01/2013, 16h26
Essayer avec ça...
Options -Indexes
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0

Ou uniquement avec :
Options -Indexes

papyHD
12/01/2013, 14h45
contenu de .htaccess (qui doit avoir été mis là par OVH en tête dans le dossier www.. en même temps que ces fichiers là : .bash_logout, .bash_profile, .bashrc et .forward ?) :

SetEnv PHP_VER 5_3
SetEnv REGISTER_GLOBALS 0

gierschv
11/01/2013, 21h43
Citation Envoyé par papyHD
* je me suis aperçu que si je supprime le fichier .htaccess sur OVH, le formulaire fonctionne parfaitement
Que contient ce fichier .htaccess ?

papyHD
11/01/2013, 20h28
Je suis un papy novice mais mon problème me semble différent de ce qui précède.

J'ai un formulaire de contact devant m'arriver dans une boite mail actuellement sur une adresse perso (en l'occurrence sur free)

Le formulaire fonctionne et arrive bien dans ma boite mais il est vide


Je précise :
* mon site est encore (aussi) sur free et cela fonctionne parfaitement (je fais le basculement progressivement et je conserve encore les 2 sites)
* je me suis aperçu que si je supprime le fichier .htaccess sur OVH, le formulaire fonctionne parfaitement