OVH Community, votre nouvel espace communautaire.

Problème gestion DNS


loyum
10/12/2012, 22h52
Ok, merci pour tout

cassiopee
10/12/2012, 19h53
Oui, ça ne ne pose aucun problème, il suffit de rajouter un enregistrement DNS
dans le fichier de zone :

Code:
sous_domaine.domaine.fr IN A 12.34.56.78
où "12.34.56.78" est la seconde adresse IP.

puis d'incrémenter le numéro de série DNS et enfin de redémarrer Bind.

loyum
10/12/2012, 17h46
Sa marche merci à tous! Je voudrait savoir si c'est possible d'avoir des sous domaine et rediriger un de ces dernier vers mon serveur avec une ip spécifique!

cassiopee
10/12/2012, 17h46
Ok, tout est bon désormais

Il n'y a plus qu'à attendre la propagation sur Internet de ces nouvelles valeurs.

(perso j'arrive déjà sur le site web)

loyum
10/12/2012, 17h42
Ok, voici la réponse de named-checkconf -z
Code:
zone belcraft.fr/IN: loaded serial 2012121001
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1

cassiopee
10/12/2012, 17h36
Ok, donc :

1) modifie le numéro de série DNS : remplace "2009051501" par "2012121001" dans l'enregistrement SOA

2) remplace la ligne :

Code:
IN    A    5.39.88.184
par

Code:
belcraft.fr.    IN    A    5.39.88.184
et enfin redémarre Bind.

loyum
10/12/2012, 17h29
désolé, le voici
Code:
$ttl 3H
belcraft.fr.    IN    SOA    ks3275597.kimsufi.com. teo.ctmen.ch. (
2009051501  ;serial (version)
3600          ;refresh period
900           ;retry refresh this often
604800        ;expiration period
3600          ;minimum TTL
)

belcraft.fr.        IN    NS    ks3275597.kimsufi.com.
belcraft.fr.        IN    NS    ns.kimsufi.com.
IN    A    5.39.88.184
mail                 IN    A    5.39.88.184
svn                  IN    A    5.39.88.184
www                  IN    CNAME    belcraft.fr.
belcraft.fr.        IN    MX      10    mail.belcraft.fr.

cassiopee
10/12/2012, 17h29
Nope, le fichier de zone c'est "/etc/bind/belcraft.fr.host"

loyum
10/12/2012, 17h26
J'attend 18h30 le prochain essaie
mes fichiers de zones:

named.conf.options
Code:
options {
directory "/var/cache/bind";
forwarders {
213.186.33.99;
};
auth-nxdomain no;    # conform to RFC1035
listen-on-v6 { any; };
listen-on { any; };
allow-recursion
{
127.0.0.1;
5.39.88.184;
};
allow-transfer { 213.186.33.199; };

};
named.conf.default-zones:
Code:
// prime the server with knowledge of the root servers
zone "." {
	type hint;
	file "/etc/bind/db.root";
};

// be authoritative for the localhost forward and reverse zones, and for
// broadcast zones as per RFC 1912

zone "localhost" {
	type master;
	file "/etc/bind/db.local";
};

zone "127.in-addr.arpa" {
	type master;
	file "/etc/bind/db.127";
};

zone "0.in-addr.arpa" {
	type master;
	file "/etc/bind/db.0";
};

zone "255.in-addr.arpa" {
	type master;
	file "/etc/bind/db.255";
};
named.conf.local:
Code:
zone "belcraft.fr" {
        type master;
        file "/etc/bind/belcraft.fr.host";
        // 213.186.33.199 = ns.kimsufi.com
        allow-transfer { 213.186.33.199; };
};
Sur le manager, le dns secondaire est en état "ok", mais la redirection sur l'ip n'est pas encore fonctionnel, est-ce du au temps de propagation?

cassiopee
10/12/2012, 17h20
Ok ça c'est bon mais il y a toujours un souci dans ton fichier de zone.

Quel est son contenu actuel ?

loyum
10/12/2012, 17h12
Voici le nouveau contenu lors de la commande named-checkconf -z:

Code:
zone belcraft.fr/IN: loaded serial 2009051501
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1

cassiopee
10/12/2012, 15h23
Nowwhat : nope ça c'était le contenu précédent de la commande "named-checkconf",
avant le tutoriel donc

Nowwhat
10/12/2012, 15h18
Citation Envoyé par loyum
Code:
root@ks3275597:~# named-checkconf -z
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1
Je pense que t'as zappé totalement cette partie de ton tuto:
Ensuite passons à la configuration d’une zone. Editons le fichier /etc/bind/named.conf.local afin d’y renseigner nos zones.
Ajoute donc ceci à ton /etc/bind/named.conf.local:
Code:
zone "belcraft.fr" {
        type master;
        file "/etc/bind/blecraft.fr.host";
        // 213.186.33.199 = ns.kimsufi.com
        allow-transfer { 213.186.33.199; };
};

cassiopee
10/12/2012, 15h05
Attention, il reste encore un "123.234.1.2" à remplacer par l'adresse IP du Kimsufi

En profiter pour incrémenter le numéro de série DNS (2009051501 -> 2012121001 )
et redémarrer Bind.

Dans la ligne "IN MX", ce n'est pas "craft.belcraft.fr" mais plutôt "mail.belcraft.fr" qu'il faudrait
écrire. Si tu préfères "craft.belcraft.fr", dans ce cas il faut ajouter une ligne de définition de
l'adresse IP correspondant à ce nom :

Code:
craft IN A 5.39.88.184
Enfin, vérifier qu'il n'y a pas d'erreur indiquée dans les résultats de la commande :

Code:
named-checkconf -z

loyum
10/12/2012, 14h49
J'ai fait ce qui était marqué en remplacant correctement l'ip est le domaine, voici mon blecraft.fr.host:
Code:
$ttl 3H
belcraft.fr.    IN    SOA    ks3275597.kimsufi.com. XXX.XXXXX.XX. (
2009051501  ;serial (version)
3600          ;refresh period
900           ;retry refresh this often
604800        ;expiration period
3600          ;minimum TTL
)

mon-site.tld.        IN    NS    ks3275597.kimsufi.com.
mon-site.tld.        IN    NS    ns.kimsufi.com.
IN    A    123.234.1.2
mail                 IN    A    5.39.88.184
svn                  IN    A    5.39.88.184
www                  IN    CNAME    belcraft.fr.
belcraft.fr.        IN    MX      10    craft.belcraft.fr.

cassiopee
10/12/2012, 13h52
Voilà l'explication : il n'y a aucune information relative à ce nom de domaine, le serveur DNS n'a pas
du tout été configuré afin de gérer ce nom de domaine.

Aller zou, direction un tutoriel complet sur ce sujet : http://www.prometee-creation.com/tut...eur-dedie.html

Ce qui t'intéressera le plus maintenant, c'est le contenu du fichier " /etc/bind/mon-site.tld.hosts"

Partout où il y a "mon-site.tld" dans le tutoriel, tu dois remplacer par ton nom de domaine.

loyum
10/12/2012, 13h46
Code:
root@ks3275597:~# named-checkconf -z
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1

cassiopee
10/12/2012, 13h43
Ok, on progresse, désormais le serveur DNS répond mais ne donne pas encore d'infos
sur le nom de domaine :

Code:
# dig @5.39.88.184 soa belcraft.fr

;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 8189
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
Que donne comme résultats la commande :

Code:
named-checkconf -z
?

loyum
10/12/2012, 13h29
J'ai lancé la commande voici le résultat:
Code:
tcp        0      0 5.39.88.184:53          0.0.0.0:*               LISTEN      3241/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      3241/named
tcp6       0      0 ::1:53                  :::*                    LISTEN      3241/named
et le contenu de named.conf donne des includes:
Code:
include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
et le contenu de named.conf.options:
Code:
	options {
	directory "/var/cache/bind";dnssec-validation auto;

	auth-nxdomain no;    # conform to RFC1035
        //listen-on { 127.0.0.1; };
	listen-on-v6 { ::1; };
	allow-recursion { 127.0.0.1; };
};

cassiopee
10/12/2012, 10h06
Yep, la connexion de l'extérieur au serveur DNS du Kimsufi n'est toujours pas possible.

Quel est le contenu de "named.conf" et des autres fichiers inclus ?

Que donne comme résultats la commande :

Code:
netstat -tanpu | grep LISTEN | grep ":53"
?

loyum
10/12/2012, 07h36
J'ai modifier le named.conf.option, et verifier les autres fichiers inclus au named.conf (/etc/bind/)

J'ai ensuite redémarré bind, mais une nouvelle erreur s'est instanciée lors du test:
: zone belcraft.fr/IN: refresh: unexpected rcode (REFUSED) from master 5.39.88.184#53 (source 0.0.0.0#0)
: transfer of 'belcraft.fr/IN' from 5.39.88.184#53: failed while receiving responses: NOTAUTH

merci de l'aide précédente, aidez moi pour la suivante!

cassiopee
09/12/2012, 20h36
Le serveur DNS secondaire (ns.kimsufi.com) n'arrive pas à faire de transfert de zone
(=synchronisation) parce que le serveur DNS dans le Kimsufi n'est pas accessible de l'extérieur :

Code:
# telnet 5.39.88.184 53

Trying 5.39.88.184...
telnet: Unable to connect to remote host: Connection refused
C'est généralement du au fait que l'on a laissé une directive par défaut
dans le fichier "named.conf" ou dans un fichier appelé à partir de ce dernier
(named.options, etc.) :

Code:
listen-on { 127.0.0.1; }
qui fait que le serveur DNS n'est à l'écoute que localement, à l'intérieur du dédié.

Il faut placer cette directive entre commentaires (ou la supprimer) puis redémarrer Bind

loyum
09/12/2012, 19h49
Bonjour, j'ai un serveur dédié (kimsufi), et un nom de domaine chez ovh. Mon domaine pointe bien sur dns de mon kimsufi (ks*******.kimsufi.com, et ns.kimsufi.com), la zone dns A pointe la bonne ip.
Du coté serveur, lorsque j'essaie de mettre en place le dns secondaire, j'ai ce message d'erreur:

: transfer of 'belcraft.fr/IN' from 5.39.88.184#53: failed to connect: connection refused
: zone belcraft.fr/IN: zone transfer deferred due to quota
: zone belcraft.fr/IN: refresh: retry limit for master 5.39.88.184#53 exceeded (source 0.0.0.0#0)

Toutes les heures le serveur fait un nouveau test, mais celui-ci échoue à chaque tentative.

J'ai essayer plusieurs solutions, mais aucune ne suffit, mon serveur tourne sous ubuntu server 12.10.

Je ne sais plus quoi faire, aidez moi !