OVH Community, votre nouvel espace communautaire.

Fichier Sh


Sp3ud
17/11/2012, 15h52
Pour être franc, le problème je ne le connais toujours pas. J'ai simplement pris un autre client.

fritz2cat
17/11/2012, 15h35
Citation Envoyé par Sp3ud
Pourquoi mauvaise réponse ?
Parce que je posais 2 questions et tu n'avais répondu à aucune des deux.
En particulier le début de ton fichier .sh avait de l'intérêt.

Tu as trouvé la réponse et j'en suis bien content.
Pour que ton expérience profite aux autres, peux-tu expliquer quel était le problème ?

Comme le dit Raph, n'installe pas n'importe quoi sur ton serveur, dont la provenance n'est pas fiable.

Frédéric

Sp3ud
17/11/2012, 15h15
Non à la base le VPS est pour mon site web, mais je me suis dit tant qu'à faire autant mettre ce client, bien sûr si cela le rend instable je le supprime de suite !

RaphAstronome
17/11/2012, 15h12
C'est un client pour l'uptime de la machine.
C'est pour un concours d'uptime ?

Parce que là j'ai du mal à saisir l'utilité.
Il faut faire attention à ne pas installer n'importe quoi sur ton dédié.

Sp3ud
17/11/2012, 15h12
Mon problème est régler

Merci à vous !

Sp3ud
17/11/2012, 11h35
Pourquoi mauvaise réponse ?

La commande uptime, je connais, mais c'est pas celle là qui m’intéresse !

J'essaie juste d'installer ce fichier install-sh qui me pose problème.

J'ai fait des tests avec d'autres fichiers, cela fonctionne mais celui-là, ça veut pas !

fritz2cat
17/11/2012, 11h32
Citation Envoyé par Sp3ud
C'est un client pour l'uptime de la machine.
Mauvaise réponse.

Sinon il y a la commande uptime

Frédéric

Sp3ud
17/11/2012, 11h18
C'est un client pour l'uptime de la machine.

fritz2cat
17/11/2012, 10h23
Quelle est la provenance de ton install-sh ? On peut voir les 3 premières lignes de ce fichier ?

Frédéric

Sp3ud
17/11/2012, 10h10
Super, merci infiniment, cela fonctionne !

Mais j'ai encore un soucis, j'ai suivi la procédure d'RaphAstronome.

Mais il ne me trouve pas mon fichier install-sh et pourtant il est bien dans le répertoire


fritz2cat
17/11/2012, 09h19
Les mots de passe ne s'affichent jamais à l'écran du ssh.
Et ça ne met pas non plus des petites boules ou des étoiles.

C'est donc normal.

Le mot de passe de 'root' se trouve dans le mail que tu as reçu d'OVH lors de la location du serveur.

Frédéric

Sp3ud
17/11/2012, 07h35
Le serveur SSH est bien ouvert, mais je n'arrive pas à me connecter, Sur le Webmin quand je clique sur le SSH Login j'ai une pop-up SSL Autorization Required, je rentre mon user : root et mon password mais ça m'indique Not connected...

Pour Putty, voici un screen. Je peut bien mettre mon user mais pour le pasword j'ai beau taper sur le clavier, aucun chiffre ne s'inscrit et pourtant le logiciel n'a pas planter.




Dois-je contacter le support ou l'erreur vient de moi ?

RaphAstronome
16/11/2012, 21h39
Redémarrer ne changera rien mis à part si tu as fermé volontairement le serveur ssh.

Sp3ud
16/11/2012, 20h58
Ok merci de ton aide. Je vais faire ça, au pire si je n'arrive toujours pas à me connectes. Je vais essayes de redemarrer le VPS mais je ne sais pas si ça changera quelque chose.

RaphAstronome
16/11/2012, 20h28
Pour ce connecter en SSH le mieux c'est d'utiliser directement un logiciel d'SSH comme putty sous Windows (je ne connais pas très bien) ou sous Linux la commande "ssh".

Sp3ud
16/11/2012, 20h25
Oui bien sûr je vais vraiment étudié la chose de plus près.

Merci pour les lignes de commandes. Mais j'ai encore un petit souci.

Je passe donc par le Webmin puis SSH, ensuite j'ai une petite fenêtre pop-up qui me demande login et mot de passe. En login je mets root puis mon password mais ça me déconnecte du SSH.

Dois je redemarrer le VPS ?

RaphAstronome
16/11/2012, 20h14
En SSH :
- tu va dans le bon répertoire avec la commande 'cd'
- tu le rend exécutable : chmod +x install.sh
- tu l'exécute : ./install.sh

Par contre tu devrais t'informer sur l'administration d'un serveur dédié et sur les commandes Linux pour gérer un VPS.

Sp3ud
16/11/2012, 18h26
Bonsoir,

Je dispose d'un VPS, mais je suis vraiment plus que novice en la matière. Je dois installer un logiciel sur mon VPS...

Je l'upload donc via le file manager et je passe par le Webmin -> Command Shell

Et je tape : /nomdurepertoire/install.sh

Mais rien ne se passe.

Je suppose donc que ma ligne de commande n'est pas la bonne, mais j'ai beau chercher, je n'arrive à rien...