OVH Community, votre nouvel espace communautaire.

PHPMailer et GMail


Nowwhat
05/11/2012, 22h09
Je me rappelle de quelque chose.

J'ai travaillé beaucoup avec le CMS qui s'appelle e107.
e107 utilise PHPMailer.
Pour que e107 utilise un gmail pour envoyer ces mails, il faut faire ceci: http://wiki.e107.org/index.php?title...SMTP_server%3F

....

Cet information est toujours correct.
Mais ......
Puis je découvre que gmail m'as donné une mail (venant de gmail.com !) avec un sujet "Suspicious sign in prevented", du genre:
Nowwhat,

Someone recently tried to use an application to sign in to your Google Account, (mon-gmail)@gmail.com. We prevented the sign-in attempt in case this was a hijacker trying to access your account. Please review the details of the sign-in attempt:

Monday, November 5, 2012 10:12:45 PM GMT
IP Address: 2001:41d0:1:97a5::4
Location: Unknown Location
....
2001:41d0:1:97a5::4 == mon serveur dédié sur laquelle tourne mon CMS 'e107' ! - en ipv6 en plus

Puis l'interface web de gmail me propose d'accepter ou refuser cette tentative.
J'ai accepté.

Maintenant, mon CMS e107 basé sur 'PHPMailer' peut de nouveau utiliser gmail comme relay smtp.
(Mais le Wiki http://wiki.e107.org/index.php?title...SMTP_server%3F doit être mise à jour)

Freemaster
05/11/2012, 17h21
moi je dirais que cela viendrais plutôt de là :

SMTP -> ERROR: AUTH not accepted from server

mais je n'ai pas ta solution

JPean.net
05/11/2012, 16h03
Merci Nowhat

J'ai modifié comme cela :
Code:
$mail->SMTPSecure = "ssl";
// sets the prefix to the servier
$mail->Host = 'smtp.gmail.com';
$mail->Port = 465;
Et j'ai toujours le même message d'erreur :
SMTP -> ERROR: EHLO not accepted from server:
SMTP -> ERROR: HELO not accepted from server:
SMTP -> ERROR: AUTH not accepted from server:
SMTP -> NOTICE: EOF caught while checking if connected
Un problème est survenu lors de l'envoi des emails. : The following From address failed: monmail@gmail.com
Je vois dans la page que tu m'as indiqué :
Délais d'expiration du serveur Supérieurs à 1 minute, nous recommandons 5 minutes
ça pourrai venir de là ? si oui, je n'ai aucune idée de comment configurer PHPMailer pour obéir à cette directive...

Nowwhat
05/11/2012, 15h24
Si si.
Regarde chez gmail http://support.google.com/mail/bin/s...rom=75726&rd=1
puis coche "Je souhaite activer le protocole POP" puis coche "Autre".
Et la, on parle de SSL au lieu de ton TLS.

JPean.net
05/11/2012, 14h26
Personne n'a une idée ?

JPean.net
01/11/2012, 10h47
Bonjour

J'essaye depuis plusieurs heures de configurer correctement mon PHPMailer mais en vain. Je viens donc vous demander de l'aide

Voici mon script :

Code:
		$mail = new PHPmailer();
		$mail->isSMTP();
		$mail->Host = 'smtp.gmail.com';
		$mail->SMTPDebug  = 1;                     // enables SMTP debug information (for testing)
		// 1 = errors and messages
		// 2 = messages only

		$mail->SMTPAuth   = true;                  // enable SMTP authentication
		$mail->SMTPSecure = "tls";                 // sets the prefix to the servier
		$mail->Host = 'smtp.gmail.com';
		$mail->Port = 587;
		$mail->Username   = "monmail@gmail.com";  // GMAIL username
		$mail->Password   = "monpassword";            // GMAIL password
		
//		$mail->setFrom("monmail@gmail.com", "Moi");
		$mail->isHTML(true);
		$mail->SetLanguage("en", '../wp-includes/phpmailer/language/');		

		$mail->Subject    = $subject;
		 
		$mail->AltBody    = "$message"; // optional, comment out and test
		 
		$mail->Body = "mon message";
		
		if ($mail->send()) {
			return "Mail envoyé à $i personnes.";
		} else {
			return "Un problème est survenu lors de l'envoi des emails. : ".$mail->ErrorInfo."";
		}
	}
à chaque fois, j'ai :
SMTP -> ERROR: EHLO not accepted from server:
SMTP -> ERROR: HELO not accepted from server:
SMTP -> ERROR: AUTH not accepted from server:
SMTP -> NOTICE: EOF caught while checking if connected

Un problème est survenu lors de l'envoi des emails. : The following From address failed: monmail@gmail.com
Merci d'avance pour votre aide