OVH Community, votre nouvel espace communautaire.

Problème de réception de mails depuis OVH.


fritz2cat
15/12/2012, 21h00
pour info il y a le même problème sur http://forum.ovh.com/showthread.php?t=85075

Frédéric

brice.capelle
10/12/2012, 09h41
Bon il aura fallut du temps et sans compter l'aide tardive de OVH.

Il faut qu'un domaine réponde sur "dig ANY domain.tld" afin qu'il puissent trouver les bonnes info et délivrer le mail.

Pourquoi je ne sais pas ... alors que tout le monde cherche en général les MX. Faudrait qu'ils patchent leur Qmail.

J'espère que cela pourra aider ceux qui étaient dans notre cas !

fritz2cat
07/11/2012, 18h19
Je vais déterrer cette conversation.

Si le mutu d'OVH a des difficultés pour discuter (au niveau SMTP) avec tes serveurs MX, tu devrais en voir une quelconque trace dans tes fichiers logs.

Je confirme que mon mail sortant ne passe plus par le mutu depuis des années et je passe de meilleures nuits qu'avant donc c'est direct du producteur au consommateur.

Frédéric

brice.capelle
30/10/2012, 13h20
Salutations !

dp n'est pas un adresse qui existe donc elle n'a pas fonctioné, c'était notre correspondant externe qui lui passe par OVH

Par contre j'ai bien reçu l'autre mail intitulé simplement "test mail" envoyé par postmaster et sans retard. Mais j'ai l'impression qu'il est passé direct du serveur au miens sans passer par les serveurs d'envoi de mail OVH. Très certainement mutualisés.

Merci pour le test

PS: je n'ai toujours aucune nouvelle d'OVH malgré mes relances.

fritz2cat
25/10/2012, 18h26
Je t'ai envoyé 2 mails:

Un est passé, et l'autre pas:

Oct 25 19:21:12 v2 postfix/smtp[29508]: 5CE48D84EE: to=, relay=mx0.euler!an.net[109.232.193.6]:25, delay=0.32, delays=0.08/0/0.21/0.02, dsn=5.1.1, status=bounced (host mx0.euler!an.net[109.232.193.6] said: 550 5.1.1 : Recipient address rejected: euler!an.com (in reply to RCPT TO command))

Oct 25 19:21:14 v2 postfix/smtp[29507]: 99715D80AF: to=, relay=mx0.euler!an.net[109.232.193.6]:25, delay=3.1, delays=0.08/0/0.16/2.9, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as B1D1E2040FA6)
As-tu reçu quelque chose ?

Peux-tu poster les en-têtes d'un message que tu as reçu avec beaucoup de retard ?

Frédéric

brice.capelle
25/10/2012, 14h09
@Nowwhat: Non rien vu et j'ai regardé dans le SPAM aussi pour être sur. Rien reçu. Il n'est pas exclu que d'içi quelques jour tu reçoives un mail d'erreur car il est resté trop longtemps en queue.

@fritz2cat: Oui toute personne passant par les serveurs mails OVH ne peuvent pas nous joindre, des fois on reçoit certain mail 2 semaines plus tard. Mais c'est rare.

Pourtant le message d'erreur Qmail indique bien qu'il ne trouve pas le CNAME ... C'est surtout cette partie qui m'intrigue :/

fritz2cat
25/10/2012, 10h47
Pour être bien certain de la question, ce sont bien d'autres clients ovh qui sont dans l'impossibilité de t'écrire sur ton adresse @euler!an.com ?

La commande dig euler!an.com mx me renvoie une réponse parfaitement correcte et qui ne fait que 222 caractères, ce qui semble exclure le bug Qmail.

Frédéric

Nowwhat
25/10/2012, 10h33
Vu pour le MX, c'est ton host avec l'extension dot net

Je t’envoie un mail à partir de postmaster@papy-team.fr - avec le serveur mail du Mutu OVH que va avec. Je suis passé par mon smtp.
A 11h30.
Vu quelque chose ?

brice.capelle
25/10/2012, 09h29
Bonjour à tous !

Donc non nous n'utilisons pas les services OVH pour nos mails nous gérons nous même le serveur. Il est passé d'un serveurs Cyrus à Zimbra. L'ancien serveur je ne le connais pas trop mais cela n'a pas corrigé le problème.

Pour le soucis de QMAIL, c'est en fait un des rares messages d'erreurs que nous avons reçu d'un de nos clients. Et ces messages d'erreurs proviennent des serveurs OVH. Donc si un des serveurs n'est pas patché pour signé les DNS en effet cela pourrait posé problème.

Exemple:
Exemple de mail d'erreur:/ >:/
/eulerian.com : CNAME lookup
failed
temporarily
(Connection timed out) (#4.4.3)/
/|MAIL_FROM: >|CNAME_lookup_failed_te
mporarily
_(Connection_timed_out)?I'm
not going to try again; this message has been in the queue
too long."/

En gros votre serveur mail essaye de trouver le CNAME
eulerian.com alors que nos MX sont correctement
configurés.

Comme vous l'avez deviné, le domaine est eulerian.com. Pour tester avec un mail suffit de mettre mon prénom avant le @ !

Pour info j'ai eu un message hier soir avant de partir pour me dire qu'ils vérifiaient du coté des admins. Ce qui est un peu abusé vu que c'est ce qu'il m'a été dit 2 semaines plus tôt :/

Encore merci pour votre aide, je pense que le coups de DNSSEC pourrait etre la cause. On a aussi du DKIM de notre coté mais personne n'a eu de soucis pour l'instant pour nous joindre hormis ceux qui ont OVH.

fritz2cat
24/10/2012, 21h57
Je parie que Brice utilise une ancestrale version non patchée de Qmail, et qui craque sur les réponses DNS d'une taille supérieure à 512 bytes.

Maintenant que OVH signe les réponses DNS avec DNSSEC on est vite à 512 bytes dans les réponses DNS.

@Brice, quel est ton nom de domaine ?

@Nicolas, je ne vois pas le rapport.

Frédéric

NicolasLines
24/10/2012, 21h34
...

fritz2cat
24/10/2012, 14h53
Il faudrait ton nom de domaine pour pouvoir investiguer plus en avant.

Édit: gillé une fois de plus par Nowwhat

Frédéric

Nowwhat
24/10/2012, 14h52
Bonjour,

Ces 'clients' sont donc des gens avec un mail 'Mutu' chez OVH, c'est ça ?
Ou des clients avec un serveur mail sur dédié chez OVH ?

Ces mails sont vaporisés, il n'y a pas des bounces ?

T'es sur que l'IP de ton serveur ne figure sur aucun 'blacklist' ?

Et comment savoir que c'est "leur" QMAIL (OVH travaille sur leur serveurs publiques, comme Mutu etc de plus en plus avec postfix) qui cherche un CNAME ? La source de ce petit détail m’intrigue.

A savoir, pas mal des visiteurs/lecteurs de ta question ont des services mail chez OVH.
Pourquoi tu te laisse pas tester ??
Quelques vrais expert 'en email' sont présent ici, mais ils ne peuvent RIEN faire car: pas de domaines, pas d'adresses mail, pas d'IP's.

brice.capelle
24/10/2012, 13h50
Merci pour la réponse.

J'ai du mal m'exprimer.

En fait les mails d'OVH vers notre serveur de mails ne sont pas reçu puisqu'il n'arrivent pas du tout à nous joindre. Et ce car leur QMAIL cherche un CNAME au lieu d'un MX.

Mais notre serveur de mail n'a rien à voir avec la plateforme OVH. On l'héberge en propre dans un Datacenter. On a d'ailleurs changé de serveur il y a peu mais bien entendu cela n'a pas améliorer les choses vu qu'OVH ne nous trouve meme pas. Et seul OVH ne nous trouve pas dans le monde ...

Impossible d'avoir des infos de leur part, je suis prêt à faire des modifs de notre coté si besoin. Un ticket a été ouvert depuis plusieurs mois pourtant ... le forum reste notre dernier espoir de faire bouger les choses.

Bref j'ai toujours des clients qui ralent car nous sommes pour eux injoignable alors que le problème ne vient semble t'il pas de chez nous :/

fritz2cat
23/10/2012, 21h46
Tout ceci se passe-t-il sur le mutualisé ? Ou bien y a-t-il un dédié loué par l'entreprise ? Est-ce une release 2 ? Est-elle à jour ?

Il est question de Qmail. Est-il à jour ?

Frédéric

brice.capelle
22/10/2012, 17h37
Bonjour,

Cela fait plusieurs mois que l'entreprise dans laquelle de travail a des soucis de mails avec les serveurs OVH. En effet 95% de mails qui sont transité par OVH n'arrive pas du tout à destination, ceux qui arrive par contre ont des jours et des jours de retard, cela peut aller jusqu'à une semaine ou plus. Je n'ai pas vraiment calculé.

Nous avons pas mal de nos clients qui passent par OVH pour nous envoyer des mails et donc des demandes de support. Impossible à satisfaire puisque cela n'arrive pas ...

J'ai remonté le problème il y a plusieurs mois mais ceci est toujours au points mort.

Il semble que le QMAIL ne trouve pas le CNAME de notre domaine, d'après les message d'erreur que quelques client ont pu nous communiquer. Je ne vois pas pourquoi puisqu'il est sensé chercher les MX.

Sommes nous les seuls à avoir ce soucis ?