OVH Community, votre nouvel espace communautaire.

Configuration des mails sur RPS


Toumilovitch
03/09/2012, 23h51
C'est clair ! t'as bien fait de me le rappeler...

fritz2cat
03/09/2012, 22h58
Non ce n'est pas fini, il te reste à supprimer le compte 'essaiovh' avec lequel n'importe qui pourrait commencer à spammer la terre entière.

Frédéric

Toumilovitch
03/09/2012, 22h38
Merci à vous tous pour votre aide dans ma quête pour ouvrir mes quelques 250 mails reçus !

En effet, je viens de trouver la solution ! Finalement, il ne s'agissait pas d'un problème sur mon serveur ni d'une mauvaise configuration d'Outlook...
Il s'avère que mon bon vieux Avast qui me sert d'antivirus forçait le port pop3 à se connecter sur le port 995 au lieu de 110 ! Du coup j'ai rectifié la config d'avast et maintenant ça fonctionne.
C'est assez étrange, le changement de config d'Avast (sans doute une mise à jour) à coïncidé exactement avec le moment où j'ai réinstallé l'OS de mon serveur.

Je me serais bien arraché les cheveux sur ce coup là !

Merci à vous pour votre patience.

cassiopee
03/09/2012, 15h21
Citation Envoyé par Nowwhat
Lui qui a eu cette idée de déposer un mail quelque part sans s'authentifier d'abord sur la porte 25 d'un serveur mail mérite la perpétuité. Ça a causer énormément des problèmes (open relays etc).
ça semblera incroyable à tous ceux qui connaissent Internet que depuis moins de 10 ans
mais fut une époque, on pouvait de servir de n'importe quel serveur SMTP (dans le monde)
pour émettre ses messages à destination de n'importe quel destinataire ...

Bien entendu, c'était avant le spam ne prenne de l'ampleur

Nowwhat
03/09/2012, 14h30
Hummm.
De tout façon: envoyer un mail par smtp sur la "25" est une connerie.
Quasiment toutes les FAI accepte un genre de "submission" - je sais qu'Orange le fait.

Lui qui a eu cette idée de déposer un mail quelque part sans s'authentifier d'abord sur la porte 25 d'un serveur mail mérite la perpétuité. Ça a causer énormément des problèmes (open relays etc).

fritz2cat
03/09/2012, 13h07
Return-Path:
Delivered-To: essaiovh@gymaweb.com
Received: (qmail 26094 invoked by uid 508); 3 Sep 2012 10:46:09 -0000
Received: from unknown (HELO S) (213.49.249.21)
by r17002.ovh.net with SMTP; 3 Sep 2012 10:46:09 -0000
From: "test forum ovh"
To:
Subject: =?iso-8859-1?Q?test_via_le_SMTP_de_ton_RPS_=28non_authentifi= E9=29?=
Date: Mon, 3 Sep 2012 12:46:01 +0200
Message-ID: <000001cd89c1$4f43a8a0$edcaf9e0$@gymaweb.com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0001_01CD89D2.12CEC290"
X-Mailer: Microsoft Outlook 14.0
Thread-Index: Ac2JwU1zdNtjpnF+RseGpYvUQQbnLg==
Content-Language: fr-be
Réponse: Microsoft Outlook 14.0
c'est à dire Office 2010.

Pour le POP3 ce sont les réglages absolument standard !!!!

Pour le SMTP il faut aller dans "avancé" et changer le port 25 en 587 si tu ne sais pas envoyer de mail.

Frédéric

Toumilovitch
03/09/2012, 11h52
J'ai bien mis 587 pour le port smtp et 110 pour pop.
Tu as testé avec quel client de messagerie ??

Peux-tu me donner ta configuration ?

fritz2cat
03/09/2012, 11h47
Tout fonctionne parfaitement, pour autant que tu utilises le port 587 pour le SMTP sortant.
J'ai testé POP3 mais pas IMAP.

(587 parce que les FAI bloquent le port 25)

Frédéric

Toumilovitch
03/09/2012, 10h34
Franchement, je pense que j'ai fait le tour avec Outlook... J'ai aussi essayé avec Incredimail.

Si quelqu'un pouvait essayer de configurer cette adresse dans un client messagerie pour voir ce serait sympa.
Adresse : essaiovh@gymaweb.com
mot de passe : essaiovh
utilisateur : essaiovh@gymaweb.com
pop : pop3.gymaweb.com
smtp : smtp.gymaweb.com

Merci beaucoup.
Mickaël

fritz2cat
03/09/2012, 06h53
Que ton serveur POP3 fonctionne ! C'est dans Outlook que tu as dû laisser traîner un mauvais réglage..

Frédéric

Toumilovitch
02/09/2012, 23h22
Oui ça fonctionne... Ça veut dire quoi ?

fritz2cat
02/09/2012, 15h09
Est-ce que tu arrives à ouvrir ta boîte POP à partir d'ici ? http://www.mail2web.com/login/?lid=0&il=0

Frédéric

Toumilovitch
02/09/2012, 12h56
Bonjour,

J'ai contacté le support qui peine à trouver une solution... Voici ce qu'ils me disent :
Bonjour,

Dans un premier temps, il faut savoir que la plupart des fournisseurs d'acces bloquent l'acces au port 25 à leurs serveurs smtp uniquement. Pour contourner cela, je vous recommande de suivre cette documentation:

http://guides.ovh.com/ajouterportsmtp#link2

Afin d'ouvrir un port smtp alternatif (587), une fois cela fait vous pourrez utiliser ce port pour l'envoi.

L'authentification via pop fonctionne comme le montre le test ci dessous:

root@son:~# telnet r17002.ovh.net 110
Trying 91.121.58.139...
Connected to r17002.ovh.net.
Escape character is '^]'.
+OK <14546.1346402207@r17002.ovh.net>
user essaiovh@gymaweb.com
+OK
pass essaiovh
+OK
list
+OK
1 852
.
retr 1
+OK
Return-Path:
Delivered-To: essaiovh@gymaweb.com
Received: (qmail 14414 invoked by uid 509); 31 Aug 2012 08:35:47 -0000
Received: from 94.23.11.218 by r17002.ovh.net (envelope-from , uid 508) with qmail-scanner-2.01st
(clamdscan: 0.96.1/12620. spamassassin: 3.3.1. perlscan: 2.01st.
Clear:RC:0(94.23.11.218):SA:0(1.3/6.0):.
Processed in 2.231273 secs); 31 Aug 2012 08:35:47 -0000
X-Spam-Status: No, hits=1.3 required=6.0
X-Spam-Level: +
Received: from unknown (HELO r18959.ovh.net) (94.23.11.218)
by r17002.ovh.net with AES256-SHA encrypted SMTP; 31 Aug 2012 08:35:45 -0000
Received: (qmail 1799 invoked by uid 0); 31 Aug 2012 08:38:27 -0000
Date: 31 Aug 2012 08:38:26 -0000
Message-ID: <20120831083826.1798.qmail@r18959.ovh.net>
From: root@r18959.ovh.net
To: essaiovh@gymaweb.com
Subject: test

test

.


Et suite à l'authentification via pop, l'envoi via smtp est possible:

root@son:~# telnet r17002.ovh.net 25
Trying 91.121.58.139...
Connected to r17002.ovh.net.
Escape character is '^]'.
220 r17002.ovh.net ESMTP
ehlo toa
250-r17002.ovh.net
250-PIPELINING
250-STARTTLS
250-8BITMIME
250 SIZE 0
mail from: essaiovh@gymaweb.com
250 ok
rcpt to: XXX@ovh.net
250 ok
data
354 go ahead
subject: test
test message
.
250 ok 1346402335 qp 14768
J'ai donc ouvert le port 587 comme ils me l'indiquent mais ça ne fonctionne pas.

Ce que je trouve étrange c'est qu'ils me parlent de SMTP alors que Outlook me dit qu'il ne parvient pas à se connecter au serveur POP3...

Un grand merci d'avance à celui qui pourra m'aider !

Toumilovitch
30/08/2012, 04h09
Citation Envoyé par fritz2cat
aïe aïe... ça n'a rien à voir

Tu as une release OVH : suis bien les guides (guides.ovh.net) car tu es dans le meilleur cas pour avoir des explications fiables de la part d'OVH.

Frédéric
Ah oui ? J'ai beaucoup cherché dans les guides et j'ai pas résolu mon affaire. Peut-être j'ai pas trouvé les bons ou n'existent-ils pas.

J'ai contacté le support et au bout d'une quinzaine d'échanges j'ai rien réglé du tout ! Le gars part toujours sur autre chose genre les mails du domaine mutualisé ou m'a demandé 3 fois ma config d'Outlook... Franchement ça saoule...

fritz2cat
29/08/2012, 20h21
aïe aïe... ça n'a rien à voir

Tu as une release OVH : suis bien les guides (guides.ovh.net) car tu es dans le meilleur cas pour avoir des explications fiables de la part d'OVH.

Frédéric

Toumilovitch
29/08/2012, 20h11
Je suppose que c'est normal puisque cette adresse existe aussi sur l'administration des mails dans le manager OVH...

fritz2cat
29/08/2012, 19h57
Je t'ai envoyé un mail à ton adresse postmaster. Il a été accepté par ton serveur.

Frédéric

Toumilovitch
29/08/2012, 19h47
Citation Envoyé par fritz2cat
Ton serveur DNS est de nouveau KO.
Ton domaine est donc en panne.

Edit: non c'est OK, je ne sais pas quel a été le problème.

Pour le reste il semble bien que tes services SMTP, POP3 et IMAP sont fonctionnels.

Frédéric
Quand je fais des modifs, je redémarre les services. Je pense que tu as été sur mon domaine pendant un redémarrage.

Sinon, non, ce n'est pas fonctionnel...

fritz2cat
29/08/2012, 19h42
Ton serveur DNS est de nouveau KO.
Ton domaine est donc en panne.

Edit: non c'est OK, je ne sais pas quel a été le problème.

Pour le reste il semble bien que tes services SMTP, POP3 et IMAP sont fonctionnels.

Frédéric

Toumilovitch
29/08/2012, 19h37
Je peux affirmer à 100% que mon Outlook utilise le port 110 ! j'avais même essayé avec un autre client de messagerie et j'avais le même message avec 995. Ca parait louche je sais...

Par contre, quand je vais dans le manager OVH - zones DNS, j'ai ça qui est complètement différent de ce que je peux avoir sur BIND.
Roooo la la comment que je suis complètement perdu !!!


Freemaster
29/08/2012, 19h31
IN MX 10 mail.gymaweb.com.
mail IN A 91.121.58.139

c'était très bien...

mais -ERR Cannot connect to POP server 91.121.58.139 (91.121.58.139:995), connect error 10061
indique que tu essaies de passer en mode sécurisé (995) au lieu du port standard 110 (qui lui est open)

Toumilovitch
29/08/2012, 18h55
Citation Envoyé par Freemaster
NON !
le MX doit être un hostname, qui lui doit être un IN A 91.121.58.139
J'ai un peu de mal à saisir... ça veut dire qu'il faudrait que je supprime la ligne avec le MX ?

Voici mon fichier d'enregistrement BIND integrale :

gymaweb.com. IN SOA gymaweb.com. postmaster.gymaweb.com. (
2012082905
21600
3600
604800
86400 )
IN NS r17002.ovh.net.
IN NS sdns2.ovh.net.
IN MX 10 mx0.ovh.net.
IN A 91.121.58.139
www IN A 91.121.58.139
mail IN A 91.121.58.139
smtp IN A 91.121.58.139
pop IN A 91.121.58.139
pop3 IN A 91.121.58.139
imap IN A 91.121.58.139
sql IN A 91.121.58.139
mysql IN A 91.121.58.139

Là je me suis focalisé sur BIND mais peut-être que le problème vient d'ailleurs ?

Freemaster
29/08/2012, 18h51
Citation Envoyé par Toumilovitch
puis-je remplacer IN MX 10 mail.gymaweb.com. par IN MX 91.121.58.139 ?
NON !
le MX doit être un hostname, qui lui doit être un IN A 91.121.58.139

Toumilovitch
29/08/2012, 18h26
Donc si je redirige sur mon mutualisé alors c'est pas ça... puis-je remplacer IN MX 10 mail.gymaweb.com. par IN MX 91.121.58.139 ?

C'est dingue de ne pas trouver de guide OVH sur le sujet tout de même !

fritz2cat
29/08/2012, 15h30
Bonjour,

Je vois que tu as redirigé le mx de ton domaine sur le mutu OVH (mx0.ovh.net).
C'est une bonne idée tant que ton RPS refuse les connexions entrantes sur le port 25.
Malheureusement je n'ai aucune expérience avec qmail et je ne suis pas ton interlocuteur de choix...

Frédéric

Toumilovitch
28/08/2012, 19h59
Merci pour vos réponses ! :-) En effet, je suis complètement perdu !

J'ai essayé d'appliquer "à la lettre" ce que vous me dites. Donc je récapitule :
- J'ai mis le DNS secondaire sur sdns2.ovh.net
- je suis retourné sur l'admin de mon domaine et j'ai mis r17002.ovh.net en DNS primaire et sdns2.ovh.net en DNS secondaire.

Visiblement ça ne suffit pas pour récupérer les mails créées sur le serveur avec Qmailadmin.

J'ai donc été voir sur BIND et voici ce que j'ai sur mon fichier d'enregistrements de mon domaine :
IN NS r17002.ovh.net.
IN NS sdns2.ovh.net.
IN MX 10 mail.gymaweb.com.
mail IN A 91.121.58.139
smtp IN A 91.121.58.139
pop IN A 91.121.58.139
pop3 IN A 91.121.58.139
imap IN A 91.121.58.139

Est-ce correct ?

Aussi dans le message d'erreur de outlook, si vous regardez mon premier post, on voit qu'il utilise le port 995. Je précise bien entendu que mon client est bien configuré sur le port 110. D'ailleurs il fonctionnait très bien depuis des années avec cette config avant que je réinstalle l'OS du serveur.

Il ne doit certainement pas manquer garnd chose et malgré toutes mes recherches sur la toile, je m'étonne d'être le seul à avoir ce problème.

Merci pour votre aide.
Mickaël

fritz2cat
25/08/2012, 18h02
Complément d'information.

Ton RPS r17002.ovh.net répond effectivement des trucs intelligents pour ton domaine. Donc il faudrait envisager de changer ns.ovh.net et dns.ovh.net dans les propriétés de ton domaine, en mettant r17002.ovh.net et sdns2.ovh.net.

MAIS (et il y a un mais) tu dois d'abord reconfigurer le zone transfer de ton RPS vers sdns2, qui refuse de répondre pour ton domaine.
Voir http://guides.ovh.com/InstallDNSSecondaire

Frédéric

fritz2cat
25/08/2012, 17h57
pop3.gymaweb.com est un synonyme de ns0.ovh.net, c'est-à-dire le mutualisé et non un serveur dédié (rappel: RPS est un dédié)

A mon avis tu fais une grosse soupe entre le DNS, l'hébergement web et l'hébergement mail de ton domaine.

Comme c'est configuré aujourd'hui, ni le DNS, ni le Web, ni le mail du domaine gymaweb.com ne sont pris en charge par ton RPS.

Frédéric

Toumilovitch
25/08/2012, 11h38
Bonjour,

Il y a quelques jours, j'ai réinstallé l'OS de mon serveur RPS et depuis, je n'arrive plus à consulter mes mails via Outlook.
Mes adresses sont bien présentes sur qmailadmin.

Le seul paramètrage que j'ai fait, c'est les noms des serveurs DNS :
primaire : dns.ovh.net | secondaire : ns.ovh.net

J'imagine que j'ai oublié quelque chose mais je ne sais pas quoi. Je ne maîtrise pas vraiment l'administration du serveur...
J'ai vu ce guide mais je ne sais pas faire ce qui est écrit. C'est quoi ? : http://guide.ovh.com/VpopmailEtAdministration

j'ai cette erreur pour chaque adresse mail : La connection au serveur a été interrompue. Réponse du serveur : -ERR Cannot connect to POP server 91.121.58.139 (91.121.58.139:995), connect error 10061

Même si je sais que ça ne vient pas de là car ça marchait très bien depuis des années, voici ma config pour l'adresse toumilovitch@gymaweb.com :
Adresse de messagerie : toumilovitch@gymaweb.com
Type de compte : POP
serveur de courrier entrant : pop3.gymaweb.com
serveur de courrier sortant (SMTP) : smtp.gymaweb.com
Nom d'utilisateur : toumilovitch@gymaweb.com
Mot de passe : **********
Exiger l'authentification par mot de passe sécurisé (SPA) lors de la connexion : non coché

PARAMETRES SUPPLEMENTAIRES :
Onglet Serveur sortant :
Mon serveur sortant (SMTP) requiert une authentification : coché
-> Utiliser les mêmes paramètres que mon serveur de courrier entrant

Onglet Options avancées :
Serveur entrant (POP3) : 110
Ce serveur nécessite une connexion chiffrée (SSL) : non coché
Serveur sortant (SMTP) : 25
Utiliser le type de connexion chiffrée suivant : Aucun
Délai du serveur : 1 minute


Merci d'avance pour votre aide.
Mickaël