OVH Community, votre nouvel espace communautaire.

500 internal server error sur .htaccess


Darkdalia
03/10/2013, 01h30
désolée :-/

Nowwhat
03/10/2013, 01h11
Ce n'est pas bien vu de poster deux fois la même question sur le même forum.

http://forum.ovh.com/showthread.php?t=77344&page=7

Darkdalia
03/10/2013, 00h43
bonjour à tous,
je suis completement noob et j'ai beau avoir passé 5h (hé oui... j'ai persisté...) a chercher sur le forum et avoir testé une trentaine de manipulation, je demande officiellement de l'aide.

j'ai acheté un nom de domaine, et évidemment, en voulant installer wordpress, j'ai fait l'erreur d'effacer les fichiers cgi-bin et www.

Mais ça, a force de chercher, je crois l'avoir résolu.
En revanche, j'ai d'abord rencontré le message d'erreur me dsant que mon php était 4.4.9 etc...

J'ai donc crée un fichier .htaccess en suivant le guide de OVH, mais maintenant j'ai l'erreur 500.

Quelqu'un peut-il m'aider svp??
je pensais que c'était simple et je suis larguée totalement.

Merci beaucoup pour vos réponses.
Darkdalia

gaboul49
16/07/2012, 10h43
\xef\xbb\xbf
Pour éviter ça, il faut sauvegarder le fichier en UTF8 "sans BOM".

sylvainde
16/07/2012, 10h39
C'est bon, sauvé en ANSI, j'ai pu mettre un .htaccess 'Redirect 301 / http://nouveaudomaine.net/' dans le répertoire de mon sous domaine...

La redirection de fait bien, et je suppose que c'est bien en 301 (la console développeur de Firefox n'affiche pas la redirection et commence directement au nouveau domaine).

Merci pour votre aide!

sylvainde
16/07/2012, 10h22
Merci pour le lien vers les logs, cassiopee...

A priori, c'est bien un pb d'encoding... Voici le log:

.htaccess: Invalid command '\xef\xbb\xbfRedirect', perhaps misspelled or defined by a module not included in the server configuration
Ce préfixe \xef\xbb\xbf est apparemment de l'unicode (mal) lu par Apache...

Ca progresse...

cassiopee
16/07/2012, 00h17
A priori je dirais de ne pas encoder en UTF8 justement (ASCII pur à la place).

S'il y a une erreur 500, il y a une trace plus détaillée dans le fichier de log des erreurs
de l'hébergement.

voir par là : https://logs.ovh.net

le fichier des "errors".

(le login est le même que pour accéder au manager d'OVH)

sylvainde
15/07/2012, 23h53
Il n'y a pas le moindre fichier php sur mon hébergement...
La seule chose non statique est le .htaccess que je tente de mettre en place...

Mais peut-être faut-t'il activer un mode php dans le manager pour qu'un htaccess puisse fonctionner? J'avoue être complêtement débutant pour le coup...

Que dois-je mettre dans un .htaccess, si je veux qu'il ne fasse rien?
RewriteEngine off?
Rien du tout?

Merci...

Gaston_Phone
15/07/2012, 19h06
L'erreur 500 peut provenir d'une boucle sans fin d'un script PHP.

sylvainde
15/07/2012, 17h21
Bonjour à tous.

Cela fait quelques heures que je cherche à positionner un .htaccess à la racine d'un sous domaine, qui ne débouche PAS sur une 500 internal server error.

J'ai essayé pas mal de syntaxes différentes trouvées sur le web, sans succès. J'ai même essayé un .htaccess vide => erreur 500.

J'ai bien fait attention à encoder mon fichier en UTF8...


Quelqu'un peut-t'il m'aider et me transmettre un .htaccess (même s'il ne fait rien du tout!) qui ne crée pas d'erreur 500 sur un hébergement mutualisé OVH?


Y-a-t'il une option à activer pour que le .htaccess puisse fonctionner?

Pour info, au départ, je voulais faire une redirection permanente (301) de l'ensemble d'un sous domaine vers un nouveau domaine.
Dans mon manager le sous domaine en question est associé à un répertoire /rep1/rep2/ sur mon ftp -rep1 et rep2 ne correspondent pas précisément au nom de mon sous domaine-.
J'essaie donc de placer un fichier .htaccess dans rep2/.

Si au moins je pouvais placer un .htaccess, même "vide", qui ne plante pas, j'aurais déjà bien progressé...

Merci...