OVH Community, votre nouvel espace communautaire.

CDN ne met pas en cache


sergead
16/07/2012, 09h33
Bonjour,

en fait je viens de remarquer que le HTTPS n'est pas encore pris en compte par la Beta et vu que c'est pour une appli facebook, il me faut absolument du HTTPS.
Donc je laisse tomber ce CDN je vais m'orienter sur autre chose.

Merci pour votre aide.
Serge

gaboul49
15/07/2012, 09h58
Peux-tu mettre des urls de test : Une qui pointe directement vers le fichier de ton serveur, un autre lien en passant par le CDN. Sans ça, difficile de diagnostiquer.

sergead
13/07/2012, 11h07
Bonjour,

oui c'est vrai je l'avais enlevé en fait parceque ça ne fonctionnait pas mais même en remettant ma config j'ai l'erreur. Voici ma config :

Code HTML:

 ExpiresActive On
 ExpiresDefault "access plus 7200 seconds"
 ExpiresByType image/jpg "access plus 2592000 seconds"
 ExpiresByType image/jpeg "access plus 2592000 seconds"
 ExpiresByType image/png "access plus 2592000 seconds"
 ExpiresByType image/gif "access plus 2592000 seconds"
 AddType image/x-icon .ico
 ExpiresByType image/ico "access plus 2592000 seconds"
 ExpiresByType image/icon "access plus 2592000 seconds"
 ExpiresByType image/x-icon "access plus 2592000 seconds"
 ExpiresByType text/css "access plus 2592000 seconds"
 ExpiresByType text/javascript "access plus 2592000 seconds"
 ExpiresByType text/html "access plus 7200 seconds"
 ExpiresByType application/xhtml+xml "access plus 7200 seconds"
 ExpiresByType application/javascript A259200
 ExpiresByType application/x-javascript "access plus 2592000 seconds"
 ExpiresByType application/x-shockwave-flash "access plus 2592000 seconds"


## BEGIN Cache-Control Headers

 
 Header set Cache-Control "max-age=2592000, public"
 
 
 Header set Cache-Control "max-age=2592000, private"
 

Header set Cache-Control "max-age=7200, public"

# Disable caching for scripts and other dynamic files

Header unset Cache-Control


# END Cache-Control Headers
et toujours la mm chose dans les Headers :

(Status-Line) HTTP/1.1 200 OK
Last-Modified Tue, 10 Jul 2012 14:04:16 GMT
Etag "5ea-4c47a34b25800"
Accept-Ranges bytes, bytes
Cache-Control max-age=2592000, public, private
Expires Sun, 12 Aug 2012 08:55:31 GMT
Content-Type image/png
Proxy-Connection close
Content-Length 1514
Date Fri, 13 Jul 2012 08:55:31 GMT
Connection keep-alive
X-Cacheable Not cacheable: private
X-CDN-Geo gsw

Mais normalement il ne devrait pas avoir d'impact sur le CDN parceque c'est le CDN qui doit mettre en cache et donc envoyer les Headers grâce à la config sur le managerv5 ?

rekcah
12/07/2012, 17h00
Salut,

Tu a la réponse dans ton header:
Cache-Control private
et OVH confirme dans le header:
X-Cacheable Not cacheable: private

Pour que le cache fonctionne, dans ta config apache tu ajoute un règle pour les image/css/js dans ce genre:


Header set Cache-Control "max-age=86000000, public"

sergead
12/07/2012, 14h56
Bonjour,

je viens de tester le CDN sur des images en static et malheureusement le CDN rapelle à chaque fois mon serveur ....
Pourquoi ne met-il pas en cache mon image alors que j'ai bien configuré la mise en cache pour les images de type png/jpeg/gif ??
L'appel est fait depuis la France.

Dans les headers de retour j'ai ça :

(Status-Line) HTTP/1.1 200 OK
Last-Modified Tue, 10 Jul 2012 14:04:16 GMT
Etag "5ea-4c47a34b25800"
Accept-Ranges bytes, bytes
Content-Type image/png
Cache-Control private
Proxy-Connection close
Content-Length 1514
Date Thu, 12 Jul 2012 12:48:55 GMT
Connection keep-alive
X-Cacheable Not cacheable: private
X-CDN-Geo gsw

Y a t'il une configuration particulière sur les serveurs Apache à mettre en place ?

Merci de votre aide.
Serge