OVH Community, votre nouvel espace communautaire.

CDN sur Mutualisé : 404 sur le contenu


ddavid
10/07/2012, 15h49
Citation Envoyé par buddy
salut,
oui le .htaccess le permet néanmoins, il faut faire attention à imposer le domaine principal uniquement sur les fichiers .html et .php sinon aucune image ne sera mise en cache via le cdn.
En général, la config suivante me plait bien :
* redirection vers le domaine principal dès lors que le "-f" ne passe pas (pas de fichier statique dispo, d'où un 404 renvoyé par le domaine principal, ou un contenu délivré suite à l'utilisation de mod_rewrite)
* redirection vers le domaine principal si l'on à affaire à un ".php" , ".htm", ".html"

À adapter bien entendu selon les cas...

buddy
09/07/2012, 21h11
* rien n'oblige à délivrer la même réponse parce que le dossier est le même, au contraire... Le .htaccess permet d'éviter ça, et de faire des redirections à chaque fois que le mauvais FQDN est interrogé...
salut,
oui le .htaccess le permet néanmoins, il faut faire attention à imposer le domaine principal uniquement sur les fichiers .html et .php sinon aucune image ne sera mise en cache via le cdn.

aurel92
09/07/2012, 18h12
@ddavid : pour le test du host, à mon avis ... tu as raison

Pour le reste, j'ai fais au plus simple, c'était un test, mais je vais maintenant prendre des mesures pour choisir ce qui passe via le CDN.

thx

ddavid
09/07/2012, 17h02
Citation Envoyé par aurel92
Au final, comme le dit buddy, le site est du coup entièrement accessible via cdn.appsthru.com, ce qui n'est pas désirable car le contenu est dupliqué. Je m'y attendais, c'est un test.
Ce n'est pas parce que le dossier est le même que le contenu est nécessairement "dupliqué" aux yeux des moteurs :
* rien n'empêche d'utiliser toujours la même adresse pour des éléments accessibles via deux FQDNs,
* rien n'oblige à délivrer la même réponse parce que le dossier est le même, au contraire... Le .htaccess permet d'éviter ça, et de faire des redirections à chaque fois que le mauvais FQDN est interrogé...

ddavid
09/07/2012, 16h57
Citation Envoyé par aurel92
PS : ddavid, amha le test que tu fais en modifiant ton fichier host revient à faire le test de http://213.186.33.17/wp-images/RSS.png, ce qui est tj en 404, car on tombe sur le mutualisé, qui lui, ne sait pas quel site tu interroges ...
Absolument pas, le fichier hosts court-circuite l'interrogation du DNS, mais ça ne revient pas à remplacer textuellement le nom d'hôte par l'IP.

Le FQDN reste absent de la ligne "GET", sur cette ligne on trouve uniquement "/wp-images/RSS.png" pour désigner la ressource demandée, mais par contre il y a une ligne d'en-tête "Host" avec le FQDN. Cf les RFCs concernant HTTP/1.1 ou cf l'expérimentation. Bref, c'est comme si un serveur DNS avait été interrogé, les en-têtes du navigateur restent les même...

aurel92
09/07/2012, 09h32
En effet, ça marche et je reviens vers vous pour vous décrire mes actions :

1. Vérifier que l'IP configurée automatiquement à l'inscription au CDN soit bien celle du cluster hébergeant le site ( ds le cas d'un mutu ). Pour ma part, ce n'était pas la bonne.

Puis, dans cet ordre :
2. Configurer un sous domaine, dans la gestion des hébergements, pointant vers le dossier à servir,
3. Modifier l'entrée A, dans les Zones DNS, pour pointer sur l'IP du CDN donnée lors de l'inscription.

Dans cet ordre, car la création d'un sous domaine dans le manager, créé automatiquement ou modifie l'entrée A correspondante.

Au final, comme le dit buddy, le site est du coup entièrement accessible via cdn.appsthru.com, ce qui n'est pas désirable car le contenu est dupliqué. Je m'y attendais, c'est un test.

Merci pour vos conseils !

PS : ddavid, amha le test que tu fais en modifiant ton fichier host revient à faire le test de http://213.186.33.17/wp-images/RSS.png, ce qui est tj en 404, car on tombe sur le mutualisé, qui lui, ne sait pas quel site tu interroges ...

ddavid
07/07/2012, 23h56
Là ça marche en effet, http://cdn.appsthru.com/wp-images/RSS.png délivre bien l'image, même en s'adressant directement à 213.186.33.17.

Je suppose qu'aurel92 va revenir très prochainement vers nous pour nous indiquer les changements ?

buddy
07/07/2012, 23h27
Salut,

çà marche très bien en ce moment ...
http://web-sniffer.net/ indique bien que l'image est distribuée par le CDN.

ddavid
07/07/2012, 21h33
Citation Envoyé par aurel92
L'image suivante est tj en 404 via le CDN.

http://cdn.appsthru.com/wp-images/RSS.png
Origine :
http://appsthru.com/wp-images/RSS.png
Il y a là une erreur de compréhension.

http://cdn.appsthru.com/wp-images/RSS.png doit être à la fois l'adresse sur le serveur d'origine et celle via le CDN. (Le FQDN ne change pas.)

Les visiteurs auront le résultat via le CDN, parce que les DNS leur diront d'aller sur l'IP du CDN. Le CDN trouvera le serveur d'origine parce qu'il utilise son réglage enregistré pour savoir l'IP du serveur d'origine (il ne refait pas de requête DNS).

Mais le serveur d'origine doit répondre correctement lorsqu'il est interrogé pour http://cdn.appsthru.com/wp-images/RSS.png , hors là 213.186.33.17 me renvoie une 404 pour cette adresse (j'ai vérifié en modifiant /etc/hosts avant), erreur 404 qu'il est logique que le CDN répercute...

buddy
07/07/2012, 14h53
tu as bien créer le sous domaine cdn comme expliqué ici ?
http://guide.ovh.com/ManagerServicesHebergement

il faut que tu crées un sous domaine CDN, et que tu lui mettent les images dedans.

Dans ton cas, il y a 2 solutions,
soit tu peux faire pointer cdn vers ton dossier www. ( c'est pas génialissime car du coup ton site sera accessible via 2 sous domaines )
soit tu créés un dossier cdn et tu fais une copie de ton dossier /www/wp-images vers /cdn/wp-images

aurel92
07/07/2012, 12h16
Merci ddavid et buddy pour vos réponses.

J'ai configuré l'IP du CDN, donnée lors de l'inscription, dans une entrée A correspondante au sous domaine cdn.appsthru.com depuis les zones DNS du manager v3 (46.105.198.3) .

Dans le manager CDN, j'ai constaté que l'IP du serveur d'origine configurée automatiquement n'était pas l'IP du cluster hébergeant mon site ( 213.186.33.17 ). Je l'ai donc modifié.

L'image suivante est tj en 404 via le CDN.

http://cdn.appsthru.com/wp-images/RSS.png
Origine :
http://appsthru.com/wp-images/RSS.png

buddy
07/07/2012, 11h38
tu as bien ajouter ton domaine ici : https://cdn.labs.ovh.com/managerv5

et tout régler dans l'onglet configuration? ( il faut que tu indiques dans cette interface l'ip réelle de ton serveur web)

le "manager v5" est en maintenance: http://travaux.ovh.net/?do=details&id=6962 donc essaye plusieurs fois.
Des fois, çà marche et des fois non.

ddavid
07/07/2012, 07h31
Citation Envoyé par aurel92
J'ai lu dans ce forum qu'il faut aussi faire pointer ce sous-domaine vers le répertoire du site, mais il me semble que cela "écrase" la config DNS précédente ?!
Bonjour,

L'IP du CDN doit remplacer l'IP du serveur d'orgine dans le champ A. En cas d'IPv6, il faut vérifier éventuellement (si cela est souhaité), qu'il n'y a pas de champ AAAA persistant pointant vers le serveur d'origine.

Le CDN doit lui être paramétré pour connaître l'IP du serveur d'origine (il devine l'IP à l'installation via les DNS, mais après ça se passe dans la config du CDN sur le manager).

Citation Envoyé par aurel92
Le CDN OVH est-il de type "Origin Pull" ?
Oui, le CDN d'OVH est en mode Pull, pas de push zone prévue à ma connaissance. Il prend les données depuis le serveur d'origine la première fois, puis les conserve en cache après autant que possible (au maximum la durée prévue dans la config du CDN, mais il se peut que le cache soit jeté à la poubelle avant par Varnish, en particulier si ce n'est pas un site très fréquenté).

Les nœuds du CDN ne seraient pas synchronisés directement entre eux (autrement dit, le pull peut avoir lieu plusieurs fois si les demandes émanent de nœuds différents.)

(Sous réserve de bonne compréhension et de non-modifications, le CDN d'OVH, j'ai à peine touché pour l'instant...)

aurel92
06/07/2012, 23h53
Bonjour,
j'ai configuré une entrée A du sous domaine inscrit au CDN avec l'IP que j'ai reçu lors de l'inscription ( 46.105.198.3)

Après plus de 48 heures, les fichiers sont tj en 404, et la racine présente comme un site par défaut ( "choississez votre interface préférée" ).

Je suis sur un mutualisé pro.
J'ai lu dans ce forum qu'il faut aussi faire pointer ce sous-domaine vers le répertoire du site, mais il me semble que cela "écrase" la config DNS précédente ?!

Quelle est mon erreur ?
Le CDN OVH est-il de type "Origin Pull" ?


http://cdn.appsthru.com/
http://cdn.appsthru.com/wp-images/RSS.png
http://appsthru.com/wp-images/RSS.png