OVH Community, votre nouvel espace communautaire.

Problème d'envoie de mails


falco3
26/02/2013, 16h01
Bonjour,

J'ai exactement le même problème que celui mentionné dans le premier message. Mes mails sont hébergés par Google Apps et les MX de mon domaine pointent vers les DNS Google.
Du coup, les envoies et récéptions de mails se passent très bien sauf quand ceux-ci partent du serveur sur lequel est configuré le domaine ; et je suppose que c'est parce que Qmail essaye de les envoyer en local alors qu'il faudrait les "laisser partir" chez Google.

J'ai essayé de vider mes deux fichiers /var/qmail/control/rcpthosts et /var/qmail/control/virtualdomains puis de redémarrer Qmail, mais visiblement ça n'a rien changé...

A noter, mon serveur est sous CentOS 6 et je l'administre avec Plesk 11 (en plus du SSH).

D'avance merci !

Julien

xavd2a
18/06/2012, 11h38
Merci fritz2cat et aussi insi,

effectivement mon serveur traitait les mailbox comme étant locales.
J'ai donc modifié les fichiers "rcpthosts" et "virtualdomains" (dans /var/qmail/control/) de sorte de ne plus avoir de référence au domaine dont le service mails est hébergé chez Google.

J'ai redémarré qmail et le problème est résolu, un grand merci au participants de cette discussion.

Xavier.

fritz2cat
18/06/2012, 11h15
Vois par ici: http://www.lifewithqmail.org/lwq.htm...iple-hostnames

il est quasiment certain que ton serveur croie que tes mailbox sont hébergées en local, alors qu'il faut envoyer les mails à Google.

Frédéric

xavd2a
18/06/2012, 10h24
La résolution DNS semble ok, voici les résultats observés des commandes suivantes :

# dig www.domain.tld.
; <<>> DiG 9.8.1-P1 <<>> www.domain.tld.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59516
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 3

;; QUESTION SECTION:
;www.domain.tld. IN A

;; ANSWER SECTION:
www.domain.tld. 86400 IN CNAME domain.tld.
domain.tld. 86400 IN A aaa.bbb.ccc.ddd

;; AUTHORITY SECTION:
domain.tld. 100786 IN NS nsXX.ovh.net.
domain.tld. 100786 IN NS dnsXX.ovh.net.

;; ADDITIONAL SECTION:
nsXX.ovh.net. 36007 IN A 213.251.ccc.ddd
dnsXX.ovh.net. 36007 IN A 213.251.ccc.ddd
dnsXX.ovh.net. 41423 IN AAAA 2001:41d0:xxxx:xxxx::1

;; Query time: 7 msec
;; SERVER: 213.186.ccc.ddd#53(213.186.ccc.ddd)
;; WHEN: Mon Jun 18 10:14:19 2012
;; MSG SIZE rcvd: 172

# dig MX domain.tld.
; <<>> DiG 9.8.1-P1 <<>> MX domain.tld.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 49717
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 2, ADDITIONAL: 8

;; QUESTION SECTION:
;domain.tld. IN MX

;; ANSWER SECTION:
domain.tld. 85856 IN MX 10 aspmx3.googlemail.com.
domain.tld. 85856 IN MX 1 aspmx.l.google.com.
domain.tld. 85856 IN MX 5 alt1.aspmx.l.google.com.
domain.tld. 85856 IN MX 5 alt2.aspmx.l.google.com.
domain.tld. 85856 IN MX 10 aspmx2.googlemail.com.

;; AUTHORITY SECTION:
domain.tld. 100448 IN NS nsXX.ovh.net.
domain.tld. 100448 IN NS dnsXX.ovh.net.

;; ADDITIONAL SECTION:
aspmx.l.google.com. 181 IN A 173.194.70.26
alt1.aspmx.l.google.com. 221 IN A 173.194.71.26
alt2.aspmx.l.google.com. 78 IN A 74.125.127.27
aspmx2.googlemail.com. 2333 IN A 173.194.69.27
aspmx3.googlemail.com. 2333 IN A 74.125.127.27
nsXX.ovh.net. 35669 IN A 213.251.ccc.ddd
dnsXX.ovh.net. 35669 IN A 213.251.ccc.ddd
dnsXX.ovh.net. 41085 IN AAAA 2001:41d0:xxxx:xxxx::1

;; Query time: 1 msec
;; SERVER: 213.186.ccc.ddd#53(213.186.ccc.ddd)
;; WHEN: Mon Jun 18 10:19:57 2012
;; MSG SIZE rcvd: 348

gaboul49
16/06/2012, 07h39
Tu peux utiliser l'utilitaire dig pour résoudre ton domaine et voir ce que voit ton VPS au niveau DNS.

insy
15/06/2012, 20h28
Bonsoir,

La meilleure solution (ou la plus simple) serait d'envoyer l'ensemble de tes emails via SMTP.
Cet article devrait pouvoir t'aider: https://support.ikoula.com/index-1-2...r-de-mail.html si tu souhaite continuer à utiliser qmail (yerk).

xavd2a
15/06/2012, 19h15
Bonjour,

mon site envoie des emails avec la fonction php mail().
Les mails (notifications, formulaire de contact, etc...) sont correctement envoyés si l'adresse email n'appartient pas au domaine hébergé sur mon VPS.

Je suis en release 2, j'ai configuré l'adressage DNS dans le manager pour utiliser les DNS d'OVH (dnsXX.ovh.net et nsXX.ovh.net) et non celui de mon VPS, j'ai donc arreter Bind sur mon VPS.

De plus je n'utilise pas le service mail d'OVH ou de mon VPS, car historiquement les mails sont gérés dans Google Apps pour ce domaine. Donc toujours dans le manager OVH les zones DNS MX pointent vers les serveurs de Google.

Ma zone DNS ressemble à ca :
.domain.tld NS dnsXX.ovh.net
.domain.tld NS nsXX.ovh.net
.domain.tld MX 5 alt1.aspmx.l.google.com
.domain.tld MX 5 alt2.aspmx.l.google.com
.domain.tld MX 10 aspmx2.googlemail.com
.domain.tld MX 1 aspmx.l.google.com
.domain.tld MX 10 aspmx3.googlemail.com
.domain.tld A aaa.bbb.ccc.ddd (ip de mon VPS biensur)

Je confirme que l'envoie de mails vers des adresses en dehors de mon domaine fonctionne correctement.

J'ai fait le test avec / sans iptables : sans succès
J'ai fait le test avec / sans Bind sur mon VPS (avec les MX mis sur les serveur de Google comme ci dessus) : sans succès.

Les logs /var/log/mail.err sont vides, /var/log/httpd/domain_error_log n'indiquent rien de probant.
Au niveau des log qmail, dans le fichier /var/log/qmail/current, j'observe les erreurs suivantes :
@400000004fdb52ca37cc243c new msg 819688
@400000004fdb52ca37cc243c info msg 819688: bytes 20726 from qp 24839 uid 1001
@400000004fdb52ca3855322c starting delivery 16: msg 819688 to local domain.tld-serviceclients@domain.tld
@400000004fdb52ca38553614 status: local 1/10 remote 0/20
@400000004fdb52ca38888e9c delivery 16: failure: Sorry,_no_mailbox_here_by_that_name._(#5.1.1)/
@400000004fdb52ca3888966c status: local 0/10 remote 0/20
@400000004fdb52ca39a6992c bounce msg 819688 qp 24843
@400000004fdb52ca39a69d14 end msg 819688

Donc effectivement si il essaye d'écrire à domain.tld-serviceclients@domain.tld
au lieu de serviceclients@domain.tld je comprend que cela ne fonctionne pas.

Mais pourquoi l'adresse du destinataire est elle "transformée" ainsi ??? Mystère.

Je précise que j'ai migré sur mon VPS il y un un peu plus de 24h mais pas encore 48h. Est ce que je pourrais être encore dans les délais de propagation ? Sachant que les entrées MX n'ont pas bougées.

Voila en finale je sèche, moi qui pensait mériter mon WE.

Merci de m'avoir lu, et de partager vos suggestions.

Cordialement,
Xavier.