OVH Community, votre nouvel espace communautaire.

Forum Fluxbb et smtp


Nowwhat
14/08/2013, 07h35
Re.

J'ai installé Fluxbb sur un des mes Mutus (serveur mail: ns0.ovh.net)
Le paramétrage 'mail' est commun, pas de soucis de ce coté là.

J'ai testé l'inscription d'un nouveau membre du forum - mail avec message bien reçu.
J'ai posté quelques messages - en tant que admin - chaque fois un nouveau sujet.
J'ai posté quelques messages - en tant que nouveau membre - chaque fois un nouveau
sujet et j'ai répondu sur les messages posté par l'admin
Pour l'admin, pareil, j'ai répondu sur toutes les messages de ce nouveau membre.

Je pense que j'ai trouvé pourquoi moi j'ai reçu ces notifications:

Code:
admin has replied to the topic 'Hi' to which you are subscribed. There May be more new replies, but this is the only notification you will receive until you visit the board again.

The post is located at http://www.MONSITE.fr/fluxbb/viewtopic.php?pid=3#p3

You can unsubscribe by going to
http://www.MONSITE.fr/fluxbb/misc.php?action=unsubscribe&tid=2

--
My FluxBB Forum Mailer
(Do not reply to this message)
T'as vu le "to which you are subscribed" ? Il faut s'inscrire pour chaque thread que tu souhaite suivre.
J'ai coché pour chaque thread le mot 'subscribe' en bas - à droite
Par défaut, le suivi par mail n'est pas activé.
Depuis, j'ai ces notifications.


PS: reste loin de ce paramétrage 'SSL' - quand tu coche ça, sans autre modifs, ça ne marche plus ... (a lire: http://guides.ovh.net/ConfigurationEmail)

Edit: sympa, ce petit forum.

gboc
13/08/2013, 21h17
Merci de ta réponse

"pas OK" = je crée un message sur le forum, un message de confirmation s'affiche, le mail d'alerte devrait alors partir à ce moment là, d'après le paramétrage que j'ai renseigné par ailleurs, mais personne ne reçoit rien...

Je vais essayer de cocher "chiffrage du smtp par SSL"

Nowwhat
13/08/2013, 21h01
Ça me prouve que ces deux sources de mails utilisent pas le même paramétrage.

Je ne connais pas "fluxbb".
Je sais que "ns0.ovh.net" fonctionne correctement quand tu lui parle "correctement".
"pas OK..." est très peu d'info pour comprendre ce qui ce passe.

gboc
13/08/2013, 19h47
Ah, sauf qu'apparemment, les utilisateurs du forum ne reçoivent pas tous les mails :
- mails envoyés directement à un utilisateur depuis l'administration : OK
- mails envoyés automatiquement par le site en cas de nouveau sujet, par exemple : pas OK...

gboc
13/08/2013, 19h29
MERCI BEAUCOUP !!!
Ça fonctionne !

Nowwhat
13/08/2013, 19h16
Citation Envoyé par gboc
....
Une idée ?
Oui.
Au lieu d'utiliser 'news' comme "Nom d'utilsateur SMTP" utilise news@#####.fr (comme tu mentionne plus haut).
(car le login par submission (=587) est la même que le login pour POP)

Décoche pour l'instant "Chiffrage du SMTP par SSL".

Check (par ping) que smtp.#####.fr possède le même IP que "ns0.ovh.net".

Source: http://guide.ovh.com/ConfigurationEmail

gboc
13/08/2013, 19h07
Hello,

J'ai moi aussi des problèmes pour configurer l'envoi de mails depuis mon forum fluxbb hébergé chez OVH.

J'ai saisi ces paramètres : http://bit.ly/13hMfS7

Mais quand j'essaie d'envoyer un mail à un utilisateur, j'obtiens le message :
"Error: Could not connect to smtp host "smtp.chry.fr:587" (115) (Operation now in progress)"
Aucun mail n'arrive.

Le support OVH m'indique que mes paramètres sont corrects.
Ils m'ont conseillé d'essayer le script d'envoi sur cette page : http://forum.ovh.com/showthread.php?t=31770
Le script fonctionne bien.

Une idée ?

A-snowboard
13/05/2012, 13h11
Merci pour toutes tes informations.


En fait j'ai réussi a régler le problème, dans les options de fluxbb il ne fallait pas remettre les identifiant et autre en ce qui concerne les paramètres smtp !

fritz2cat
13/05/2012, 09h27
Peu importe le logiciel de forum. Les règles d'envois de mail chez OVH sont peu claires, mais en cherchant un peu on finit par trouver.

Il faut utiliser les fonctions standards de ton hébergement c'est à dire la fonction mail() de PHP ou /usr/lib/sendmail
Cette fonction d'envoi de mail ne requiert pas d'authentification lors de l'envoi des mails.
Cependant en cas d'envoi un grand nombre de messages ceux-ci seront mis en queue et distillés à raison d'un par seconde ou même deux à trois secondes.

S'il s'avère que c'est une campagne de spam (parce que client indélicat ou site hacké), le temps qu'OVH intervienne il y aura quelques milliers de messages émis et non des centaines de milliers ...

En outre un fusible bloque immédiatement l'envoi des messages s'il y a trop de retours-erreurs. Ces retours reviennent toujours via une page dans le manager: hébergement web > suivi des e-mails automatisés.

Maintenant si tu as un fournisseur d'envoi par SMTP rien ne t'empêche d'y faire appel via un port autre que 25.

Dans le cas particulier où tu utilises le SMTP d'OVH (ssl0.ovh.net/ns0.ovh.net) qui est là pour accepter tes envois normalement en provenance d'Outlook/Thunderbird/... sache qu'il faut envoyer ton login/pass à chaque message envoyé, et qu'il y a des restrictions (max 100 destinataires x messages par heure), n'oublie pas d'employer un port autre que 25. Vois les http://guides.ovh.net pour les détails.

Frédéric

A-snowboard
13/05/2012, 08h06
Désolé du retard mais je n'avais plus internet.

Merci pour vos réponses.

bon j'ai rentré de nouveau les données, j'ai ça comme erreur :

Unable to send email. Please contact the forum administrator with the following error message reported by the SMTP server: "555 sorry, invalid MAIL FROM for open-smtp session (http://travaux.ovh.com/?do=details&id=2602) ".
Mais bon, je pense que je vais me tourner vers fluxbb.

fritz2cat
05/05/2012, 21h09
On n'envoie jamais sur le port 110 ni sur le port 993.
Ces ports sont pour la réception de mails en POP3 et POP3/ssl
Essaie plutôt le port 5025 qui est spécifique à OVH ou un des autres ports documentés dans guides.ovh.com
Le port 25 est à éviter car il est (plus ou moins) bloqué.

Vis-à-vis du serveur ssl0.ovh.net, n'oublie pas que:
- tu dois authentifier ta session (login/mdp)
- il y a des quotas à respecter (100 messages par heure aux dernières nouvelles)

Frédéric

Nowwhat
03/05/2012, 23h12
'Soir,

Le doc: http://guides.ovh.com/ConfigLogicielMessagerie
Le "ssl0.ovh.net" travaille pas sur la porte "110" (la porte POP) mais sur "993".

A-snowboard
03/05/2012, 22h09
Bonjour tout le monde,

j'essaye a partir de mon forum et d'une mod installé dessus de faire un envoie de mail groupé.
La mod est opérationnel car d'autres l'ont installé sur leur forum et ne rencontrent pas de souci.

Quand je fait envoyer mon groupe de mail (a 2personnes pour tester), après un long temps de chargement j'ai droit a une erreur de type :

Error: Could not connect to smtp host "ssl0.ovh.net" (110) (Connection timed out).
Concrètement que cela signifie-t-il ?