OVH Community, votre nouvel espace communautaire.

les email de mon dédié partent bien vers l'exterieur..mais pas en local


BakaLeGuM
14/04/2012, 19h45
Bon verdict, ca fonctionne. la solution : configurer le serveur web avec postfix (sendmail c'est trop chaint) en smarthost et en indiquant l'ip local du serveur mail.

faut faire gaffe dans la configuration des nom de domaine accepté, sinon c'est le serveur web qui va essayer de distribuer certain mail par lui meme... et ca marche pas vraiment

merci encore freemaster.

BakaLeGuM
14/04/2012, 18h10
bon...
freemaster désolé d'avoir mis en doute ton idée car ca semble fonctionner. je tente de corriger mon serveur en prod et ca devrait fonctionner

BakaLeGuM
14/04/2012, 17h52
alors en installant postfix sur une VM eant sr 10.0.0.16:


Code:
Apr 14 20:44:38 web2 postfix/pickup[349]: E6984198410E: uid=0 from=
Apr 14 20:44:38 web2 postfix/cleanup[542]: E6984198410E: message-id=<20120414164438.E6984198410E@web2.ovh.net>
Apr 14 20:44:38 web2 postfix/qmgr[350]: E6984198410E: from=, size=323, nrcpt=1 (queue active)
Apr 14 20:44:40 web2 postfix/smtp[544]: connect to mail.legum.fr[91.121.149.194]:25: Connection refused
Apr 14 20:44:40 web2 postfix/smtp[544]: E6984198410E: to=, relay=none, delay=1.2, delays=0.07/0.01/1.1/0, dsn=4.4.1, status=deferred (connect to mail.legum.fr[91.121.149.194]:25: Connection refused)
meme symptome.


edit : houla y'a du mouvement, un de mes essais de mail est passé! je sais pas quand ni comment. je reprends courage

BakaLeGuM
14/04/2012, 16h31
hummm...

ce que tu me dis me semble etrange:

sendmail sur 10.0.0.10 est pleinement fonctionnel, il se fait juste dégager par 10.0.0.13 quand il essaye de lui envoyer un message. donc pur moi le soucis viendrait de la config de postfix sur 10.0.0.13 Mon sendmail arrive a envoyer des mails a gmail, hotmail, yopmail, pour moi il n'est pas en cause. qu'en dis tu?

Je vais quand meme me renseigner sur cette histoire de smarthost, et essayer avec postfix si vriament ca peut arranger les choses.

edit : bon l'interet des VM c 'est qu on peut les dupliquer poru les bidouilles... je vais donc prendre une installe vierge et tester avec postfix.

Freemaster
14/04/2012, 15h49
et ben voilà
sendmail c'est chiant à configurer, car il faut le recompiler à chaque changement de config... à moins que cela ai changé ces dernières années...

le mieux c'est d'utiliser également postfix
c'est simple, lorsque tu l'installes, tu choisi la méthode smarthost en indiquant donc l'ip 10.0.0.13, et rien d'autre à configurer

BakaLeGuM
14/04/2012, 12h23
sur 10.0.0.10 c'est sendmail qui est installé.. et j'ai rien configuré du tout (et en fait il fonctionne tres bien, sauf pour envoyer les mails vers mes ndd)

Freemaster
14/04/2012, 12h13
sur le 10.0.0.10 aurais-tu mis un postfix avec relay smarthost mail.ndd.fr ?

remplace le relayhost = mail.ndd.fr par relayhost = 10.0.0.13

BakaLeGuM
14/04/2012, 12h01
j'ai fait la modif.. mais ca change rien.

C'est quoi la commande a "ne jamais utiliser" qui transforme ton serveur en OPEN RELAY? pour voir si au moins comme ca ca fonctionne?

Freemaster
14/04/2012, 11h30
10.0.0.0/22 remplace par 10.0.0.0/24

postfix reload et retest

BakaLeGuM
14/04/2012, 10h38
Merci Freemaster

il me semble que c'est bien le cas.voici mon main.cf :
Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
delay_warning_time = 1h

alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
relayhost =
recipient_delimiter = +



inet_interfaces = all
myorigin = /etc/mailname
mydestination = mail.monNDD.fr, localhost.monNDD.fr, localhost
mynetworks = 10.0.0.0/22 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myhostname = mail.monNDD.fr

mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
inet_protocols = ipv4

virtual_uid_maps = static:3000
virtual_gid_maps = static:3000
virtual_mailbox_base = /home/facteur

virtual_transport = dovecot

virtual_mailbox_domains = mysql:/etc/postfix/mysql_virtual_mailbox_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql_virtual_mailbox_maps.cf
virtual_alias_maps = mysql:/etc/postfix/mysql_virtual_alias_maps.cf
relay_domains = mysql:/etc/postfix/mysql_relay_domains.cf

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous

dovecot_destination_recipient_limit = 1

content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
smtpd_sasl_local_domain =
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

je suis en train de faire des essais de config, tu vois une erreur?

Freemaster
14/04/2012, 09h10
sur ta config de postfix (main.cf), tu as bien rajouté ton réseau ?

mynetworks = 10.0.0.0/24

BakaLeGuM
13/04/2012, 23h20
je me fais un petit up, en rajoutant quelques autres test

ca n'apporte pas grand chose cependant.
toujours depuis mon serveur web
Code:
root@web:~# sendmail -v monnom@gmail.com < /dev/null
monnom@gmail.com... Connecting to [127.0.0.1] via relay...
220 web.ovh.net ESMTP Sendmail 8.14.3/8.14.3/Debian-9.1ubuntu1; Sat, 14 Apr 2012 00:14:13 +0200; (No UCE/UBE) logging access from: localhost.localdomain(OK)-localhost.localdomain [127.0.0.1]
>>> EHLO web.ovh.net
250-web.ovh.net Hello localhost.localdomain [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5
250-DELIVERBY
250 HELP
>>> VERB
250 2.0.0 Verbose mode
>>> MAIL From: AUTH=root@web.ovh.net
250 2.1.0 ... Sender ok
>>> RCPT To:
>>> DATA
250 2.1.5 ... Recipient ok
354 Enter mail, end with "." on a line by itself
>>> .
050 ... Connecting to gmail-smtp-in.l.google.com. via esmtp...
050 220 mx.google.com ESMTP c1si4257440wiz.3
050 >>> EHLO web.ovh.net
050 250-mx.google.com at your service, [xx.xxx.xxx.xxx]
050 250-SIZE 35882577
050 250-8BITMIME
050 250-STARTTLS
050 250-ENHANCEDSTATUSCODES
050 250 PIPELINING
050 >>> STARTTLS
050 220 2.0.0 Ready to start TLS
050 >>> EHLO web.ovh.net
050 250-mx.google.com at your service, [xx.xxx.xxx.xxx]
050 250-SIZE 35882577
050 250-8BITMIME
050 250-ENHANCEDSTATUSCODES
050 250 PIPELINING
050 >>> MAIL From: SIZE=270
050 250 2.1.0 OK c1si4257440wiz.3
050 >>> RCPT To:
050 >>> DATA
050 250 2.1.5 OK c1si4257440wiz.3
050 354  Go ahead c1si4257440wiz.3
050 >>> .
050 250 2.0.0 OK 1334355254 c1si4257440wiz.3
050 ... Sent (OK 1334355254 c1si4257440wiz.3)
250 2.0.0 q3DMEDAU006263 Message accepted for delivery
monnom@gmail.com... Sent (q3DMEDAU006263 Message accepted for delivery)
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 web.ovh.net closing connection
Code:
root@web:~# sendmail -v monnom@monNDD.fr < /dev/null
monnom@monNDD.fr... Connecting to [127.0.0.1] via relay...
220 web.ovh.net ESMTP Sendmail 8.14.3/8.14.3/Debian-9.1ubuntu1; Sat, 14 Apr 2012 00:16:44 +0200; (No UCE/UBE) logging access from: localhost.localdomain(OK)-localhost.localdomain [127.0.0.1]
>>> EHLO web.ovh.net
250-web.ovh.net Hello localhost.localdomain [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5
250-DELIVERBY
250 HELP
>>> VERB
250 2.0.0 Verbose mode
>>> MAIL From: AUTH=root@web.ovh.net
250 2.1.0 ... Sender ok
>>> RCPT To:
>>> DATA
250 2.1.5 ... Recipient ok
354 Enter mail, end with "." on a line by itself
>>> .
050 ... Connecting to mail.monNDD.fr. via esmtp...
050 ... Deferred: Connection refused by mail.monNDD.fr.
250 2.0.0 q3DMGir1007154 Message accepted for delivery
monnom@monNDD.fr... Sent (q3DMGir1007154 Message accepted for delivery)
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 web.ovh.net closing connection

BakaLeGuM
13/04/2012, 14h17
Bonjour a tous,

petit casse tete avec mes envois de mails.
sur mon site web (blog wordpress) si je m'inscrit avec une adresse du type monnom@gmail.com je recois bien le mail et tout fonctionne.
Par contre si j'utilise comme mail monnom@monNDD.fr le mail ne part pas!
(et ça fait la même chose pour tous mes ndd)
(généralement on rencontre ce soucis dans l'autre sens,donc je suis paumé).

au niveau technique, je suis sous proxmox avec 2 VM la première sur 10.0.0.10 qui gère le web et la seconde 10.0.0.13 qui gere les mail.(dovecot et postfix)

tout se passe comme si 10.0.0.13 n'acceptait pas les mails envoyés par 10.0.0.10.

J'ai d'ailleurs fais des tests en ligne de commande sur 10.0.0.10 logué en root je peux envoyer des mails a qui je veux (gmail, hotmail, yopmail) SAUF sur les ndd que gère 10.0.0.13.

je vous met ici les log de 4 tests que j'ai fait (en tant que root sur 10.0.0.10):



Code:
echo "xfrom root to yop" | mail -s xbidouille314@yopmail.com
-> tout fonctionne



Code:
Apr 13 15:05:19 web sendmail[3211]: q3DD5J2f003211: from=root, size=18, class=0, nrcpts=1, msgid=<201204131305.q3DD5J2f003211@web.ovh.net>, relay=root@localhost
Apr 13 15:05:19 web sm-mta[3212]: q3DD5JkN003212: from=, size=294, class=0, nrcpts=1, msgid=<201204131305.q3DD5J2f003211@web.ovh.net>, proto=ESMTP, daemon=MTA-v4, relay=localhost.localdomain [127.0.0.1]
Apr 13 15:05:19 web sendmail[3211]: q3DD5J2f003211: to=xbidouille314@yopmail.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30018, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q3DD5JkN003212 Message accepted for delivery)


Code:
echo "xfrom root to gmail" | mail -s monnom@gmail.com
-> tout fonctionne

Code:
Apr 13 15:05:19 web sendmail[3216]: q3DD5JpK003216: from=root, size=20, class=0, nrcpts=1, msgid=<201204131305.q3DD5JpK003216@web.ovh.net>, relay=root@localhost
Apr 13 15:05:19 web sm-mta[3217]: q3DD5J9x003217: from=, size=290, class=0, nrcpts=1, msgid=<201204131305.q3DD5JpK003216@web.ovh.net>, proto=ESMTP, daemon=MTA-v4, relay=localhost.localdomain [127.0.0.1]
Apr 13 15:05:19 web sendmail[3216]: q3DD5JpK003216: to=monom@gmail.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30020, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q3DD5J9x003217 Message accepted for delivery)


Code:
echo "xfrom root to monNDD" | mail -s xbidouille314@monNDD.fr
Code:
Apr 13 15:05:19 web sendmail[3221]: q3DD5JXD003221: from=root, size=20, class=0, nrcpts=1, msgid=<201204131305.q3DD5JXD003221@web.ovh.net>, relay=root@localhost
Apr 13 15:05:19 web sm-mta[3222]: q3DD5JBY003222: from=, size=293, class=0, nrcpts=1, msgid=<201204131305.q3DD5JXD003221@web.ovh.net>, proto=ESMTP, daemon=MTA-v4, relay=localhost.localdomain [127.0.0.1]
Apr 13 15:05:19 web sm-mta[3219]: STARTTLS=client, relay=gmail-smtp-in.l.google.com., version=TLSv1/SSLv3, verify=FAIL, cipher=RC4-SHA, bits=128/128
Apr 13 15:05:19 web sendmail[3221]: q3DD5JXD003221: to=xbidouille314@monNDD.fr, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30020, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q3DD5JBY003222 Message accepted for delivery)


Apr 13 15:05:19 web sm-mta[3224]: q3DD5JBY003222: to=, ctladdr= (0/0), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120293, relay=mail.monNDD.fr. [xx.xxx.xxx.xxx], dsn=4.0.0, stat=Deferred: Connection refused by mail.monNDD.fr.
-> la par contre ca bloque a la fin "connection refused by ..." et ca fait la meme chose avec tous mes NDD




une petite idée?

merci beaucoup


Edit: si je fais les même tests directement depuis 10.0.0.13 (mon serveur mail) tous les mails partent et arrivent