OVH Community, votre nouvel espace communautaire.

Créer une base de données avec Plesk


kevin76110
02/03/2012, 10h49
Edit :

Cela fonctionne MAIS:

Nouveau message d'erreur:

Code:
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'admin'@'stm59-3-78-248-12-9.fbx.proxad.net' (using password: YES) in /opt/lampp/htdocs/test/index.php on line 17
Erreur : Access denied for user 'admin'@'stm59-3-78-248-12-9.fbx.proxad.net' (using password: YES)
Je pense que je vais repartir de zéro, refaire quelque chose de propre, une nouvelle base de données...

kevin76110
02/03/2012, 10h26
J'avais déjà vu cette solution.
C'est normal que je ne puisse accéder à ce fichier qu'en SSH et pas via FTP ?


Voici le fichier en question ( /etc/mysql/my.cnf ) :

Code:
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
local-infile=0
#
# * Basic Settings
#

#
# * IMPORTANT
#   If you make changes to these settings and your system uses apparmor, you may
#   also need to also adjust /etc/apparmor.d/usr.sbin.mysqld.
#

user            = mysql
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
# bind-address          = 127.0.0.0
#
# * Fine Tuning
#

key_buffer              = 16M
max_allowed_packet      = 16M
thread_stack            = 192K
thread_cache_size       = 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover         = BACKUP
#max_connections        = 100
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
# As of 5.1 you can enable the log at runtime!
#general_log_file        = /var/log/mysql/mysql.log
#general_log             = 1

log_error                = /var/log/mysql/error.log

# Here you can see queries with especially long duration
#log_slow_queries       = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id              = 1
#log_bin                        = /var/log/mysql/mysql-bin.log
expire_logs_days        = 10
max_binlog_size         = 100M
#binlog_do_db           = include_database_name
#binlog_ignore_db       = include_database_name
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#

[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer              = 16M

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/
Les lignes sont bien commentées.
Par ailleurs, dans le parefeu, j'ai autorisé l'accès au port 3306.

Pourtant, toujours aucun accès extérieur à la base.
Ce qui est très embêtant.

Surtout qu'il n'y a pas trop d'aide dans les tutos OVH, et que je débute un peu là-dedans ...

Merci.

K.

Nowwhat
02/03/2012, 07h44
Salut,

Plesk ?

Tu trouvera le 'pourquoi' dans /etc/mysql/my.cnf
Dès que tu trouve les mots "bind-address" et "skip-networking" tu sera près du but

kevin76110
01/03/2012, 17h05
Bonjour,

J'ai loué un serveur chez OVH, un VPS.
J'utilise Parallels Plesk pour l'admin serveur.
Or, je n'arrive pas à créer une simple base de données.
En effet, le serveur n'est destiné qu'à une entreprise, sans revente, sans client etc.
Lorsque je créé une base, je ne peux pas y accéder de l'extérieur, ce qui est embêtant.
J'ai ceci comme message d'erreur dans le php :


Warning: mysql_connect() [function.mysql-connect]: [2002] Connexion refusée (trying to connect via tcp://vpsXXXXX.ovh.net:3306) in /opt/lampp/htdocs/test/index.php on line 17

Le port 3306 est bien ouvert dans le parefeu.
Mon code est bon, c'est certain.
Mais rien ne se fait.

Quelqu'un peut voir d'où vient le soucis ?

Merci d'avance.


K.