OVH Community, votre nouvel espace communautaire.

Problème réception mail


Pascal47
29/02/2012, 08h27
Salut,
Aucun de mes domaines ne fait référence au Kimsufi.
Les DNS sont gérés par OVH et ont tous ns.ovh.net, dns.ovh.net ou ns13.ovh.net, dns13.ovh.net
Seul la partie WEB pour le site Internet de chacun des domaines est utilisé.
Les mails associés a chacun des domaines sont gérés par mon serveur Exchange.
Donc, si BIND n'est pas nécessaire et qu'en plus cela règle mon problème de bouclage d'adresse mail, alors le problème est réglé.
Merci.
Cdlt,
Pascal

fritz2cat
28/02/2012, 22h53
Si ton kimsufi n'a comme unique fonction que d'être serveur web, les seules requêtes DNS qu'il doit faire c'est pour mentionner les noms au lieu des IP dans les fichiers log de Apache.

Dans ce cas, tu peux sans problème mettre 213.186.33.99 dans /etc/resolv.conf et ne pas avoir de serveur Bind.

Par contre, si un seul de tes domaines fait référence à ton kimsufi pour ses DNS authoritatifs, alors, oui, ton serveur Bind doit tourner.

Frédéric

Pascal47
28/02/2012, 22h15
Bsr,
OK pour retirer la loopback sur /etc/resolv.conf => C'est fait
Mais pour déconfigurer la zone cci47.fr ?
Je déconfigure ou ? comment ?
Merci
Cdlt,
Pascal

PS: Question subsidiaire:
La manip que j'ai fait pour un domaine doit-elle être faite pour tous les domaines ?
J'en ai une tripotée...
@+++

fritz2cat
28/02/2012, 21h52
Aucun risque.

Les serveurs DNS de ton domaine sont: ns.ovh.net. et dns.ovh.net.

Cependant il faudrait envisager maintenant de:
- soit déconfigurer la zone cci47.fr sur celui-ci afin qu'il ne serve plus que de cache DNS pour ton serveur lui-même
- ou bien veiller à retirer 127.0.0.1 du fichier /etc/resolv.conf

Frédéric

Pascal47
28/02/2012, 21h44
Bonsoir,
Suite des évènements:
J'ai commenté dans ces fichiers, les lignes pointants vers mon domaine
/var/qmail/control/rcpthosts
/var/qmail/control/virtualdomains
/var/qmail/users/assign

J'ai renommé le dossier "cci47.fr" dans /home/vpopmail/domains/
J'ai arrêté et redemarré qmail, ça ne marchait toujours pas et j'avais une erreur bizarre
dans les log qmail du genre:
delivery 2: failure: Sorry._Although_I'm_listed_as_a_best-preference_MX_or_A_for_that_host,/it_isn't_in_my_control/locals_file,_so_I_don't_treat_it_as_local._(#5.4.6 )/

J'ai arrêter BIND et ça fonctionne.
Maintenant, même si tout semble fonctionner correctement, je me demande quel est le risque d'avoir arrêter BIND.

Pascal47
27/02/2012, 17h05
Salut,
Mon serveur chez ovh s'appelle ks35720.kimsufi.com
Le domaine concerné est cci47.fr
Mon serveur mail est mailhost.cci47.fr (c'est mon exchange)

En ce qui concerne qmail, je ne connais pas non plus, il est installé par défaut dans la config du kimsufi.

Cdlt,
Pascal

fritz2cat
26/02/2012, 20h45
Je ne connais pas du tout qmail et je ne peux t'aider de ce côté-là.

Il semble que ton problème est un grand classique.

Quel est le nom de machine de ton serveur web ?
Quand tu as initialisé ton serveur Kimsufi, tu as probablement mis dans OVHm ou cPanel ou ... que le nom de ta machine est précisément le nom du domaine vers lequel tu ne peux pas envoyer du mail.

C'est logique. Le serveur pense que les mails adressés à n-importe-qui@tondomaine.com doivent être traités en local, puisque tondomaine.com c'est le serveur lui-même.

Il vaudrait donc mieux que ton serveur s'appelle webserver.tondomaine.com et certainement pas tondomaine.com.

Il n'y a pas que du côté du 'hostname' qu'il faut chercher. Mais aussi dans la config de qmail.
Pour comparaison dans le logiciel Postfix c'est "mydomains="

Frédéric

Pascal47
26/02/2012, 14h55
Suite des évènements:
Bon, ça ne marche toujours pas...
J'ai regardé les logs de qmail, et je remarque une erreur surprenante, il est inscrit qu'aucune boite aux lettres n'existe pour le compte vers lequel je veux envoyer le mail.
Les boites aux lettres ne sont pas chez OVH mais sur mon serveur Exchange.
Je pense que le pb vient de là.
Mais comment le résoudre ?
Si qqun a une solution.
Merci
Cdlt,
Pascal

Pascal47
25/02/2012, 21h16
Suite des évènements:

J'ai déclaré mon mailhost en type A avec mon IP public dans les DNS OVH
J'ai redirigé le MX vers le mailhost
Pb identique... les mails sont bien reçus sur les adresses qui n 'appartiennent pas à mon domaine, mais pas sur celles de mon domaine.
Même en supprimant les relai smtp d'orange, le pb persiste...
Alors est-ce que si je tente d'envoyer un mail avec une adresse de mon domaine depuis le serveur mail d'OVH bloquerai sur mon serveur Exchange...
du style le mail ne peux pas venir d'un autre serveur que celui qui possède les adresses...
Mais comment résoudre cette problématique ?
Galère....galère
@+++
Pascal

Pascal47
25/02/2012, 11h24
Bonjour,
Mes sites sont sur le kimsufi
J'ai tenté hier soir de modifier le fichier qmail et y ai ajouté le port 587
car je suis persuadé que mon relai bloque le port 25.

*J'ai ajouté ceci dans /etc/initd/qmail

ebegin "Starting Smtp587"
env - PATH="/var/qmail/bin:/usr/local/bin" CHKUSER_START="DOMAIN" \
tcpserver -H -R -x /etc/tcp.smtp.cdb -c100 -u508 -g503 0 587 \
/var/qmail/bin/qmail-smtpd 2>&1 \
| /usr/local/bin/tai64n \
| /usr/local/bin/setuidgid qmaill /usr/local/bin/multilog /var/log/qmailsmtp587/ &
eend $?

J'ai redemarré les services, mais à fortiori, rien n'y fait.
Peut être en déclarant les MX chez OVH directement sur l'IP Public de mon Exchange...
Je vais tenter le coup.
Merci
Cdlt,
Pascal

fritz2cat
25/02/2012, 08h42
Le serveur Exchange est nouveau dans la discussion.

Tu peux très bien le configurer pour accepter des mails avec authentification, utilise plutôt le port submission (587) que SMTP (25).

Configurer phpmailer mour utiliser ton Exchange.

Remarque: les problèmes entre OVH et Orange, c'est principalement le mutualisé et les sites à gros trafic qui en souffrent. Ce n'est pas clair à la lecture de tes messages précédents si ton site est en mutu ou sur un kimsufi. Dans le dernier cas ne passe pas par un SMTP relais.


Frédéric

Pascal47
24/02/2012, 21h40
Je voudrais bien, mais le souci est que mon Exchange n'est pas en frontal sur le net.
Je passe par un relai smtp chez orange.
Sur ma page web qui est hebergée chez OVH, si j'utilise le phpmailer (donc la remise directe par un serveur mail de chez OVH) ca fonctionne sur toutes les adresses qui ne font pas partie de mon domaine. Si, au lieu d'utiliser le phpmailer, je configure le site pour envoyer les mails via un serveur SMTP GMAIL, tous les messages passent sans problème.
D'ou ma déduction que le relai Orange bloque les mails en provenance des serveurs d'OVH. Je crois avoir lu dans certains posts sur ce forum que des problèmes similaires existent entre les serveurs d'OVH et les serveurs d'Orange.

Pascal

fritz2cat
24/02/2012, 20h03
Si tu as un Kimsufi, pourquoi te casses-tu la tête à relayer ton mail via Orange ? Livre les en direct sans passer par un relais !

Frédéric

Pascal47
24/02/2012, 19h48
Bonsoir,
C'est une offre Kimsufi sur un serveur gentoo
J'utilise phpmailer sur mon site internet et donc les serveurs de mail d'OVH.
Les mails arrivent bien sur les domaines qui ne m'appartiennent pas. Dès que c'est un domaine que je gère, les mails n'arrivent pas.
Je passe par un relai SMTP chez orange qui route les mails vers mon serveur Exchange 2010.
J'ai tenté en désactivant le phpmailer dans la conf du le site et mettre à la place le SMTP de mon adresse privé. Et là, tout fonctionne correctement sur toutes les adresses.
Je pense que le relai smtp de chez Orange bloque les mails en provenance des serveurs d'OVH, mais je ne suis pas sur. Ca pourrait fonctionner comme ça, mais avec mon SMTP privé, je suis bloqué à 500 mails par jours, alors que mes campagnes de mails comportent presque 20 000 destinataires.
J'en perd mon latin...
Merci
Cdlt,
Pascal

fritz2cat
24/02/2012, 19h14
Ton dédié: quelle distribution, quel logiciel de mail, quel est le hostname de ce serveur (cat /etc/hostname ; cat /etc/mailname) ?
Ton domaine: quels sont les serveurs MX ?

Frédéric

Pascal47
24/02/2012, 17h01
Bonjour,

Je rencontre un problème depuis quelques temps, et je n'arrive pas à trouver la solution.

J'ai un serveur dédié chez OVH qui héberge un site Internet.
OVH gère aussi mon nom de domaine.
Dans les DNS de ces domaines les MX pointent vers le relai mx d'orange
J'ai un serveur Exchange dans l'entreprise qui gère les emails en les récupérant depuis le relai d'orange. Jusque là, tout va bien, ça fonctionne.
MAIS
Sur le serveur d'OVH j'ai une site en php dans lequel est utilisé l'envoi de mail automatique.
Les mails arrivent bien dans la boite de leurs destinataires (gmail, yahoo, ...)sauf ceux de mon domaine.
Avez vous déjà rencontré ce problème, et si OUI, comment avez vous fait pour le régler.
Merci.
Cordialement,
Pascal