OVH Community, votre nouvel espace communautaire.

Apc combiné à memcached - vous avez dit libtool ?


jack84an
17/03/2012, 18h43
je butte sur le même probleme. Peut-être une piste: sur la gentoo release2 il n'y a pas de pear sous php53 , il n'existe que sur /usr/share/php5/PEAR/Builder.php afin de corriger le probleme de libtool.
J'ai tout pointé vers php5 (c'est pour du wordpress) mais je n'arrive toujours pas à passer le cap du
/etc/init.d/memcached start
c'est comme si memcached n'était pas installé pourtant /usr/local/src/memcache-3.0.6 est bien plein de fichiers..

gaboul49
07/02/2012, 09h16
Digitus, je n'ai pas lu tout ton post mais j'ai tout de même une question.

Es-tu sûr que la release 2 est faite pour toi ? Si tu sais comment "regarder sous le capot", alors je te conseille plutôt de partir sur une distrib supportée par une large communauté + un panel si nécessaire.

vaporisator
07/02/2012, 06h42
Citation Envoyé par Digitus
Oui Release 2 ... Faut'il attendre OVH pour mettre les paquets à jours !

Vaporisator ui, j'ai lu la mise en place d'un ramdisk d'une taille choisie chez OVH sans avoir à bidouiller ni lilo ni grub ! As-tu mis en place Lighttpd à la place d'Apache ?

Coté Gentoo, on me dit ne pas pouvoir pas faire tourner apc cache sur une gentoo2
que dans l'acp.php, seule la page courante est mise en cache ???
quelqu'un peut confirmer !!!

Vais tout de même tenter ce Tuto avant de passer sur une autre release : Installation FastCGI, eAccelerator sur Release 2 Gentoo via http://forum.ovh.com/showthread.php?t=33988
Je suis resté sous apache2 que je maitrise mieux :

Config suivante pour eaccelerator :

eAccelerator support enabled
Version 0.9.6.1
Caching Enabled true
Optimizer Enabled true
Check mtime Enabled true
Memory Size 33,554,360 Bytes
Memory Available 56 Bytes
Memory Allocated 33,554,304 Bytes
Cached Scripts 252
Removed Scripts 120

Sur VPS 3, il ne saute plus depuis que j'ai changé les configs sur apache, j'ai adapté ce tuto là à ma config et mon traffic : http://www.yann.com/fr/optimiser-la-...0/05/2011.html

Bon courage

Tibre44
03/02/2012, 18h33
De mémoire je n'ai réussi à résoudre ce pb sur la release 2 qu'en désinstallant tout les paquets php et apache et en repartant des paquets standard. Mais ça c'était il y a longtemps et debian est depuis des années ma meilleure amie

Il n'est pas conseillé de modifier la release 2 dont le but est justement d'offrir une distri toute prête pour les non initiés.

Digitus
03/02/2012, 16h56
Oui Release 2 ... Faut'il attendre OVH pour mettre les paquets à jours !

Vaporisator ui, j'ai lu la mise en place d'un ramdisk d'une taille choisie chez OVH sans avoir à bidouiller ni lilo ni grub ! As-tu mis en place Lighttpd à la place d'Apache ?

Coté Gentoo, on me dit ne pas pouvoir pas faire tourner apc cache sur une gentoo2
que dans l'acp.php, seule la page courante est mise en cache ???
quelqu'un peut confirmer !!!

Vais tout de même tenter ce Tuto avant de passer sur une autre release : Installation FastCGI, eAccelerator sur Release 2 Gentoo via http://forum.ovh.com/showthread.php?t=33988

Tibre44
03/02/2012, 13h17
Citation Envoyé par Digitus
/home/src/APC-3.1.9/libtool: line 467: CDPATH: command not found
/home/src/APC-3.1.9/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error. This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [/home/src/APC-3.1.9/modules/apc.la] Error 63
Release 2 par hasard ?

vaporisator
03/02/2012, 12h44
Salut,
j'ai pas le temps d'analyser tout ce que tu as dit, mais à titre perso, sur une distro ubuntu, j'utilise eaccelerator qui fonctionne très bien, j'avais essayé de mettre memcached, mais j'avais eu des soucis avec apache, donc j'étais resté sur eaccelerator. Sinon y a php5-xcache qui n'est pas mal non plus...

Digitus
31/01/2012, 18h56
Bonjour,
je cherche depuis un certain temps (enfin, ça fait 2 jour seulement que j'ai souscris à ce VPS ! - mais, je le fait intensivement ) à optimiser la gestion de mes sites, surtout au niveau de la rapidité de chargement des pages.

Hier soir, j'ai mis en place MEMCACHED (système de cache mémoire distribué)
et j'ai rencontré ce problème lors de la commande ./configure && make

... recreate aclocal.m4 with macros from libtool 2.2.6b

Afin de résoudre cette problématique, j'ai édité le fichier : /usr/share/php5/PEAR/Builder.php

Et ajouté après "// }}} end of interactive part"
if (file_exists('aclocal.m4')) {
$this->_runCommand('rm aclocal.m4');
$this->_runCommand('autoreconf');
}

Ce qui a résolu cette petite première expérience
ça c'est pour l'info et le partage.

Combiner APC et MEMCACHE est la configuration qui me séduit le plus !(enfin, ce que je peux en lire). Je cherche donc à ajouter APC sur un gentoo 2 64bits !

Pour installer APC au jour d’aujourd’hui sur un gentoo 2 64bits, la commande est t'elle bien celle ci avec la dernière version et php 5.3 ?

APC

Sous SSL on tape :

ln -s /usr/local/php53/bin/phpize /bin/phpize
ln -s /usr/local/php53/bin/php-config /bin/php-config
ln -s /usr/local/php53/bin/pear /bin/pear
ln -s /usr/local/php53/bin/pecl /bin/pecl

cd /home
mkdir src
cd src
wget http://pecl.php.net/get/APC-3.1.9.tgz

tar xvzf APC-3.1.9.tgz

cd APC-3.1.9
phpize
./configure && make
make install

Puis dans "/usr/local/lib/php53/php.ini" on ajoute/modifie :
extension_dir = "/usr/local/php53/lib/php/extensions/no-debug-non-zts-20060613/"

extension=apc.so

apc.enabled = 1
apc.rfc1867 = on

-----------------------------------------------------------------------

Sauf que lors de la commande ./configure && make
je rencontre à nouveau le problème lié à libtool ????


creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
config.status: config.h is unchanged
/bin/sh /home/src/APC-3.1.9/libtool --mode=install cp ./apc.la /home/src/APC-3.1.9/modules
/home/src/APC-3.1.9/libtool: line 467: CDPATH: command not found
/home/src/APC-3.1.9/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error. This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [/home/src/APC-3.1.9/modules/apc.la] Error 63



PQ ?
Quelqu'un a t'il déjà rencontré ce problème ?
Y'a t'il une erreur ...
De l'aide ne serait pas de refus ...

Merci et bravo pour cet espace d'échange d’entraide ainsi qu'à tout ceux qui y participe ...

St.