OVH Community, votre nouvel espace communautaire.

Ouvrir les ports Thomson TG784n


Mariotte91
21/12/2011, 17h54
Bonjour,

malgré que le port soit ouvert dans le routeur, tant que l'application concerné n'est pas lancé le port apparait fermé au scanner.
Ca c'est tout a fait normal ! Le routeur essaye d'aiguiller des données vers une adresse qui n'écoute pas. Au bout d'un moment, il va y avoir un time out et le routeur va informer l'adresse qui a fait la demande que la porte est fermée.

Si le port n'est pas ouvert, le routeur va jeter les paquets et ne pas envoyer de réponse à l'émetteur. Le port est dit "filtré".

Donc un port qui apparait fermé sur un test indique à la source que celui-ci peut être ouvert de temps en temps.

La bonne question est : Est-ce que ton jeu fonctionne ? J'ai cru comprendre que non....

Ensuite, les ports nécessaires sont ils bien dirigés

Lineage II requires the following ports to be fully unrestricted and accessible inbound and out:

TCP 80, 2009, 7777, 2106
UDP 53
Pour ce qui des ports en sortie, normalement aucun problème car tout est ouvert en configuration de firewall "standard" sur le tg784n.

Reste à déclarer les 5 règles ci dessus.

Je viens de re-scanner ton IP et il y a du mieux par rapport à hier mais je vois 2 erreurs
Le port 53 est déclaré en TCP au lieux de UDP

le Port TCP 2009 n'est pas programmé (c'est le TCP 2109 qui semble déclaré)


Bon courage,

Patrick

dblkion
21/12/2011, 17h15
MAJ :

Après un bout de temps passé avec Sylvain du support au 1007 et plusieurs manips, on s'est rendu compte que malgré que le port soit ouvert dans le routeur, tant que l'application concerné n'est pas lancé le port apparait fermé au scanner.

Example :

Scan port 25565 (minecraft server) = port closed
Open port 25565 on routeur then scan = port closed
Start minecraft server.exe then scan port = port open

Dans le cas de mon applications sur lineage 2, il est possible qu'elle n'arrive pas à avoir accès au port.

Bref moi je suis totallement perdu, je sais pas si c'est normal et si il y a un moyen de laisser le port bien ouvert en permanance ..

Merci pour votre aide !

Mariotte91
20/12/2011, 20h40
J'ai fait le scan et cela donne

Ports fermés TCP 21 et TCP 2106 (ceci indique généralement un port ouvert sur le routeur mais bloqué plus loin)
Ports Ouverts TCP 80, 1080, 8080, 51005 (utilisé par la téléphonie), et UDP 5060 (téléphone SIP)

Tous les autre ports sont filtrés.

Je pense donc que ton problème est après la box (client ou serveur pas à l'écoute au moment du test entre 21:14 et 21:29 ou pare-feu qui bloque des choses)

Patrick

Mariotte91
20/12/2011, 16h29
Envoi moi par MP ton adresse IP et je ferai un scan complet TCP et UDP

Oups, pas de system MP sur ce forum, j'ai donc autorisé l'envoi d'e.mail.

Patrick

dblkion
20/12/2011, 16h26
Pour lineage 2 il ne s'agit pas d'un serveur, c'est juste un service qui doit avoir accès au port, et j'ai pas de firewall, c'est bien pour ça que je comprend pas pourquoi ca marche pas :/

Mariotte91
20/12/2011, 15h51
Pour que le port soit vu ouvert, il faut que ton serveur soit en marche et qu'aucun pare-feu ne le bloque.

dblkion
20/12/2011, 14h47
Ok merci, j'avais pas compris qu'il fallais récupérer ces fichiers avec le backup, Du coup dans mon service.ini j'ai bien

rule add name="L2" protocol=tcp portrange=2106-2106
rule add name="L2" protocol=udp portrange=2106-2106
assign name="L2" host=192.168.1.66 log=disabled

Et pourtant, sur les sites qui check les ports ouverts, ils disent que mon port 2106 est fermé ..

Mariotte91
20/12/2011, 14h34
service.ini est une section à l'intérieur du fichier user.ini

Le fichier user.ini est généré par une sauvegarde de la configuration de la box que l'on fait par l'interface d'administration via le menu

Home > Thomson Gateway > Configuration > Save or Restore configuration

en choisissant l'option "backup configuration now"

Par le même menu, tu restaurera ta configuration modifiés en pointant sur le fichier puis en cliquant sur le bouton "Restore configuration now"

Patrick

dblkion
20/12/2011, 14h19
Bonjour et merci pour le coup de main, Par contre je comprend pas ou trouver les fichiers User.ini et service.ini :/

Mariotte91
20/12/2011, 06h08
Bonjour,

Pour Mincraft server, il faut effectivement ouvrir le port 25565 en TCP et en UDP

J'ai créé une règle que je retrouve bien dans le fichier user.ini récupéré lorsqu'on fait une sauvegarde des paramètres de config du TG784n.

Code:
[ service.ini ]
add name=MineCraft_server
rule add name=MineCraft_server protocol=tcp portrange=25565-25565
rule add name=MineCraft_server protocol=udp portrange=25565-25565
assign name=MineCraft_server host=192.168.1.101 log=disabled
En fin de ligne "add name" il pourrait être bien d'ajouter "mode=server"

Code:
add name=MineCraft_server mode=server
Pour ce qui est de Lineage II, il semble que ce soit un peu plus compliqué

D'après le site PortForward.com il faudrait ouvrir en TCP 80, 2106, 2009, 7777 et en UDP 53,
ce qui donnerait

Code:
add name=Lineage2
rule add name=Lineage2 protocol=tcp portrange=80-80
rule add name=Lineage2 protocol=tcp portrange=2106-2106
rule add name=Lineage2 protocol=tcp portrange=2109-2109
rule add name=Lineage2 protocol=tcp portrange=7777-7777
rule add name=Lineage2 protocol=udp portrange=53-53
assign name=Lineage2 host=192.168.1.101 log=disabled
Si tu n'arrive pas à ce résultat par l'interface Web d'administration, il est possible d'ajouter les lignes ci dessus dans la section [service.ini] à la suite des lignes existantes en adaptant l'adresse IP du host de destination à ton cas. Ensuite tu n'as qu'a faire relire le fichier de configuration modifié par le TG784n par le menu

Home > Thomson Gateway > Configuration > Backup & Restore


j'ai essayé d'ouvrir Minecraft (25565) ca a marché le jour même et le lendemain non
Je travailles toujours en IP fixes sur le LAN quand je fais des règles NAT.

Patrick

dblkion
19/12/2011, 20h40
En l'occurence j'ai essayé d'ouvrir Minecraft (25565) ca a marché le jour même et le lendemain non, ensuite j'ai essayé d'ouvrir un port pour Lineage 2 (2106)

Mariotte91
19/12/2011, 20h27
Bonjour,

Pour quels services souhaites tu ouvrir des ports.

Pour ma part c'est OK pour SMTP, HTTP, HTTPS, Jabber (créé) , Bittorent (créé) mais par contre KO pour FTP (avec le port TCP 21 mais en changeant ça fonctionne)

Patrick

dblkion
19/12/2011, 20h15
Bonjour,

J'ai beau avoir effecté de recherches, fouillé dans l'aide du modem, j'arrive pas à ouvrir les ports.

Je vais bien dans Game & Application Sharing, je crée la règle, ensuite je l'attribu à mon PC dans le réseau mais apès tests, le port est toujours fermé.

Je comprend pas ... J'ai donné l'accès remote à des potes qui sont en école d'ingé et qui taffent sur du réseau qui comprennent pas non plus pourquoi ca marche pas -.-

Help plz !

Merci