OVH Community, votre nouvel espace communautaire.

Votre VPS toujours à jour avec le Patch Automatique


Matthieu.L
24/01/2012, 16h39
larleuch > Oui, c'est dû à la limitation actuelle à une adresse IP par VPS. Cette limite devrait bientôt être levée et vous pourrez sans pb mettre votre certificat SSL sur un nouveau VPS.
Pour le patch auto, tout dépend de votre installation actuelle. Vous avez une release 2 non modifiée ?

alexis-bg > Merci pour votre retour.
Je comprends votre analyse. Plesk est une bonne approche du serveur pour les débutants qui n'ont pas l'habitude du root en effet. son interface est vraiment facile à prendre en main et moderne.
Aucun système de mise à jour n'est parfait, mais Parallels fournit de gros efforts pour que les upgrades soient complets et se passent sans encombre.

alexis-bg
23/01/2012, 17h51
@Matthieu.L

Merci de votre réponse.

En fait, je n'y connais pas grand-chose à Plesk car je ne l'ai jamais installé sur un de mes serveurs. Je suis de l'école SSH en root.

Mais je me mets à la place d'une majorité de mes clients. Ils n'ont en effet aucune utilité d'un accès root, ne sachant pas s'en servir. Ils louent des serveurs "managed" une fortune chez d'autres prestataires qu'OVH. C'est pour cela que j'estime qu'il y a un marché à prendre pour OVH.

1 & 1 propose une solution de ce type sur leur dédiés, reprenant plus ou moins l'interface de leur serveurs mutualisés. Mais il manque la fiabilité et la souplesse dans le choix de la config hardware comme le propose le VPS. Et puis JAMAIS je ne recommanderais 1 & 1, même à mon pire ennemi.

Est-ce que l'auto-update de Plesk permet d'avoir un système parfaitement à jour et sécurisé, sans avoir besoin d'aller le trifouiller avec des apt-get ?

Pour les CMS, c'est un domaine qu'ils maîtrisent. Ils s'occupent des installs et les mise-à-jours via FTP.

Alexis

larleuch
23/01/2012, 17h06
Bonjour,

J'aimerais avoir des précisions car :

- nous avons pris un 1er VPS en mai~juin 2011 : sur ce VPS la connexion https est possible en simultanée sur le site et sur phpmyadmin.

- nous avons pris un 2e VPS en janvier 2012 : sur celui-ci et d'après Richard (service téléphonique VPS) nous ne pouvons pas avoir une connexion sécurisée en même temps sur notre site et sur phpmyadmin. Apparemment il s'agit d'un problème de virtualhost dû à la nouvelle version. (Donc dans ces conditions on ne peux pas utiliser notre VPS...). Le service VIP n'a rien pu faire pour nous.


Dans ces conditions j'aimerais savoir comment se passe la mise à jour automatique, car mon VPS fonctionnel deviendrais inutilisable car non sécurisé avec la dernière version... ?

Merci de votre attention.
Cordialement.

Matthieu.L
23/01/2012, 11h45
Bonjour,

La dernière version de Plesk intègre une fonctionnalité d'auto-update, ainsi qu'une librairie de softs open source (CMS inclus) à installer très facilement.
Vous préféreriez que vos clients n'aient pas du tout l'accès root ?

alexis-bg
22/01/2012, 11h53
Bonjour à tous,

Je pense qu'il serait bien plus profitable de proposer une distrib ou une option intégrant Plesk (ou cPanel), maintenue, sécurisée et sauvegardée par OVH.

En effet, je bosse avec des agences de com ou web agencies dont les compétences techniques sont relativement limitées. Leurs besoins se limitent à installer des sites web généralement basés sur des CMS, des noms de domaines et parfois des comptes email. Pour ce faire, si l'interface graphique de Plesk leur convient parfaitement, un accès root en SSH est totalement inadapté.

Je suis persuadé qu'elles seront prêtes à délier leur bourse si un tel service est proposé.

Alexis

Matthieu.L
16/01/2012, 15h15
Bonjour,

Ajouter un certificat SSL n'est pas considéré comme une modification de la config, non. Vous pouvez y aller tranquillement

oyac
14/01/2012, 23h20
Bonjour,
Qu'est-ce qui est mis à jour ?

Si j'installe OpenSSH, Apache, MySQL ou PHP, est-ce que l'option "Patch Automatique" va les mettre à jour lors des mises à jour de sécurité ?

Ou uniquement les services installés de base sur la disitrib choisie à l'installation ?


Edit:
En regardant un peu de plus près, j'ai compris plusieurs choses sur l'option patch auto:

- il faut obligatoirement utiliser la distrib release 2 OVH (Gentoo)
- le noyau et les services installés de base (SSH,Apache,PHP,Mysql, qmail...) sont mis à jour
- on utilise webmin pour administrer la distrib
- il ne faut pas modifier la config de la distrib sinon...


Donc ma nouvelle question est : ajouter un certificat SSL, est-ce considéré comme une modification de la config ?

Matthieu.L
14/12/2011, 17h16
Avec l'option Patch Automatique, OVH se charge d'effectuer les mises à jour nécessaires à la sécurité de votre VPS en activant le Netboot, en appliquant les releases et en mettant à jour les noyaux GR Security moins de 24H après leur parution officielle.

Libérez-vous du temps !
http://www.ovh.com/fr/vps/vps_dynamique_votre_offre.xml

Bien à vous,
Matthieu L.
___________________
Team OVH