OVH Community, votre nouvel espace communautaire.

Configurer Plesk pour les .FR


spiritdax
05/09/2009, 22h52
Citation Envoyé par lozit
Lorsque vous voulez héberger un nom de domaine en .FR sur votre serveur OVH Plesk, vous avez la désagréable surprise de ne pas avoir l'autorisation de l'AFNIC car le serveur, par défaut, n'est pas conforme aux attentes de l'AFNIC. Si vous avez choisi PLESK, c'est aussi peut être par volonté de ne pas avoir à mettre les mains dans le code, et bien j'ai une mauvaise nouvelle pour vous, il va falloir quand même utiliser SSH, VI et autres commandes Shell.

Il est bon de configurer le serveur AVANT de rediriger le .FR sur le serveur, car de toute façon, tant que le serveur n’est pas configuré correctement, l’AFNIC refusera tout simplement de faire la redirection.

Je vais prendre comme exemple le nom de domaine toto.fr. On imagine pour l’occasion que votre serveur DNS primaire a l’adresse IP 213.0.0.1 et comme nom ns00000.ovh.net

Et que l’adresse IP du DNS secondaire d’OVH est 212.27.32.132 avec comme nom ns.ovh.net

Etape 1 : Dans plesk, ajoutez le nom de domaine comme d’habitude.

Etape 2 : Modifier le named.conf

* Connectez vous en SSH sur votre serveur en root
* Editez le fichier : /var/named/run-root/etc/named.conf

Vous devez avoir quelquechose comme ça :



Et il suffit de rajouter l’adresse IP du DNS secondaire d’OVH entre l’adresse IP de votre serveur et la ligne : common-allow-transfer; pour avoir ça :



Etape 3 : Modifier le fichier /var/named/run-root/var/toto.fr

Vous devez avoir ça :



Il faut modifier la seconde ligne, là où vous avez le « serial ». Il faut que le sérial soit conforme avec la volonté de l’afnic, c'est-à-dire : annéemoisjournuméro. Pour le 31 Janvier 2006 on aura 2006013101 Notez que les deux derniers chiffres sont necessaires si vous enregistrez plusieurs .FR dans la même journée : 01 pour le premier, 02 pour le second…

Sur la première ligne remplacez l’adresse email (avec un point à la place du @) par postmaster.toto.fr

Il faut ensuite supprimer la ligne IN NS Et rajouter à la place :



N’oubliez pas les point en fin de ligne et apres le toto.fr

On doit avoir ça :



Etape 4 : Redémarrez BIND
/etc/init.d/named restart.

Etape 5 : Ajouter le nom de domaine dans le serveur de nom secondaire OVH

* Allez dans votre espace client OVH
* Cliquez sur « Serveur Dédié »
* Cliquez sur « DNS Secondaire »
* Ajouter votre domaine toto.fr

Etape 6 : Tester si tout est bon

Allez sur le site du Zone Check de l'AFNIC

et remplissez le formulaire :
zone : toto.fr
primaire : ns00000.ovh.net - ip: 213.0.0.1
secondaire : ns.ovh.net - ip : 212.27.32.132

et laissez les options par défaut.

Normalement, vous devriez avoir un succés en résultat final.

Si vous avez comme erreur : Aucun enregistrement SOA présent sur le serveur, c’est normal, il faut attendre que le DNS secondaire d’OVH se mette à jour.

Il faut donc patienter un peu et essayer jusqu'à ce que ça passe.

Bon courage
Bonjour, j'ai plesk 9 et je suis chez ovh.
j'ai suivi ce tuto à la lettre
concernant le fichier named.conf , tout était déjà corectement configurer.
Ensuite sur le fichier monsite.fr il falait juste changer le serial, ce que j'ai fait.
en mettant la date d'aujourd'hui "2009090501 ; Serial"
malgré tout lorsque je vais sur zonecheck j'ai toujours l'erreur suivante:

* Réf: RFC1912 (p.3)

The recommended syntax is YYYYMMDDnn (YYYY=year, MM=month, DD=day, nn=revision number).

*

Le numéro de série 1212334660 ne semble pas être au format YYYYMMDDnn.

* sdns1.ovh.net./213.251.188.140

je ne sais pas ou il vas chercher ce numero "Le numéro de série 1212334660 "

Je ne sais plus quoi faire si quelqu'un peut m'aider.

merci

Yoo
09/01/2009, 18h36
Dans plesk 8.6 il ya une option sur la page DNS de chaque domaine :

Chez moi en anglais ca donne SOA Record 4eme icone.

On cliquant dessus on arrive sur la page de config des SOA...

il suffit de cocher la case dans la partie du bas...

Code:
Usage of serial number format recommended by IETF and RIPE can resolve registrar refusal issues and is mandatory for many domains registered in some high-level DNS zones.
Use serial number format recommended by IETF and RIPE *
Et ca marche...

Douifre
14/11/2006, 23h36
est ce quelquun a réussi à sortir de la ? y a t il une bonne ame capable de m'aider... j'offre un ou 2 beaux livres anciens au candidat... Je ne m'en sort pas avec mon serveur dédié plesk et mon domaine.fr

Merci

Frederic

chris2a
03/11/2006, 18h14
enfaite jai resusi jai plus que cela

---- fatal ----
f: Enregistrements SOA et ANY incohérents


* ks351095.kimsufi.com./213.186.38.26

chris2a
03/11/2006, 12h53
oui et non :/ la procedure exate pour le squelette a modifier car je c'est pas trop quoi mettre et jai pas envi de tout planter :$

janiko
03/11/2006, 10h10
Le mieux est d'aller voir les guides OVH à ce sujet :

http://guides.ovh.com/ToutPlesk

http://guides.ovh.com/ModifDnsPlesk (pour modifier le DNS d'un domaine).

Plesk est conçu pour gérer de nombreux domaines, et propose donc des paramètres par défaut pour la création. Par exemple, quand on crée un domaine, il faut créer tout un tas d'enregistrements pour la résolution des DNS (des PTR, des A, des CNAME, des NS, etc). Plesk les crée automatiquement, à partir de ce que j'ai appelé le squelette, et qui est accessible dans la rubrique "Serveur", puis "DNS".

Pour faciliter les choses, il est préférable de modifier ce squelette pour le .FR en ajoutant un second enregistrement NS.

Sinon, pour chaque domaine, il est possible de modifier ces enregistrements, mais domaine par domaine, en allant non plus sur "Serveur" mais sur "Domaine" puis sur le domaine voulu puis sur DNS. Alors, seuls les enregistrements du domaine seront modifiés.

J'espère que cela eclaire le sujet.

chris2a
02/11/2006, 22h42
Citation Envoyé par janiko
Pour cela, il faut que dans Plesk, Server > DNS il y ait deux enregistrements NS. Ce qu'on voit dans Server > DNS, c'est le "squelette" utilisé pour chaque domaine qui doit être géré par Plesk. Il faut donc un enregistrement NS pour le serveur primaire (ns.mon-serveur.com) et un pour le serveur secondaire (ns.ovh.net).
LA J'ai pas compris :x desoler

Et j'ai remarquer quelque chose de bizar aussi défoit ZoneCheck me mais cela et defoit rien :x comme si il ete trouver :/

Aucun enregistrement SOA présent sur le serveur

* ns.kimsufi.com./213.186.33.199

janiko
02/11/2006, 22h11
Pour configurer les domaines en .FR, il y a quelques points primordiaux à savoir.

D'abord il faut éviter les modifs manuelles, car Plesk risque de tout écraser à la moindre mise-à-jour par le panneau d'administration web.

La seule modif à faire manuellement est celle du fichier /etc/named.conf, à savoir décommenter la ligne :

// query-source address * port 53;

Cela évitera des problèmes si on utilise un firewall (ce qui est fortement recommandé) qui n'ouvrirait que le port 53 pour bind.

Ensuite un .FR doit avoir deux serveurs DNS distincts. Sur une machine dédiée OVH, il est conseillé de prendre son serveur (ns.mon-serveur.com par exemple) et le serveur secondaire mis gratuitement à disposition par ovh (ns.ovh.net). Cela implique notamment d'ajouter son domaine sur ce serveur secondaire (cf http://guide.ovh.net/InstallDNSSecondaire).

Pour cela, il faut que dans Plesk, Server > DNS il y ait deux enregistrements NS. Ce qu'on voit dans Server > DNS, c'est le "squelette" utilisé pour chaque domaine qui doit être géré par Plesk. Il faut donc un enregistrement NS pour le serveur primaire (ns.mon-serveur.com) et un pour le serveur secondaire (ns.ovh.net).

Enfin, il faut indiquer à Plesk qu'il doit autoriser la propagation des informations du serveur primaire vers le serveur secondaire, afin qu'ils soient synchronisés. Il faut aller dans Server > DNS > Common ACL et ajouter l'IP (ou les IP) sur lesquelles les transferts sont autorisés.

Il est préférable d'indiquer une plage d'adresse (car l'IP de ns.ovh.net peut changer). En pratique, cela ne pose pas de souci de sécurité.

Donc en théorie il faut mettre l'IP de ns.ovh.net (212.27.32.132) mais on peut mettre un "masque" plus large (genre 212.27.32.144/28 si je ne me trompe pas).

Si tout va bien, des messages de transferts doivent apparaître dans /var/messages.

Attention : si le domaine a été créé avant la modification du "squelette", il faudra ajouter ou modifier les enregs 'NS' pour chaque domaine déjà créé, mais cela se fait aussi dans Plesk, en allant dans le domaine puis dans DNS.

Dernière chose : faire ces manips (éventuellement relancer BIND) et... attendre 2 ou 3 jours ! Ensuite, aller sur zonecheck.fr pour contrôler qu'on remplit bien les conditions nécessaires à un .FR et si c'est ok, demander le transfert de gestion du DNS du domaine.

chris2a
02/11/2006, 13h42
coucou voila jai suivi ton tuto lozit mais j'ai un probleme que je ne comprend pas.

Aucun enregistrement SOA présent sur le serveur

* ns.kimsufi.com./213.186.33.199


f: Enregistrements SOA et ANY incohérents

* ks351095.kimsufi.com./213.186.38.26
pour le pas de SOA OK on va atendre un peu mais pour SOA et ANY incohérents je vois pas trop et ANY c'est quoi ? ( je suis novice )

lozit
02/11/2006, 11h00
Pour plesk620 : désolé je n'avais pas vu ton message, et je n'utilise plus PLESK

Pour Jonat : Si tu arrete et redemarre ton site, il faut re-modifier ton fichier zone.

Pour Julie : J'ai cherché un peu mais ça m'a vite gavé du coups je faisais les modifs à la main. C'est pas très compliqué... après ça dépend si on tripatouille les .fr tous les 2 jours ou pas.

Sinon dans les trucs obligatoire pour les .fr, il faut avoir deux DNS de configurés.

Julie
24/10/2006, 14h45
http://download1.swsoft.com/Plesk/Pl...uide/22369.htm

Ca ne marche pas sur Plesk 8 Linux

Une autre solution ?

Moi j'veux pas jouer manuellement sur les fichiers zones... il doit y avoir moyen de patcher Plesk pour qu'il gère les .fr correctement
En plus modifier les zones à la main c'est pas super car dès qu'on fait une modif sur une zone via Plesk, Plesk remet les choses noms conformes

Pour que l'AFNIC accepte une migration, quelles sont les règles à respecter ?
Format du serial, postmaster dans l'adresse email... mais quoi d'autre ?

Merci d'avance pour vos réponses car je vais bientôt migrer mon .fr du mutualisé vers un dédié... j'suis dans le "caca"

Jonat
07/10/2006, 17h26
Up pour une petite question

Une fois qu'on a fait ça et que l'AFNIC a accepté la config, qu'est-ce qu'il se passe si je désactive / réactive le DNS du domaine .fr dans Plesk ? Parce que quand on désactive ça efface le fichier zone et quand on réactive ça recrée le fichier zone (et ça remet l'adresse email d'origine (pas la .fr) et le serial d'origine (pas celui au bon format)

Autre chose : je rencontre un prob avec Plesk. Je ne peux pas arrêter / redémarrer le service DNS BIND dans le Service Management et j'comprends pas pourquoi
Avez vous le même prob ?

Merci

plesk620
12/09/2006, 15h28
Dis Lozi, tu voudrais pas m'aider à configurer spamassassin sur mon serveur plesk? Ovh me l'a installé mais, pas configurer pour filtrer les spam...

Cordielement

lozit
12/09/2006, 09h13
Ca me fait plaisir de voir que ça a servi à quelqu'un

plesk620
11/09/2006, 19h17
Slt Lozi,
g viens d'arriver sur ce forum après tant de galère tout seul avec ovh à configurer mon plesk. Et effectivement, ce que tu souligne est très vras car j'en ai subit les frais. je n'ai toujour spas resous ce pb mais, ta solution vient me sauver. G vais m'y mettre. Tout simplement pour te dire ...Thx!!!! big Thx

lozit
14/04/2006, 10h08
Lorsque vous voulez héberger un nom de domaine en .FR sur votre serveur OVH Plesk, vous avez la désagréable surprise de ne pas avoir l'autorisation de l'AFNIC car le serveur, par défaut, n'est pas conforme aux attentes de l'AFNIC. Si vous avez choisi PLESK, c'est aussi peut être par volonté de ne pas avoir à mettre les mains dans le code, et bien j'ai une mauvaise nouvelle pour vous, il va falloir quand même utiliser SSH, VI et autres commandes Shell.

Il est bon de configurer le serveur AVANT de rediriger le .FR sur le serveur, car de toute façon, tant que le serveur n’est pas configuré correctement, l’AFNIC refusera tout simplement de faire la redirection.

Je vais prendre comme exemple le nom de domaine toto.fr. On imagine pour l’occasion que votre serveur DNS primaire a l’adresse IP 213.0.0.1 et comme nom ns00000.ovh.net

Et que l’adresse IP du DNS secondaire d’OVH est 212.27.32.132 avec comme nom ns.ovh.net

Etape 1 : Dans plesk, ajoutez le nom de domaine comme d’habitude.

Etape 2 : Modifier le named.conf

* Connectez vous en SSH sur votre serveur en root
* Editez le fichier : /var/named/run-root/etc/named.conf

Vous devez avoir quelquechose comme ça :

zone "toto.fr" {
type master;
file "toto.fr";
allow-transfer {
213.0.0.1;
common-allow-transfer;
};
};
Et il suffit de rajouter l’adresse IP du DNS secondaire d’OVH entre l’adresse IP de votre serveur et la ligne : common-allow-transfer; pour avoir ça :

zone "toto.fr" {
type master;
file "toto.fr";
allow-transfer {
213.0.0.1;
212.27.32.132;
common-allow-transfer;
};
};
Etape 3 : Modifier le fichier /var/named/run-root/var/toto.fr

Vous devez avoir ça :

@ IN SOA ns.toto.fr. toto.wanadoo.fr. (
1138702310 ; Serial
10800 ; Refresh
3600 ; Retry
604800 ; Expire
86400 ) ; Minimum

toto.fr. IN NS ns.toto.fr.
ns.toto.fr. IN A 213.0.0.1
toto.fr. IN A 213.0.0.1
webmail.toto.fr. IN A 213.0.0.1
mail.toto.fr. IN A 213.0.0.1
ftp.toto.fr. IN CNAME toto.fr.
www.toto.fr. IN CNAME toto.fr.
toto.fr. IN MX 10 mail.toto.fr.
Il faut modifier la seconde ligne, là où vous avez le « serial ». Il faut que le sérial soit conforme avec la volonté de l’afnic, c'est-à-dire : annéemoisjournuméro. Pour le 31 Janvier 2006 on aura 2006013101 Notez que les deux derniers chiffres sont necessaires si vous enregistrez plusieurs .FR dans la même journée : 01 pour le premier, 02 pour le second…

Sur la première ligne remplacez l’adresse email (avec un point à la place du @) par postmaster.toto.fr

Il faut ensuite supprimer la ligne IN NS Et rajouter à la place :

toto.fr. IN NS ns00000.ovh.net.
toto.fr. IN NS ns.ovh.net.
N’oubliez pas les point en fin de ligne et apres le toto.fr

On doit avoir ça :

@ IN SOA ns.toto.fr. postmaster.toto.fr. (
2006013101 ; Serial
10800 ; Refresh
3600 ; Retry
604800 ; Expire
86400 ) ; Minimum

toto.fr. IN NS ns00000.ovh.net.
toto.fr. IN NS ns.ovh.net.
ns.toto.fr. IN A 213.0.0.1
toto.fr. IN A 213.0.0.1
webmail.toto.fr. IN A 213.0.0.1
mail.toto.fr. IN A 213.0.0.1
ftp.toto.fr. IN CNAME toto.fr.
www.toto.fr. IN CNAME toto.fr.
toto.fr. IN MX 10 mail.toto.fr.
Etape 4 : Redémarrez BIND
/etc/init.d/named restart.

Etape 5 : Ajouter le nom de domaine dans le serveur de nom secondaire OVH

* Allez dans votre espace client OVH
* Cliquez sur « Serveur Dédié »
* Cliquez sur « DNS Secondaire »
* Ajouter votre domaine toto.fr

Etape 6 : Tester si tout est bon

Allez sur le site du Zone Check de l'AFNIC

et remplissez le formulaire :
zone : toto.fr
primaire : ns00000.ovh.net - ip: 213.0.0.1
secondaire : ns.ovh.net - ip : 212.27.32.132

et laissez les options par défaut.

Normalement, vous devriez avoir un succés en résultat final.

Si vous avez comme erreur : Aucun enregistrement SOA présent sur le serveur, c’est normal, il faut attendre que le DNS secondaire d’OVH se mette à jour.

Il faut donc patienter un peu et essayer jusqu'à ce que ça passe.

Bon courage