OVH Community, votre nouvel espace communautaire.

Problemes d'installation avec Zend


arnolem
06/02/2012, 13h48
La règle suivante ne fait pas partie du ZF :
Code:
# Règles de réécriture pour Zend Framework
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* public/index.php
Peut etre que si tu l'enlève, ton problème sera résolu

JP16
05/12/2011, 14h41
Bonjour,

Je viens d'installer un site utilisant le framework Zend sur OVH et j'ai de gros problèmes de redirection de lien : l'appli me renvoie des erreurs "page non trouvée" pour toutes les pages (hormis les pages d'index et de login/logout) alors qu'elles existent dans le dossier.
Le site se trouve dans /www/1234 .

J'ai essayé de modifier mon htaccess mais sans résultat. Je ne comprend pas pourquoi ça ne marche plus alors qu'en local les liens fonctionnaient.

mon htaccess :

Code:
Options -MultiViews
 
# Règles de réécriture pour Zend Framework
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* public/index.php
 
# Sécurité : Ne pas autoriser le parcours de répertoires
Options -Indexes
 
# "active" PHP5
AddType x-mapp-php5 .php
SetEnv PHP_VER 5
 
# Désactive le paramètre register_globals
SetEnv REGISTER_GLOBALS 0
# Désactive le paramètre magic_quotes_gcp
SetEnv MAGIC_QUOTES 0

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
Quelqu'un a-t'il une solution s'il vous plait ?

Merci