OVH Community, votre nouvel espace communautaire.

Nom de sous domaine trop long ?


stephaneeybert
03/12/2011, 10h06
Bon, le nom de domaine se comporte très bien, merci encore.

Sinon, tu as un conseil à me donner ? J'ai le support technique de OVH qui apparemment ne prévoit pas l'installation de PHP à la ligne de commande.

Merci.

>>>>>>>>>
Bonjour,
Malheureusement il n'y a pas de guide à ce sujet, ce type d'intervention peut éventuellement être effectué dans le cadre d'une intervention payante.
Je reste à votre disposition pour toute autre question.
Cordialement,
Romuald, Support Ovh.

> Mais vous ne savez pas faire ?
> N'y a t'il pas un guide OVH a ce sujet ?
> Bon, je pourrais compiler PHP comme j'ai l'habitude de le faire sur ma machine de dev sous Linux, mais je voudrais respecter votre systeme de patch et ne pas faire quelque chose de trop hors norme, ceci afin de conserver une configuration la plus standard possible qui soit celle connue du support technique de OVH.

http://forum.ovh.com/showthread.php?t=75274

stephaneeybert
02/12/2011, 10h04
Je suis un schtroumpf Linux.

Je n'ai pas accès au routeur sinon.

Je vais patienter..

Merci encore !

cassiopee
02/12/2011, 10h02
Ça peut être une question de cache, tu peux :

- purger le cache DNS local (sous Windows, taper un "ifconfig /flushdns" dans une fenêtre DOS)

- purger le cache DNS de ta box/routeur en la redémarrant électriquement.

- purger le cache web de ton navigateur en tapant "Ctrl + F5" sur la page en question.

Sinon, il faudra patienter pour la propagation DNS.

stephaneeybert
02/12/2011, 09h56
C'est bizarre, sur mon Firefox, le clic sur le lien ci-dessus de http://katedralskolan.learnintouch.com affiche le message: Server not found.

cassiopee
02/12/2011, 09h54
De chez moi, c'est bon, avec "http://ifestonie.learnintouch.com"
on arrive bien sur l'institut français.

Compte un maxi de 24/48 heures pour que ça soit dispo partout dans le monde
(normalement je pense que ça devrait déjà être bon).

L'accès à http://katedralskolan.learnintouch.com/ affiche en revanche une belle
page blanche (mais niveau DNS c'est bon).

stephaneeybert
02/12/2011, 09h50
Ah oui :-) Merci !

Maintenant, je n'ai plus qu'à patienter alors..

cassiopee
02/12/2011, 09h47
Citation Envoyé par stephaneeybert
Bon je te dois une bonne bière ! Si un jour tu viens à Tallinn..
Je comprends mieux tes noms de sous-domaines

Pour répondre à ta question sur l'adresse IP de ifestonie.learnintouch.com,
ce sous domaine a la même IP que www.learnintouch.com je pense,
je n'aiqu'une seule IP pour mon serveur: 46.105.8.54
Vi vi mais ce n'est pas moi qui pose cette question, c'est le navigateur web
de chaque internaute voulant visiter le site web "http://ifestonie.learnintouch.com" par exemple.

Et donc selon que lui obtienne ou pas la réponse, il pourra par la suite
se connecter ou pas au site web correspondant.

stephaneeybert
02/12/2011, 09h37
Bon je te dois une bonne bière ! Si un jour tu viens à Tallinn..

Merci pour ces explications ! Je comprend enfin :-)

Pour répondre à ta question sur l'adresse IP de ifestonie.learnintouch.com, ce sous domaine a la même IP que www.learnintouch.com je pense, je n'aiqu'une seule IP pour mon serveur: 46.105.8.54

cassiopee
02/12/2011, 09h31
Citation Envoyé par stephaneeybert
Mais comment expliquer, que le sous domaine ifestonie.learnintouch.com que j'ai mis en place de la même manière, et ceci une demi heure avant, lui marche parfaitement ?
C'est justement parce que c'est désynchronisé qu'il y a ce comportement
"un coup ça marche, un coup ça ne marche pas" : tout dépend du serveur DNS
interrogé par ton PC domicile/bureau.

S'il tombe sur le serveur DNS maître, alors il aura les bonnes infos
(ici à quelle adresse IP correspond "ifestonie.learnintouch.com" ?)

S'il tombe sur le serveur DNS secondaire pas à jour, alors il n'aura pas
les bonnes infos => serveur non trouvé.

Et en plus de la configuration DNS, il faut que la configuration Apache
soit elle aussi correcte afin de pouvoir se connecter à un site web.

cassiopee
02/12/2011, 09h28
Citation Envoyé par stephaneeybert
J'ai donc changé le numéro pour celui que tu m'as indiqué et j'ai fais un reload.
C'est parfait, les deux serveurs DNS sont bien synchronisés à l'heure actuelle.

Comment tu as choisi ce numéro et pas un autre ?
A la base il s'agit d'un simple nombre entier non-signé en 32 bits,
donc compris entre 0 et 2 exposant 32 (soit 4 milliard et quelques).

Pour des raisons pratiques, on préfère en général suivre le format
YYYYMMDDNN où :

- YYYY représente l'année en cours, 2011 actuellement
- MM représente le mois en cours, 12 actuellement
- DD représente le jour courant, 02 aujourd'hui
- NN est un simple numéro séquentiel afin de distinguer deux mises à jour
successives dans la même journée : 01 puis 02 puis 03, etc.

Ca se fait qu'une seule fois dans la vie du serveur cette opération ?
Ah non pas du tout : il faut incrémenter le numéro à chaque changement,
ne serait-ce que d'une virgule, dans la configuration de la zone d'un nom
de domaine (ajout d'un nouveau nom, modification d'une adresse IP,
suppression d'un nom, etc.).

Ca sert à quoi ce truc ?
Cela permet à sdns2.ovh.net, ton serveur DNS secondaire, de rester
synchronisé avec le serveur DNS maître, ton VPS.

sdns2.ovh.net compare régulièrement son numéro de série avec celui du VPS:
s'ils sont identiques, il en déduit qu'il a une version à jour des données DNS.

S'il voit qu'il a un numéro de série DNS inférieur à celui du VPS,
il va comprendre qu'une mise à jour à eu lieu et qu'il doit se synchroniser
(= recopier les informations actuelles contenues dans le VPS)

stephaneeybert
02/12/2011, 09h08
Mais comment expliquer, que le sous domaine ifestonie.learnintouch.com que j'ai mis en place de la même manière, et ceci une demi heure avant, lui marche parfaitement ?

stephaneeybert
02/12/2011, 08h51
J'ai donc changé le numéro pour celui que tu m'as indiqué et j'ai fais un reload.

Comment tu as choisi ce numéro et pas un autre ?

Ca se fait qu'une seule fois dans la vie du serveur cette opération ?

Ca sert à quoi ce truc ?

Bon, j'espère que je t'embète pas trop avec mes questions.. :-)

Merci beaucoup en tout cas !!

Bien cool ton support...

cassiopee
01/12/2011, 23h55
Citation Envoyé par stephaneeybert
Cela se fait où cette incrémentation ?
Directement dans le fichier de zone ("/var/bind/pri/learnintouch.com.hosts" dans ton cas)
ou via webmin/ovhm.

Il faut changer le numéro de série et ensuite recharger la config de bind
( "/etc/init.d/named reload") afin que ça soit pris en compte.

stephaneeybert
01/12/2011, 23h49
Effectivement, je ne connais pas cette question de numéros de série.

Cela se fait où cette incrémentation ?

Bonne nuit !

cassiopee
01/12/2011, 23h47
Stop, je crois que j'ai compris : tu as changé/ajouté les enregistrements DNS
sans changer le numéro de série DNS ? (2011111801)

Si oui, ça veut dire que sdns2.ovh.net n'est plus synchronisé avec ton VPS.
(du coup, il n'a pas l'adresse IP correspondant à "katedralskolan.learnintouch.com"
par exemple)

Pour corriger il suffit simplement d'incrémenter le numéro de série DNS
(passer de "2011111801" à "2011120201") puis de patienter que
sdns2.ovh.net se synchronise (ça peut être fait en 5 minutes comme
en deux heures).

Une fois que ça sera bon à ce niveau, il faudra se replonger dans
la configuration d'Apache.

Bonne nuit et à demain

cassiopee
01/12/2011, 23h40
Yep, donc a priori ne reste plus que l'option du parefeu (firewall) configuré
de façon trop stricte. Comment est-il configuré actuellement ?

stephaneeybert
01/12/2011, 23h39
vps13495 stephane # netstat -tanpu | grep ":53"
tcp 0 0 46.105.8.54:53 0.0.0.0:* LISTEN 13248/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 13248/named
udp 0 0 46.105.8.54:53 0.0.0.0:* 13248/named
udp 0 0 127.0.0.1:53 0.0.0.0:* 13248/named
vps13495 stephane #

cassiopee
01/12/2011, 23h36
Ok, c'est bon.

Que donne comme résultat la commande :

Code:
netstat -tanpu | grep ":53"
?

stephaneeybert
01/12/2011, 23h32
vps13495 stephane # named-checkconf -z
pri/localhost.zone:8: NS record '127.0.0.1' appears to be an address
zone localhost/IN: NS '127.0.0.1.localhost' has no address records (A or AAAA)
zone localhost/IN: not loaded due to errors.
_default/localhost/IN: bad zone
zone 127.in-addr.arpa/IN: loaded serial 2002081601
zone learnintouch.com/IN: loaded serial 2011111801
vps13495 stephane #

cassiopee
01/12/2011, 23h30
ok, ça va à peu près (rien de bloquant), que donne comme résultat la commande :

Code:
named-checkconf -z
?

stephaneeybert
01/12/2011, 23h25
options {
directory "/var/bind";
allow-recursion {127.0.0.1;};

// uncomment the following lines to turn on DNS forwarding,
// and change the forwarding ip address(es) :
//forward first;
//forwarders {
// 123.123.123.123;
// 123.123.123.123;
//};

// listen-on-v6 { none; };
// listen-on { 127.0.0.1; };

// to allow only specific hosts to use the DNS server:
//allow-query {
// 127.0.0.1;
//};

// if you have problems and are behind a firewall:
//query-source address * port 53;
pid-file "/var/run/named/named.pid";
};

//zone "COM" { type delegation-only; };
//zone "NET" { type delegation-only; };

zone "." IN {
type hint;
file "named.ca";
};

zone "localhost" IN {
type master;
file "pri/localhost.zone";
allow-update { none; };
notify no;
};

zone "127.in-addr.arpa" IN {
type master;
file "pri/127.zone";
allow-update { none; };
notify no;
};



zone "learnintouch.com" {
type master;
file "/var/bind/pri/learnintouch.com.hosts";
notify-source 46.105.8.54;
};

cassiopee
01/12/2011, 23h21
Citation Envoyé par stephaneeybert
Tu veux son contenu ?
Oui

stephaneeybert
01/12/2011, 23h19
Ma distribution:

Release 2 OVH (Gentoo) - 64 bits (English)

Effectivement, j'ai un fichier: /etc/bind/named.conf

Tu veux son contenu ?

stephaneeybert
01/12/2011, 23h16
La error_log n'affiche rien.

La access_log affiche:

localhost - - [02/Dec/2011:00:14:16 +0100] "GET /ovh-status?auto HTTP/1.1" 200 428
localhost - - [02/Dec/2011:00:14:26 +0100] "GET /ovh-status?auto HTTP/1.1" 200 423
localhost - - [02/Dec/2011:00:14:36 +0100] "GET /ovh-status?auto HTTP/1.1" 200 428
localhost - - [02/Dec/2011:00:14:46 +0100] "GET /ovh-status?auto HTTP/1.1" 200 428

Et la log du site web affiche:

84.52.0.132 - - [02/Dec/2011:00:16:02 +0100] "GET / HTTP/1.1" 200 20 "-" "Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0"
84.52.0.132 - - [02/Dec/2011:00:16:02 +0100] "GET / HTTP/1.1" 200 20 "-" "Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0"

cassiopee
01/12/2011, 23h11
Citation Envoyé par stephaneeybert
Ouh la ! Je ne l'avais pas vu.. :-)

Et effectivement, ça a l'air sérieux.

Mais je ne comprend pas grand chose à ton message malheureusement.

Je vais essayer de voir si Google peut m'éclairer..
Sérieux non, pas tant que ça, c'est simplement de la configuration du serveur DNS
présent dans ton VPS.

(fichier "/etc/named.conf" ou équivalent)

Quelle distribution Linux utilises-tu dans ton VPS ? Une Release 2 d'OVH ?

stephaneeybert
01/12/2011, 23h09
De quelle log tu parles ?

J'en ai quelques unes:

The httpd acces log
/home/log/httpd/access_log

The httpd error log
/home/log/httpd/error_log

Each website has its own access log
/home/log/httpd/learnintouch-access_log

The system log
/home/log/syslog

stephaneeybert
01/12/2011, 23h08
Ouh la ! Je ne l'avais pas vu.. :-)

Et effectivement, ça a l'air sérieux.

Mais je ne comprend pas grand chose à ton message malheureusement.

Je vais essayer de voir si Google peut m'éclairer..

cassiopee
01/12/2011, 23h03
As-tu lu mon message de 19h51 ?

stephaneeybert
01/12/2011, 22h56
J'ai remis mes deux sous domaines que je les avais, et ça marche maintenant.

Se pourrait il qu'un temps de propagation soit aussi nécessaire pour les sous domaines ?

stephaneeybert
01/12/2011, 22h53
@Freemaster

J'ai fais ta suggestion pour mes deux sous domaines, mais au redémarrage de httpd j'ai le warning suivant:

vps13495 stephane # /etc/init.d/apache restart
* Stopping apache2 ...
[Thu Dec 01 23:52:20 2011] [warn] _default_ VirtualHost overlap on port 80, the first has precedence [ ok ]
* Starting apache2 ...
[Thu Dec 01 23:52:21 2011] [warn] _default_ VirtualHost overlap on port 80, the first has precedence

Freemaster
01/12/2011, 19h54
remplace et par :


cela marchera déjà mieux pour le second nom de domaine

cassiopee
01/12/2011, 19h12
La longueur du nom de domaine n'a aucun rapport avec ton problème actuel.

stephaneeybert
01/12/2011, 19h01
Sur un autre serveur, chez un autre hébergeur, j'ai un nom de sous domaine encore plus long:

http://franskainstitutet.thalasoft.com/

Et ça marche très bien.

cassiopee
01/12/2011, 18h51
Ton VPS ne répond pas du tout au niveau DNS, les seules réponses qui peuvent
venir viennent de sdns2.ovh.net qui n'est sans doute plus synchronisé avec ton VPS.

=> Voir dans les logs de ton VPS ce qui ne va pas au niveau serveur DNS.

- ça peut être une directive "allow-query" trop restrictive ("none" ou 127.0.0.1 seulement par exemple)

- ça peut être une directive "listen-on" trop restrictive (127.0.0.1 seulement par exemple)

- ça peut aussi être un problème de parefeu (firewall) trop restrictif (blocage du port 53).

stephaneeybert
01/12/2011, 18h42
Et maintenant, j'ai une autre erreur avec le sous domaine: http://katedral.learnintouch.com

404 Not found.

Pourtant ils ont tous les deux les même setup:

Dans bind:

ifestonie IN A MI.IP.AD.RE
katedral IN A MI.IP.AD.RE

Dans le virtual host:


AddHandler x-httpd-php53 .php
DirectoryIndex index.php
DocumentRoot /home/learnintouch/www/ifestonie
ServerName ifestonie.learnintouch.com
CustomLog logs/ifestonie-access_log combined
SuexecUserGroup learnintouch www

Include /home/learnintouch/engine/setup/url_rewrite.conf




AddHandler x-httpd-php53 .php
DirectoryIndex index.php
DocumentRoot /home/learnintouch/www/katedral
ServerName katedral.learnintouch.com
CustomLog logs/katedral-access_log combined
SuexecUserGroup learnintouch www

Include /home/learnintouch/engine/setup/url_rewrite.conf


stephaneeybert
01/12/2011, 18h40
Ce qui est étrange, c'est que je viens juste de créer un autre sous domaine, qui lui fonctionne très bien:

http://ifestonie.learnintouch.com

stephaneeybert
01/12/2011, 18h28
J'ai un nom de sous domaine comme suit:

http://katedralskolan.learnintouch.com/

Le redémarrage de bind et httpd se fait bien et sans message aucun.

Par contre, l'accès au site web provoque le message suivant dans le navigateur:

Server not found
Firefox can't find the server at katedralskolan.learnintouch.com.

Mais si je change le sous domaine, en le raccourcissant, dans les entrées bind et virtual host, pour avoir à la place:

http://katedral.learnintouch.com

Alors là, le navigateur affiche bien sans problème.

Y a t'il une si petite limite à la taille du nom de sous domaine ?

Et si oui, pourquoi n'y a t'il pas de message au moment du redémarrage de bind et/ou httpd ?

Merci.

Stephane